所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于IP子网划分VLAN示例

配置基于IP子网划分VLAN示例

组网需求

某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

图4-28所示,Switch接收到用户报文有数据、IPTV、语音等多种业务,用户设备的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,以便出口路由器Router能通过不同的VLAN分流到不同的业务服务器上以实现业务互通。

图4-28  基于IP子网划分VLAN组网图

配置思路

采用如下的思路配置基于IP子网划分VLAN:

  1. 创建VLAN并将接口加入VLAN,实现基于IP子网的VLAN通过当前接口。
  2. 使能基于IP子网划分VLAN功能,并关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。

说明:

傻瓜交换机上不需要任何配置。但要使Router能根据不同的VLAN将业务分流到不同的远端服务器,Router上需要进行如下配置:

  • 将连接Switch的接口以Tagged方式加入到所有业务的VLAN中。
  • 将连接各业务服务网络的各接口加入到对应的业务的VLAN中,并配置对应的VLANIF接口。

具体配置请参见Router设备相应的配置手册,本文不再提供。

操作步骤

  1. 创建VLAN

    # 在Switch上创建VLAN100、VLAN200和VLAN300。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 200 300

  2. 配置接口

    # 在Switch上配置接口GE1/0/1为Hybrid类型,分别以Untagged方式加入VLAN100、VLAN200和VLAN300。并使能基于IP子网划分VLAN功能。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100 200 300
    [Switch-GigabitEthernet1/0/1] ip-subnet-vlan enable
    [Switch-GigabitEthernet1/0/1] quit

    # 在Switch上配置接口GE1/0/2为Trunk类型,分别以Tagged方式加入VLAN100、VLAN200和VLAN300。

    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 200 300
    [Switch-GigabitEthernet1/0/2] quit

  3. 配置基于IP子网划分VLAN

    # 在Switch上配置VLAN100与IP地址192.168.1.2/24关联,优先级为2。

    [Switch] vlan 100
    [Switch-vlan100] ip-subnet-vlan 1 ip 192.168.1.2 24 priority 2
    [Switch-vlan100] quit

    # 在Switch上配置VLAN200与IP地址192.168.2.2/24关联,优先级为3。

    [Switch] vlan 200
    [Switch-vlan200] ip-subnet-vlan 1 ip 192.168.2.2 24 priority 3
    [Switch-vlan200] quit

    # 在Switch上配置VLAN300与IP地址192.168.3.2/24关联,优先级为4。

    [Switch] vlan 300
    [Switch-vlan300] ip-subnet-vlan 1 ip 192.168.3.2 24 priority 4
    [Switch-vlan300] quit

  4. 验证配置结果

    Switch上执行以下命令,显示信息如下:

    [Switch] display ip-subnet-vlan vlan all
    ----------------------------------------------------------------
     Vlan    Index   IpAddress           SubnetMask          Priority
     ----------------------------------------------------------------
     100     1       192.168.1.2         255.255.255.0       2
     200     1       192.168.2.2         255.255.255.0       3
     300     1       192.168.3.2         255.255.255.0       4
     ----------------------------------------------------------------
     ip-subnet-vlan count: 3                  total count: 3 

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 100 200 300
    #
    vlan 100
     ip-subnet-vlan 1 ip 192.168.1.2 255.255.255.0 priority 2
    vlan 200
     ip-subnet-vlan 1 ip 192.168.2.2 255.255.255.0 priority 3
    vlan 300
     ip-subnet-vlan 1 ip 192.168.3.2 255.255.255.0 priority 4
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid untagged vlan 100 200 300
     ip-subnet-vlan enable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200 300
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85388

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页