所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VCMP实现VLAN集中管理示例

配置VCMP实现VLAN集中管理示例

组网需求

图13-5所示,某企业分支网络为二层网络,AGG为其汇聚交换机,ACC1~ACC3为接入交换机,其中ACC1用来接入外来访客。企业分支规模越来越大,网络管理员需要在各交换机上配置和维护大量的VLAN信息,工作量大而且容易出错。因此,管理员希望减少VLAN配置和维护的工作量,但外来访客接入分支网络的权限需要限制,管理员希望ACC1上的VLAN能独立配置和维护。

图13-5  配置VCMP实现VLAN集中管理组网图

配置思路

可在此企业分支网络中部署VCMP,将汇聚交换机AGG设置为Server,接入交换机ACC2~ACC3设置为Client,为使ACC1不受VCMP管理,将其设置为Silent。这样,只需在AGG上修改VLAN信息,该信息将自动发送到企业分支网络中的ACC1~ACC3上。ACC2~ACC3会自动同步AGG上的VLAN信息,而ACC1不受VCMP的影响,从而既减少了在多台交换机上修改同一个VLAN信息的工作量,也保证了ACC1的VLAN独立性。

同时,为免去手工设置链路类型的麻烦,配置通过LNP自动协商链路类型。

采用如下的思路配置VCMP:

  1. 配置LNP,实现链路类型自动协商,简化用户配置。
  2. 指定各设备的角色,以确定VCMP管理范围、管理与被管理对象。
  3. 在角色为Server和Client的设备上分别配置VCMP相关参数,包括认证密码、设备ID等,以保证Server和Client间能安全通信和身份识别。
  4. 使能VCMP,使VCMP功能生效。

操作步骤

  1. 配置通过LNP自动协商链路类型

    缺省情况下,全局和接口上的LNP处于使能状态,此时所有接口通过LNP自协商链路类型。

    可以使用命令display lnp summary查看交换机全局和接口上是否使能链路类型自协商功能(分别关注显示信息的“Global LNP”和“link-type(C)”字段),并检查接口的链路类型(关注显示信息的“link-type(N)”字段):
    • 如果全局或接口上没有使能链路类型自协商功能,可执行如下步骤进行配置:

      # 全局使能链路类型自协商功能。ACC1、ACC2和ACC3的配置与AGG类似,不再赘述。

      <HUAWEI> system-view
      [HUAWEI] sysname AGG
      [AGG] undo lnp disable

      # 接口下使能链路类型自协商功能。ACC1、ACC2和ACC3的配置与AGG类似,不再赘述。

      [AGG] interface GigabitEthernet 1/0/1
      [AGG-GigabitEthernet1/0/1] undo port negotiation disable
      [AGG-GigabitEthernet1/0/1] port link-type negotiation-desirable
      [AGG-GigabitEthernet1/0/1] quit
      [AGG] interface GigabitEthernet 1/0/2
      [AGG-GigabitEthernet1/0/2] undo port negotiation disable
      [AGG-GigabitEthernet1/0/2] port link-type negotiation-desirable
      [AGG-GigabitEthernet1/0/2] quit
      [AGG] interface GigabitEthernet 1/0/3
      [AGG-GigabitEthernet1/0/3] undo port negotiation disable
      [AGG-GigabitEthernet1/0/3] port link-type negotiation-desirable
      [AGG-GigabitEthernet1/0/3] quit
    • 如果全局和接口上已使能链路类型自协商功能,但交换机间连接接口的链路类型为Access,为保证VCMP正常运行,可以执行命令port link-type { trunk | hybrid }手工指定接口的链路类型。

  2. 指定各设备的角色

    # 配置AGG的角色为Server。

    [AGG] vcmp role server

    # 配置ACC1的角色为Silent。

    [ACC1] vcmp role silent

    # 配置ACC2的角色为Client。

    [ACC2] vcmp role client

    # 配置ACC3的角色为Client。

    [ACC3] vcmp role client

  3. 在Server和Client上配置VCMP相关参数

    # 在AGG上配置VCMP管理域、设备ID和认证密码。

    [AGG] vcmp domain vd1
    [AGG] vcmp device-id server
    [AGG] vcmp authentication sha2-256 password Hello

    # 在ACC2上配置VCMP管理域和认证密码。

    [ACC2] vcmp domain vd1
    [ACC2] vcmp authentication sha2-256 password Hello

    # 在ACC3上配置VCMP管理域和认证密码。

    [ACC3] vcmp domain vd1
    [ACC3] vcmp authentication sha2-256 password Hello

  4. 使能VCMP功能

    缺省情况下,接口上的VCMP功能已使能,无需再使能。但为避免VCMP报文影响PC终端,可在Client连接PC终端的接口上去使能VCMP功能。

    [ACC2] interface GigabitEthernet 1/0/2
    [ACC2-GigabitEthernet1/0/2] vcmp disable
    [ACC2-GigabitEthernet1/0/2] quit
    [ACC3] interface GigabitEthernet 1/0/2
    [ACC3-GigabitEthernet1/0/2] vcmp disable
    [ACC3-GigabitEthernet1/0/2] quit

  5. 验证配置结果

    上述配置完成后,执行display vcmp status命令可以查看VCMP配置信息,包括VCMP管理域域名、设备角色、设备ID、配置序列号和域密码。

    以AGG显示为例:

    [AGG] display vcmp status
    VCMP information:
    Domain                  : vd1
    Role                    : Server
    Server ID               : server
    Configuration Revision  : 0x239c0000
    Password                : ******

    在AGG上通过命令vlan vlan-id创建VLAN10,分别在ACC1~ACC3上执行命令display vlan summary可以看到ACC2和ACC3同步了AGG上VLAN信息,而ACC1上没有同步AGG上的VLAN信息。

    [AGG] vlan 10
    [AGG-vlan10] quit
    
    [AGG] display vlan summary
    Static VLAN:                                                                    
    Total 2 static VLAN.                                                            
      1 10                                                                          
                                                                                    
    Dynamic VLAN:                                                                   
    Total 0 dynamic VLAN.                                                           
                                                                                    
    Reserved VLAN:                                                                  
    Total 0 reserved VLAN.
    [ACC1] display vlan summary
    Static VLAN:
    Total 1 static VLAN.
      1
    
    Dynamic VLAN:
    Total 0 dynamic VLAN.
    
    Reserved VLAN:
    Total 0 reserved VLAN.
    [ACC2] display vlan summary
    Static VLAN:                                                                    
    Total 2 static VLAN.                                                            
      1 10                                                                          
                                                                                    
    Dynamic VLAN:                                                                   
    Total 0 dynamic VLAN.                                                           
                                                                                    
    Reserved VLAN:                                                                  
    Total 0 reserved VLAN.
    [ACC3] display vlan summary
    Static VLAN:                                                                    
    Total 2 static VLAN.                                                            
      1 10                                                                          
                                                                                    
    Dynamic VLAN:                                                                   
    Total 0 dynamic VLAN.                                                           
                                                                                    
    Reserved VLAN:                                                                  
    Total 0 reserved VLAN.

配置文件

  • AGG的配置文件

    #
    sysname AGG
    #
    vcmp role server
    vcmp domain vd1
    vcmp device-id server
    vcmp authentication sha2-256 password %^%#6dD+>}ffA7*[j2#]0%%GfN#;I}#.lQ2Yfb2b1y"0%^%#
    #
    vlan batch 10
    #
    return
  • ACC1的配置文件

    #
    sysname ACC1
    #
    vcmp role silent
    #
    return
  • ACC2的配置文件

    #
    sysname ACC2
    #
    vcmp domain vd1
    vcmp authentication sha2-256 password %^%#6dD+>}ffA7*[j2#]0%%GfN#;I}#.lQ2Yfb2b1y"0%^%#
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/2
     vcmp disable
    #
    return
  • ACC3的配置文件

    #
    sysname ACC3
    #
    vcmp domain vd1
    vcmp authentication sha2-256 password %^%#6dD+>}ffA7*[j2#]0%%GfN#;I}#.lQ2Yfb2b1y"0%^%#
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/2
     vcmp disable
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84835

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页