所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于VLAN的VLAN Mapping示例(2 to 2)

配置基于VLAN的VLAN Mapping示例(2 to 2)

组网需求

处于不同地理位置的用户,为了可以规划自己的私网VLAN ID,避免和ISP网络中的VLAN ID冲突,同时便于区分不同的用户和业务,采用了QinQ方式传输,即用户报文中带有双层VLAN Tag。但是由于用户报文中的VLAN ID与ISP网络分配的VLAN ID不一致,将导致用户报文被丢弃,从而导致用户通信中断。此时可以在PE侧部署2 to 2的VLAN Mapping功能,将用户网络的双层Tag替换成运营商网络的双层Tag。

图11-8所示的网络中,用户发往ISP网络的报文带有双层VLAN Tag,这双层VLAN Tag与ISP网络提供的VLAN Tag不一致,用户报文无法通过ISP网络,从而导致两端用户无法正常通信,现需要实现Switch5和Switch6中的用户互通。

图11-8  配置基于VLAN的VLAN Mapping功能(2 to 2)组网图

配置思路

采用如下的思路配置基于VLAN的VLAN Mapping功能(2 to 2):

  1. 将连接用户的交换机的接口分别划分到VLAN10和VLAN30。

  2. 在Switch1和Switch4上配置QinQ,使发往ISP网络的用户报文带有双层VLAN Tag。

  3. 在连接ISP网络的交换机上部署2 to 2的VLAN Mapping功能。

操作步骤

  1. 将连接用户的交换机的下行口划分到指定VLAN

    # 配置Switch5。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch5
    [Switch5] vlan 10
    [Switch5-vlan10] quit
    [Switch5] interface gigabitethernet 1/0/1
    [Switch5-GigabitEthernet1/0/1] port link-type access
    [Switch5-GigabitEthernet1/0/1] port default vlan 10
    [Switch5-GigabitEthernet1/0/1] quit
    [Switch5] interface gigabitethernet 1/0/2
    [Switch5-GigabitEthernet1/0/2] port link-type trunk
    [Switch5-GigabitEthernet1/0/2] port trunk allow-pass vlan 10

    # 配置Switch6。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch6
    [Switch6] vlan 30
    [Switch6-vlan30] quit
    [Switch6] interface gigabitethernet 1/0/1
    [Switch6-GigabitEthernet1/0/1] port link-type access
    [Switch6-GigabitEthernet1/0/1] port default vlan 30
    [Switch6-GigabitEthernet1/0/1] quit
    [Switch6] interface gigabitethernet 1/0/2
    [Switch6-GigabitEthernet1/0/2] port link-type trunk
    [Switch6-GigabitEthernet1/0/2] port trunk allow-pass vlan 30

  2. 在Switch1和Switch4上配置QinQ,使发往ISP网络的用户报文带有双层VLAN Tag

    # 配置Switch1。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch1
    [Switch1] vlan 20
    [Switch1-vlan20] quit
    [Switch1] interface gigabitethernet 1/0/1
    [Switch1-GigabitEthernet1/0/1] port link-type hybrid
    [Switch1-GigabitEthernet1/0/1] port hybrid untagged vlan 20
    [Switch1-GigabitEthernet1/0/1] port vlan-stacking vlan 10 stack-vlan 20
    [Switch1-GigabitEthernet1/0/1] quit
    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] port link-type trunk
    [Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [Switch1-GigabitEthernet1/0/2] quit

    # 配置Switch4。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch4
    [Switch4] vlan 40
    [Switch4-vlan40] quit
    [Switch4] interface gigabitethernet 1/0/1
    [Switch4-GigabitEthernet1/0/1] port link-type hybrid
    [Switch4-GigabitEthernet1/0/1] port hybrid untagged vlan 40
    [Switch4-GigabitEthernet1/0/1] port vlan-stacking vlan 30 stack-vlan 40
    [Switch4-GigabitEthernet1/0/1] quit
    [Switch4] interface gigabitethernet 1/0/2
    [Switch4-GigabitEthernet1/0/2] port link-type trunk
    [Switch4-GigabitEthernet1/0/2] port trunk allow-pass vlan 40
    [Switch4-GigabitEthernet1/0/2] quit

  3. 在连接ISP网络的交换机上部署2 to 2的VLAN Mapping功能

    # 配置Switch2。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch2
    [Switch2] interface gigabitethernet 1/0/1
    [Switch2-GigabitEthernet1/0/1] port link-type hybrid
    [Switch2-GigabitEthernet1/0/1] port hybrid tagged vlan 50
    [Switch2-GigabitEthernet1/0/1] port vlan-mapping vlan 20 inner-vlan 10 map-vlan 50 map-inner-vlan 60
    

    # 配置Switch3。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch3
    [Switch3] interface gigabitethernet 1/0/1
    [Switch3-GigabitEthernet1/0/1] port link-type hybrid
    [Switch3-GigabitEthernet1/0/1] port hybrid tagged vlan 50
    [Switch3-GigabitEthernet1/0/1] port vlan-mapping vlan 40 inner-vlan 30 map-vlan 50 map-inner-vlan 60
    

  4. 验证配置结果

    上述配置完成后,Switch5下挂的用户可以与Switch6下挂的用户互通。

配置文件

  • Switch1的配置文件

    #
    sysname Switch1
    #
    vlan batch 20
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid untagged vlan 20
     port vlan-stacking vlan 10 stack-vlan 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Switch2的配置文件

    #
    sysname Switch2
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 50
     port vlan-mapping vlan 20 inner-vlan 10 map-vlan 50 map-inner-vlan 60
    #
    return
  • Switch3的配置文件

    #
    sysname Switch3
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 50
     port vlan-mapping vlan 40 inner-vlan 30 map-vlan 50 map-inner-vlan 60
    #
    return
  • Switch4的配置文件

    #
    sysname Switch4
    #
    vlan batch 40
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid untagged vlan 40
     port vlan-stacking vlan 30 stack-vlan 40
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
  • Switch5的配置文件

    #
    sysname Switch5
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Switch6的配置文件

    #
    sysname Switch6
    #
    vlan batch 30
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:90783

下载量:1017

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页