所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过Loop Detection检测设备所在网络环路示例

配置通过Loop Detection检测设备所在网络环路示例

组网需求

图20-6所示,某企业网络采用二层组网,Switch为其汇聚交换机,各交换机均配置为允许VLAN 10~20通过。由于人员流动性大,导致网络拓扑变动频繁。在变更过程中往往会因操作不慎而使连接或配置错误,进而可能导致VLAN 10~20中产生环路。

环路会引起网络风暴,影响设备及网络正常通信,因此用户希望能够及时检测并处理各VLAN中的环路,防止出现网络风暴。

图20-6  配置通过Loop Detection检测设备所在网络环路示例组网图

配置思路

为防止各VLAN网络中出现环路,需要对VLAN 10~20分别进行环路检测,由于VLAN数超过8个,可以配置Loop Detection功能进行环路检测,同时为防止出现网络风暴需要配置Loop Detection处理动作。由于所有VLAN共用链路,为使某VLAN环路处理不影响其他VLAN的数据转发,配置处理动作为Quitvlan。可采用如下思路配置Loop Detection功能:

  1. Switch的接口GE1/0/0和GE2/0/0上分别启用Loop Detection功能,实现对VLAN 10~20的环路检测。

  2. 在接口GE1/0/0和GE2/0/0上分别配置Loop Detection处理动作和恢复时间,实现Switch在检测到环路后能及时将接口置于受控状态,以防止出现网络风暴,并在环路消失后及时将受控接口恢复到正常状态。

说明:
  • 网络中的其他交换设备上需要配置接口的链路类型为Trunk或Hybrid,并允许相应的VLAN通过,以保证网络内的二层互通。

  • 本示例的配置也可实现交换设备间连接接口的自环检测。

操作步骤

  1. 使能全局的Loop Detection功能

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] loop-detection enable

  2. 使能VLAN的Loop Detection功能

    [Switch] vlan batch 10 to 20
    [Switch] loop-detection enable vlan 10 to 20

  3. 配置Loop Detection检测报文的发送周期

    [Switch] loop-detection interval-time 10

  4. 配置Loop Detection处理动作

    # 打开Loop Detection告警开关。

    [Switch] snmp-agent trap enable feature-name ldttrap

    配置Loop Detection处理动作为Quitvlan。

    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] port link-type hybrid
    [Switch-GigabitEthernet1/0/0] stp disable
    [Switch-GigabitEthernet1/0/0] port hybrid tagged vlan 10 to 20
    [Switch-GigabitEthernet1/0/0] loop-detection mode port-quitvlan
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 2/0/0
    [Switch-GigabitEthernet2/0/0] port link-type hybrid
    [Switch-GigabitEthernet2/0/0] stp disable
    [Switch-GigabitEthernet2/0/0] port hybrid tagged vlan 10 to 20
    [Switch-GigabitEthernet2/0/0] loop-detection mode port-quitvlan
    [Switch-GigabitEthernet2/0/0] quit

  5. 配置受控接口的恢复时间

    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] loop-detection recovery-time 30
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 2/0/0
    [Switch-GigabitEthernet2/0/0] loop-detection recovery-time 30
    [Switch-GigabitEthernet2/0/0] quit

  6. 检查配置结果

    1. 检查环路检测运行情况

      # 配置完成后,执行命令display loop-detection,查看设备上全局环路检测运行情况。

      [Switch] display loop-detection
      Loop Detection is enabled.                                                      
      Detection interval time is 10 seconds.                                          
      Following VLANs enable loop-detection:  
       VLAN  10 to 20                         
      Following ports are blocked for loop:                                           
      NULL                                                                            
      Following ports are shutdown for loop:                                          
      NULL                                                                            
      Following ports are nolearning for loop:                                        
      NULL                                                                            
      Following ports are trapped for loop:                                           
      NULL                                                                            
      Following ports are quitvlan for loop:                                          
      GigabitEthernet1/0/0    Include Vlans: 
      10 11 12 16 19 
      GigabitEthernet2/0/0    Include Vlans: 
      13 14 15 17 18 
      20

      # 查看接口GE1/0/0和GE2/0/0的环路检测运行情况。

      [Switch] display loop-detection interface gigabitethernet 1/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Quitvlan         Quitvlan          30               10
      Quitvlan         Quitvlan          30               11                  
      Quitvlan         Quitvlan          30               12                  
      Normal              Quitvlan            30                  13                  
      Normal              Quitvlan            30                  14                  
      Normal              Quitvlan            30                  15                  
      Quitvlan         Quitvlan          30               16                  
      Normal              Quitvlan            30                  17                  
      Normal              Quitvlan            30                  18                  
      Quitvlan         Quitvlan          30               19                  
      Normal              Quitvlan            30                  20                  
      [Switch] display loop-detection interface gigabitethernet 2/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Normal              Quitvlan            30                  10
      Normal              Quitvlan            30                  11                  
      Normal              Quitvlan            30                  12                  
      Quitvlan         Quitvlan          30               13                  
      Quitvlan         Quitvlan          30               14                  
      Quitvlan         Quitvlan          30               15                  
      Normal              Quitvlan            30                  16                  
      Quitvlan         Quitvlan          30               17                  
      Quitvlan         Quitvlan          30               18                  
      Normal              Quitvlan            30                  19                  
      Quitvlan         Quitvlan          30               20                  

      可以看到,VLAN 10~20使能了Loop Detection功能,接口GE1/0/0和GE2/0/0都有Quitvlan的动作,接口GE1/0/0退出了VLAN 10、11、12、16、19;接口GE2/0/0退出了VLAN 13、14、15、17、18、20。

      说明:

      哪个接口退出哪些VLAN是不定的,但最终接口会退出所有成环VLAN。

    2. 消除网络中的环路(如Shutdown接口GE2/0/0、检查并修复设备间连线连接)后,检查接口GE1/0/0和GE2/0/0是否恢复为正常状态。

      [Switch] display loop-detection interface gigabitethernet 1/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Normal             Quitvlan            30                  10                  
      Normal             Quitvlan            30                  11                  
      Normal             Quitvlan            30                  12                  
      Normal              Quitvlan            30                  13                  
      Normal              Quitvlan            30                  14                  
      Normal              Quitvlan            30                  15                  
      Normal             Quitvlan            30                  16                  
      Normal              Quitvlan            30                  17                  
      Normal              Quitvlan            30                  18                  
      Normal             Quitvlan            30                  19                  
      Normal              Quitvlan            30                  20                  
      [Switch] display loop-detection interface gigabitethernet 2/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Normal              Quitvlan            30                  10                  
      Normal              Quitvlan            30                  11                  
      Normal              Quitvlan            30                  12                  
      Normal             Quitvlan            30                  13                  
      Normal             Quitvlan            30                  14                  
      Normal             Quitvlan            30                  15                  
      Normal              Quitvlan            30                  16                  
      Normal             Quitvlan            30                  17                  
      Normal             Quitvlan            30                  18                  
      Normal              Quitvlan            30                  19                  
      Normal             Quitvlan            30                  20                  

      可以看到,接口GE1/0/0和GE2/0/0已经恢复到正常状态。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10 to 20
#
loop-detection enable
loop-detection interval-time 10
loop-detection enable vlan 10 to 20
#
interface GigabitEthernet1/0/0
 port link-type hybrid
 port hybrid tagged vlan 10 to 20
 stp disable
 loop-detection mode port-quitvlan
 loop-detection recovery-time 30
#
interface GigabitEthernet2/0/0
 port link-type hybrid
 port hybrid tagged vlan 10 to 20
 stp disable
 loop-detection mode port-quitvlan
 loop-detection recovery-time 30
#
snmp-agent
snmp-agent local-engineid 800007DB03020000000211
snmp-agent sys-info version v3 
snmp-agent trap enable feature-name LDTTRAP
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85797

下载量:1003

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页