所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过VLANIF实现同设备VLAN间通信示例

配置通过VLANIF实现同设备VLAN间通信示例

组网需求

企业的不同用户拥有相同的业务,且位于不同的网段。现在相同业务的用户所属的VLAN不相同,需要实现不同VLAN中的用户相互通信。

图4-30所示,User1和User2中拥有相同的业务,但是属于不同的VLAN且位于不同的网段。现需要实现User1和User2互通。

图4-30  配置VLAN间通过VLANIF接口通信组网图

配置思路

采用如下的思路配置VLAN间通过VLANIF接口通信:

  1. 创建VLAN,确定用户所属的VLAN。
  2. 配置接口加入VLAN,允许用户所属的VLAN通过当前接口。
  3. 创建VLANIF接口并配置IP地址,实现三层互通。
说明:

为了成功实现VLAN间互通,VLAN内主机的缺省网关必须是对应VLANIF接口的IP地址。

操作步骤

  1. 配置Switch

    # 创建VLAN

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # 配置接口加入VLAN

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 20
    [Switch-GigabitEthernet1/0/2] quit
    

    # 配置VLANIF接口的IP地址

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.10.10.2 24
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.10.20.2 24
    [Switch-Vlanif20] quit
    

  2. 检查配置结果

    在VLAN10中的User1主机上配置IP地址为10.10.10.3/24,缺省网关为VLANIF10接口的IP地址10.10.10.2/24。

    在VLAN20中的User2主机上配置IP地址为10.10.20.3/24,缺省网关为VLANIF20接口的IP地址10.10.20.2/24。

    配置完成后,VLAN10内的User1与VLAN20内的User2能够相互访问。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10 20
#
interface Vlanif10
 ip address 10.10.10.2 255.255.255.0
#
interface Vlanif20
 ip address 10.10.20.2 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 20
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85177

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页