所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过Loopback Detection检测设备所在网络环路示例

配置通过Loopback Detection检测设备所在网络环路示例

组网需求

图20-9所示,某小型企业采用二层组网,所属VLAN为100。由于人员流动性大,网络拓扑变动频繁,变动往往会因连接错误或配置错误而产生环路,进而导致广播风暴,影响Switch以及整个网络的通信。

用户希望能在Switch上检测到网络中的环路,并希望环路存在时阻塞接口以减小环路对Switch及其所在网络的冲击,环路消失时阻塞接口能自动恢复到正常状态。

图20-9  配置通过Loopback Detection检测设备所在网络环路示例组网图

配置思路

为检测Switch所在网络是否存在环路,可以在Switch上的GE1/0/1GE1/0/2上分别配置Loopback Detection功能;同时本例中,Switch发出的Untagged检测报文会被网络中的其他交换机丢弃,导致检测报文无法送回Switch,进而无法实现环路检测,所以本例必须配置对指定VLAN进行环路检测。配置思路如下:

  1. 使能接口的Loopback Detection功能,并配置对VLAN 100进行环路检测,实现对Switch所在网络的环路检测。
  2. 配置Loopback Detection处理动作和接口自动恢复时间,实现发现环路后,Switch自动阻塞接口以减少环路对其及其所在网络的冲击,环路消失后接口自动恢复。
说明:

网络中的其他交换设备上需要配置接口的链路类型为Trunk或Hybrid,并允许相应的VLAN通过,以保证网络内的二层互通。

操作步骤

  1. 使能接口的Loopback Detection功能

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] loopback-detect enable
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] loopback-detect enable
    [Switch-GigabitEthernet1/0/2] quit

  2. 配置接口对指定VLAN报文进行环路检测

    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 100
    [Switch-GigabitEthernet1/0/1] loopback-detect packet vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid tagged vlan 100
    [Switch-GigabitEthernet1/0/2] loopback-detect packet vlan 100
    [Switch-GigabitEthernet1/0/2] quit

  3. 配置Loopback Detection处理动作和环路消失后接口的自动恢复时间

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] loopback-detect action block
    [Switch-GigabitEthernet1/0/1] loopback-detect recovery-time 30
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] loopback-detect action block
    [Switch-GigabitEthernet1/0/2] loopback-detect recovery-time 30
    [Switch-GigabitEthernet1/0/2] quit

  4. 验证配置结果

    1. 执行命令display loopback-detect检查配置是否成功。

      [Switch] display loopback-detect
      Loopback-detect sending-packet interval:  5   
                                        
      (A): Auto Loopback-detect                                                                                                           
      -----------------------------------------------------------------                                                                   
      Interface                     RecoverTime  Action     Status                                                                        
      -----------------------------------------------------------------
      GigabitEthernet1/0/1          30           block      NORMAL
      GigabitEthernet1/0/2          30           block      NORMAL
      -----------------------------------------------------------------

      上述显示信息表明配置成功。

    2. 配置成功后,等待一段时间(约5秒),执行命令display loopback-detect检查接口GE1/0/1GE1/0/2是否有一个被阻塞。

      [Switch] display loopback-detect
      Loopback-detect sending-packet interval:  5                                     
                                                                                      
      (A): Auto Loopback-detect                                                                                                           
      -----------------------------------------------------------------                                                                   
      Interface                     RecoverTime  Action     Status                                                                        
      -----------------------------------------------------------------
      GigabitEthernet1/0/1          30           block      NORMAL
      GigabitEthernet1/0/2          30           block      BLOCK
      -----------------------------------------------------------------

      上述显示信息表明,接口GE1/0/2被阻塞了。

    3. 关闭接口GE1/0/1,30秒后,执行命令display loopback-detect检查接口GE1/0/2是否恢复为正常状态。

      [Switch] display loopback-detect
      Loopback-detect sending-packet interval:  5                                     
                                                                                      
      (A): Auto Loopback-detect                                                                                                           
      -----------------------------------------------------------------                                                                   
      Interface                     RecoverTime  Action     Status                                                                        
      -----------------------------------------------------------------
      GigabitEthernet1/0/1          30           block      NORMAL
      GigabitEthernet1/0/2          30           block      NORMAL
      -----------------------------------------------------------------

      上述显示信息表明,接口GE1/0/2恢复为正常状态。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 100
 loopback-detect recovery-time 30
 loopback-detect packet vlan 100
 loopback-detect enable
 loopback-detect action block
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid tagged vlan 100
 loopback-detect recovery-time 30
 loopback-detect packet vlan 100
 loopback-detect enable
 loopback-detect action block
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84982

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页