所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置SEP封闭环示例

配置SEP封闭环示例

组网需求

为了进行链路备份,提高网络可靠性,用户通常会使用冗余链路接入上层网络,但是使用冗余链路会在网络中产生环路。环路会造成报文在环路内不断的循环转发,最终导致广播风暴以及MAC地址表不稳定等故障现象,从而导致用户通信质量较差,甚至通信中断。为了阻塞冗余环路,并实现当环网上发生链路故障时,阻塞的冗余链路能够迅速恢复通信,可在环网上部署SEP协议。

该组网的特点是多台二层交换设备组成双归链路接入上级网络,位于上级网络的两台边缘设备之间是直连的方式。此组网位于汇聚层,完成单播业务及组播业务的二层透传功能。通过在汇聚层运行SEP协议,实现冗余保护倒换。

图17-19所示,多台二层交换设备LSW1~LSW5形成环形网络。此种情况下在汇聚层运行SEP协议。

  • 当环网上没有故障链路时,SEP能够消除以太网冗余环路。

  • 当环网上发生链路故障时,SEP能够迅速恢复环网上各节点间通信通路。

图17-19  SEP封闭环组网图

配置思路

采用如下的思路配置SEP封闭环:

  1. 配置SEP基本功能:

    1. LSW1~LSW5上配置Segment ID为1的SEP段和VLAN ID为10的控制VLAN。
    2. 将环网上所有设备加入SEP段并配置LSW1上接口GE1/0/1GE1/0/3加入SEP段的端口角色。

    3. 在端口角色为主边缘端口的设备上配置灵活指定阻塞端口的方式是依据端口优先级,优先阻塞优先级高的端口。

    4. 配置加入SEP段的端口优先级。

      配置LSW3上的端口GE1/0/2优先级最高,SEP段上其他的端口均采用缺省优先级,确保阻塞优先级最高的端口。

    5. 在端口角色为主边缘端口的设备上配置SEP抢占模式是延时抢占。

  2. 配置CE1、LSW1~LSW5二层转发功能。

操作步骤

  1. 配置SEP基本功能

    1. 配置Segment ID为1的SEP段和VLAN ID为10控制VLAN

      # 配置LSW1。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW1
      [LSW1] sep segment 1
      [LSW1-sep-segment1] control-vlan 10
      [LSW1-sep-segment1] protected-instance all
      [LSW1-sep-segment1] quit
      # 配置LSW2。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW2
      [LSW2] sep segment 1
      [LSW2-sep-segment1] control-vlan 10
      [LSW2-sep-segment1] protected-instance all
      [LSW2-sep-segment1] quit
      # 配置LSW3。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW3
      [LSW3] sep segment 1
      [LSW3-sep-segment1] control-vlan 10
      [LSW3-sep-segment1] protected-instance all
      [LSW3-sep-segment1] quit
      # 配置LSW4。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW4
      [LSW4] sep segment 1
      [LSW4-sep-segment1] control-vlan 10
      [LSW4-sep-segment1] protected-instance all
      [LSW4-sep-segment1] quit
      # 配置LSW5。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW5
      [LSW5] sep segment 1
      [LSW5-sep-segment1] control-vlan 10
      [LSW5-sep-segment1] protected-instance all
      [LSW5-sep-segment1] quit
      说明:
      • 控制VLAN的ID必须是没有被创建或使用的,但是控制VLAN创建后,在配置文件会自动显示创建普通VLAN的命令。

      • 每个SEP段必须配置控制VLAN,当接口加入已经配置控制VLAN的SEP段后,接口将自动加入控制VLAN。

    2. 将环网上的设备加入Segment1,并配置端口角色

      说明:

      缺省情况下,二层端口上STP处于使能状态。在将端口加入SEP段之前,请先去使能STP。

      # 配置LSW1的接口GE1/0/1端口角色为主边缘端口、接口GE1/0/3端口角色为副边缘端口。

      [LSW1] interface gigabitethernet 1/0/1
      [LSW1-GigabitEthernet1/0/1] port link-type hybrid
      [LSW1-GigabitEthernet1/0/1] stp disable
      [LSW1-GigabitEthernet1/0/1] sep segment 1 edge primary
      [LSW1-GigabitEthernet1/0/1] quit
      [LSW1] interface gigabitethernet 1/0/3
      [LSW1-GigabitEthernet1/0/3] port link-type hybrid
      [LSW1-GigabitEthernet1/0/3] stp disable
      [LSW1-GigabitEthernet1/0/3] sep segment 1 edge secondary
      [LSW1-GigabitEthernet1/0/3] quit
      # 配置LSW2。
      [LSW2] interface gigabitethernet 1/0/1
      [LSW2-GigabitEthernet1/0/1] port link-type hybrid
      [LSW2-GigabitEthernet1/0/1] stp disable
      [LSW2-GigabitEthernet1/0/1] sep segment 1
      [LSW2-GigabitEthernet1/0/1] quit
      [LSW2] interface gigabitethernet 1/0/2
      [LSW2-GigabitEthernet1/0/2] port link-type hybrid
      [LSW2-GigabitEthernet1/0/2] stp disable
      [LSW2-GigabitEthernet1/0/2] sep segment 1
      [LSW2-GigabitEthernet1/0/2] quit
      # 配置LSW3。
      [LSW3] interface gigabitethernet 1/0/1
      [LSW3-GigabitEthernet1/0/1] port link-type hybrid
      [LSW3-GigabitEthernet1/0/1] stp disable
      [LSW3-GigabitEthernet1/0/1] sep segment 1
      [LSW3-GigabitEthernet1/0/1] quit
      [LSW3] interface gigabitethernet 1/0/2
      [LSW3-GigabitEthernet1/0/2] port link-type hybrid
      [LSW3-GigabitEthernet1/0/2] stp disable
      [LSW3-GigabitEthernet1/0/2] sep segment 1
      [LSW3-GigabitEthernet1/0/2] quit
      # 配置LSW4。
      [LSW4] interface gigabitethernet 1/0/1
      [LSW4-GigabitEthernet1/0/1] port link-type hybrid
      [LSW4-GigabitEthernet1/0/1] stp disable
      [LSW4-GigabitEthernet1/0/1] sep segment 1
      [LSW4-GigabitEthernet1/0/1] quit
      [LSW4] interface gigabitethernet 1/0/2
      [LSW4-GigabitEthernet1/0/2] port link-type hybrid
      [LSW4-GigabitEthernet1/0/2] stp disable
      [LSW4-GigabitEthernet1/0/2] sep segment 1
      [LSW4-GigabitEthernet1/0/2] quit

      # 配置LSW5。

      [LSW5] interface gigabitethernet 1/0/1
      [LSW5-GigabitEthernet1/0/1] port link-type hybrid
      [LSW5-GigabitEthernet1/0/1] stp disable
      [LSW5-GigabitEthernet1/0/1] sep segment 1
      [LSW5-GigabitEthernet1/0/1] quit
      [LSW5] interface gigabitethernet 1/0/3
      [LSW5-GigabitEthernet1/0/3] port link-type hybrid
      [LSW5-GigabitEthernet1/0/3] stp disable
      [LSW5-GigabitEthernet1/0/3] sep segment 1
      [LSW5-GigabitEthernet1/0/3] quit
    3. 配置灵活指定阻塞端口

      # 在主边缘端口位于的设备LSW1上配置阻塞端口的方式为依据端口优先级,优先阻塞优先级高的端口。

      [LSW1] sep segment 1
      [LSW1-sep-segment1] block port optimal
    4. 配置LSW3上的端口GE1/0/2优先级

      [LSW3] interface gigabitethernet 1/0/2
      [LSW3-GigabitEthernet1/0/2] sep segment 1 priority 128
      [LSW3-GigabitEthernet1/0/2] quit
    5. 配置抢占模式

      # 在主边缘端口位于的设备LSW1上配置抢占模式为延时抢占。

      [LSW1-sep-segment1] preempt delay 30
      [LSW1-sep-segment1] quit
      说明:
      • 延时抢占时间没有缺省值,用户必须通过本命令配置延时抢占时间。

      • 当最后一个端口故障恢复后,边缘端口将不再收到故障通告报文。主边缘端口在3秒内没有收到故障通告报文,立即启动延时定时器。延时定时器超时后,SEP段中的节点设备执行阻塞端口抢占。

        所以,在此配置示例中,需要先人为制造端口故障,再恢复端口故障,延时抢占才能成功执行。例如:

        LSW2设备上对接口GE1/0/2执行shutdown命令,模拟端口故障。然后再在端口GE1/0/2执行undo shutdown命令,端口故障恢复。

  2. 配置CE和LSW1~LSW5的二层转发功能

    具体配置过程略。请参考本配置举例中的配置文件。

  3. 验证配置结果

    • LSW3上的接口GE1/0/1执行命令shutdown模拟端口故障,在LSW3上执行命令display sep interface查看接口GE1/0/2能否从阻塞状态放开进入转发状态。

      <LSW3> display sep interface gigabitethernet 1/0/2
      SEP segment 1
      ----------------------------------------------------------------
      Interface           Port Role     Neighbor Status     Port Status
      ----------------------------------------------------------------
      GE1/0/2             common        up                  forwarding 

配置文件

  • LSW1的配置文件

    #
     sysname LSW1
    #
     vlan batch 10 100 200
    #
    sep segment 1
     control-vlan 10
     block port optimal
     preempt delay 30
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1 edge primary
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid tagged vlan 100
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1 edge secondary
    #
    return
  • LSW2的配置文件

    #
     sysname LSW2
    #
     vlan batch 10 100
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • LSW3的配置文件

    #
     sysname LSW3
    #
     vlan batch 10 100
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
     sep segment 1 priority 128
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return
  • LSW4的配置文件

    #
     sysname LSW4
    #
     vlan batch 10 100
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • LSW5的配置文件

    #
     sysname LSW5
    #
     vlan batch 10 100 200
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid tagged vlan 100
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 200
     stp disable
     sep segment 1
    #
    return
  • CE1的配置文件

    #
     sysname CE1
    #
     vlan batch 100
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return

相关信息

视频

如何配置SEP

翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84472

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页