所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置灵活QinQ示例

配置灵活QinQ示例

组网需求

图10-10所示,PC上网用户和VoIP用户通过SwitchA和SwitchB接入运营商网络,通过运营商的网络互相通信。

企业内部为PC分配的企业内部VLAN为100,为VoIP电话分配的内部电话为300。

要求PC上网用户和VoIP用户分别以VLAN2和VLAN3通过运营商网络。

图10-10  配置灵活QinQ组网图

配置思路

采用如下的思路配置灵活QinQ:

  1. SwitchA和SwitchB上创建相关VLAN。

  2. SwitchA和SwitchB上配置接口类型并加入VLAN。

  3. SwitchA和SwitchB的接口上配置灵活QinQ功能。

操作步骤

  1. 创建VLAN

    # 在SwitchA上创建VLAN2、VLAN3,即叠加后的外层VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 2 3

    # 在SwitchB上创建VLAN2、VLAN3,即叠加后的外层VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 2 3

  2. 在接口上配置灵活QinQ

    # 配置SwitchA的接口GE1/0/1

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3
    [SwitchA-GigabitEthernet1/0/1] port vlan-stacking vlan 100 stack-vlan 2
    [SwitchA-GigabitEthernet1/0/1] port vlan-stacking vlan 300 stack-vlan 3
    [SwitchA-GigabitEthernet1/0/1] quit

    # 配置SwitchB的接口GE1/0/1

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3
    [SwitchB-GigabitEthernet1/0/1] port vlan-stacking vlan 100 stack-vlan 2
    [SwitchB-GigabitEthernet1/0/1] port vlan-stacking vlan 300 stack-vlan 3
    [SwitchB-GigabitEthernet1/0/1] quit

  3. 配置其它接口

    # 在SwitchA上配置接口GE1/0/2加入VLAN2、VLAN3。

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3
    [SwitchA-GigabitEthernet1/0/2] quit

    # 在SwitchB上配置接口GE1/0/2加入VLAN2、VLAN3。

    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3
    [SwitchB-GigabitEthernet1/0/2] quit

  4. 验证配置结果

    如果SwitchA、SwitchB上配置正确,则:

    • PC上网用户可以通过运营商网络互相通信。

    • VoIP用户可以通过运营商网络互相通信。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 2 to 3
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid untagged vlan 2 to 3
     port vlan-stacking vlan 100 stack-vlan 2
     port vlan-stacking vlan 300 stack-vlan 3
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 2 to 3
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid untagged vlan 2 to 3
     port vlan-stacking vlan 100 stack-vlan 2
     port vlan-stacking vlan 300 stack-vlan 3
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84013

下载量:999

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页