所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置SEP多实例示例

配置SEP多实例示例

本示例中的组网特点是封闭环路上存在两个SEP段,不同的SEP段处理不同的VLAN业务,实现流量负载负担,并提供链路备份。

组网需求

在普通的SEP组网图中,一个物理环上只能配置一个SEP段,也只能指定一个阻塞点。当SEP段处于完整状态时,阻塞端口会阻止所有的业务数据通过。这样,所有业务数据在SEP段上只能通过一条路径传输,阻塞端口侧的链路空闲,造成带宽浪费。

为了解决带宽浪费问题,并实现负载分担,华为公司实现了SEP多实例。

图17-23  SEP多实例封闭环组网图

图17-23所示,多台二层交换设备LSW1~LSW4形成环形网络接入上层网络。在汇聚层上运行SEP协议。在LSW1~LSW4上配置SEP多实例,通过两个SEP段解决带宽浪费问题,实现负载分担并提供链路备份。

配置思路

采用如下的思路配置SEP多实例封闭环:

  1. 配置SEP基本功能:

    1. LSW1~LSW4上创建两个SEP段和一个控制VLAN。

      不同SEP段可以使用相同ID的控制VLAN。

    2. 配置SEP保护实例,并将实例与用户VLAN映射,确保端口的转发状态变化或拓扑变化只影响对应的VLAN,而不影响其他VLAN,保证业务数据可靠传输。
    3. 将环网上所有设备加入SEP段,并配置LSW1上接口GE1/0/1是主边缘端口、GE1/0/3是副边缘端口。

    4. 在端口角色为主边缘端口的设备上配置端口阻塞方式,灵活指定阻塞端口。
    5. 配置SEP抢占模式,确保故障恢复时用户指定的阻塞端口生效。
  2. 配置CE1、CE2、LSW1~LSW4二层转发功能。

操作步骤

  1. 创建SEP段和控制VLAN

    • 配置Segment ID为1的SEP段和VLAN ID为10的控制VLAN

      # 配置LSW1。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW1
      [LSW1] sep segment 1
      [LSW1-sep-segment1] control-vlan 10
      [LSW1-sep-segment1] quit
      # 配置LSW2。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW2
      [LSW2] sep segment1
      [LSW2-sep-segment1] control-vlan 10
      [LSW2-sep-segment1] quit
      # 配置LSW3。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW3
      [LSW3] sep segment 1
      [LSW3-sep-segment1] control-vlan 10
      [LSW3-sep-segment1] quit
      # 配置LSW4。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW4
      [LSW4] sep segment 1
      [LSW4-sep-segment1] control-vlan 10
      [LSW4-sep-segment1] quit
    • 配置Segment ID为2的SEP段和VLAN ID为10的控制VLAN

      # 配置LSW1。
      [LSW1] sep segment 2
      [LSW1-sep-segment2] control-vlan 10
      [LSW1-sep-segment2] quit
      # 配置LSW2。
      [LSW2] sep segment2
      [LSW2-sep-segment2] control-vlan 10
      [LSW2-sep-segment2] quit
      # 配置LSW3。
      [LSW3] sep segment 2
      [LSW3-sep-segment2] control-vlan 10
      [LSW3-sep-segment2] quit
      # 配置LSW4。
      [LSW4] sep segment 2
      [LSW4-sep-segment2] control-vlan 10
      [LSW4-sep-segment2] quit
    说明:
    • 控制VLAN的ID必须是没有被创建或使用的。

    • 控制VLAN成功创建后,配置文件会自动显示创建普通VLAN的命令。

    • 每个SEP段必须配置控制VLAN,当接口加入已经配置控制VLAN的SEP段后,接口将自动加入控制VLAN。不需使用命令port trunk allow-pass vlan配置,该命令会自动显示在加入SEP段的接口配置文件中。

  2. 配置SEP段保护实例,并将实例与用户VLAN映射。

    # 配置LSW1。
    [LSW1] vlan batch 100 to 500
    [LSW1] sep segment 1
    [LSW1-sep-segment1] protected-instance 1
    [LSW1-sep-segment1] quit
    [LSW1] sep segment 2
    [LSW1-sep-segment2] protected-instance 2
    [LSW1-sep-segment2] quit
    [LSW1] stp region-configuration
    [LSW1-mst-region] instance 1 vlan 100 to 300
    [LSW1-mst-region] instance 2 vlan 301 to 500
    [LSW1-mst-region] active region-configuration
    [LSW1-mst-region] quit

    LSW2~LSW4配置略。LSW2~LSW4配置与LSW1配置类似,具体配置请参见本示例配置文件。

  3. 将环网上的设备加入SEP段,并配置端口角色

    说明:

    缺省情况下,二层端口上STP处于使能状态。在将端口加入SEP段之前,请先去使能STP。

    # 配置LSW1的端口GE1/0/1端口角色为主边缘端口,GE1/0/3端口角色为副边缘端口。

    [LSW1] interface gigabitethernet 1/0/1
    [LSW1-GigabitEthernet1/0/1] port link-type hybrid
    [LSW1-GigabitEthernet1/0/1] stp disable
    [LSW1-GigabitEthernet1/0/1] sep segment 1 edge primary
    [LSW1-GigabitEthernet1/0/1] sep segment 2 edge primary
    [LSW1-GigabitEthernet1/0/1] quit
    [LSW1] interface gigabitethernet 1/0/3
    [LSW1-GigabitEthernet1/0/3] port link-type hybrid
    [LSW1-GigabitEthernet1/0/3] stp disable
    [LSW1-GigabitEthernet1/0/3] sep segment 1 edge secondary
    [LSW1-GigabitEthernet1/0/3] sep segment 2 edge secondary
    [LSW1-GigabitEthernet1/0/3] quit
    # 配置LSW2。
    [LSW2] interface gigabitethernet 1/0/1
    [LSW2-GigabitEthernet1/0/1] port link-type hybrid
    [LSW2-GigabitEthernet1/0/1] stp disable
    [LSW2-GigabitEthernet1/0/1] sep segment 1
    [LSW2-GigabitEthernet1/0/1] sep segment 2
    [LSW2-GigabitEthernet1/0/1] quit
    [LSW2] interface gigabitethernet 1/0/2
    [LSW2-GigabitEthernet1/0/2] port link-type hybrid
    [LSW2-GigabitEthernet1/0/2] stp disable
    [LSW2-GigabitEthernet1/0/2] sep segment 1
    [LSW2-GigabitEthernet1/0/2] sep segment 2
    [LSW2-GigabitEthernet1/0/2] quit
    # 配置LSW3。
    [LSW3] interface gigabitethernet 1/0/1
    [LSW3-GigabitEthernet1/0/1] port link-type hybrid
    [LSW3-GigabitEthernet1/0/1] stp disable
    [LSW3-GigabitEthernet1/0/1] sep segment 1
    [LSW3-GigabitEthernet1/0/1] sep segment 2
    [LSW3-GigabitEthernet1/0/1] quit
    [LSW3] interface gigabitethernet 1/0/2
    [LSW3-GigabitEthernet1/0/2] port link-type hybrid
    [LSW3-GigabitEthernet1/0/2] stp disable
    [LSW3-GigabitEthernet1/0/2] sep segment 1
    [LSW3-GigabitEthernet1/0/2] sep segment 2
    [LSW3-GigabitEthernet1/0/2] quit

    # 配置LSW4。

    [LSW4] interface gigabitethernet 1/0/1
    [LSW4-GigabitEthernet1/0/1] port link-type hybrid
    [LSW4-GigabitEthernet1/0/1] stp disable
    [LSW4-GigabitEthernet1/0/1] sep segment 1
    [LSW4-GigabitEthernet1/0/1] sep segment 2
    [LSW4-GigabitEthernet1/0/1] quit
    [LSW4] interface gigabitethernet 1/0/3
    [LSW4-GigabitEthernet1/0/3] port link-type hybrid
    [LSW4-GigabitEthernet1/0/3] stp disable
    [LSW4-GigabitEthernet1/0/3] sep segment 1
    [LSW4-GigabitEthernet1/0/3] sep segment 2
    [LSW4-GigabitEthernet1/0/3] quit

  4. 灵活指定阻塞端口

    # 在主边缘端口所在的设备LSW1上配置阻塞端口的方式是系统名+端口名,抢占模式是延时抢占。
    [LSW1] sep segment 1
    [LSW1-sep-segment1] block port sysname LSW3 interface gigabitethernet 1/0/1
    [LSW1-sep-segment1] preempt delay 15
    [LSW1-sep-segment1] quit
    [LSW1] sep segment 2
    [LSW1-sep-segment2] block port sysname LSW2 interface gigabitethernet 1/0/1
    [LSW1-sep-segment2] preempt delay 15
    [LSW1-sep-segment2] quit
    说明:
    • 在本配置举例中,需要模拟端口故障然后恢复来完成延时抢占,为保证延时抢占功能在两个SEP段上都生效,需模拟位于两个SEP段上的端口故障。比如:
      • 在SEP segment 1上,在LSW2的GE1/0/1接口视图下执行命令shutdown来模拟端口故障,然后执行命令undo shutdown来模拟端口故障恢复。
      • 在SEP segment 2上,在LSW3的GE1/0/1接口视图下执行命令shutdown来模拟端口故障,然后执行命令undo shutdown来模拟端口故障恢复。

  5. 配置CE1、CE2、LSW1~LSW4的二层转发功能

    具体配置过程略。请参考本配置举例中的配置文件。

  6. 验证配置结果

    模拟故障产生情况下,查看阻塞端口是否能够从阻塞状态放开进入转发状态。

    LSW2上的端口GE1/0/1 shutdown模拟端口故障。

    LSW3上执行命令display sep interface,查看在Segment 1中端口GE1/0/1能否从阻塞状态放开进入转发状态。

    [LSW3] display sep interface gigabitethernet 1/0/1
    SEP segment 1
    ----------------------------------------------------------------
    Interface           Port Role     Neighbor Status     Port Status
    ----------------------------------------------------------------
    GE1/0/1             common        up                  forwarding
    SEP segment 2
    ----------------------------------------------------------------
    Interface           Port Role     Neighbor Status     Port Status
    ----------------------------------------------------------------
    GE1/0/1             common        up                  forwarding

    从上述表项可以发现GE1/0/1的状态可以成功从阻塞状态进入转发状态,Segment 1中转发路径变化并没有影响Segment 2的转发路径。

配置文件

  • LSW1的配置文件

    #
    sysname LSW1
    #
    vlan batch 10 100 to 500
    #
    stp region-configuration
      instance 1 vlan 100 to 300
      instance 2 vlan 301 to 500
      active region-configuration
    #
    sep segment 1
     control-vlan 10
     block port sysname LSW3 interface GigabitEthernet1/0/1
     preempt delay 15
     protected-instance 1
    sep segment 2
     control-vlan 10
     block port sysname LSW2 interface GigabitEthernet1/0/1
     preempt delay 15
     protected-instance 2
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1 edge primary
     sep segment 2 edge primary
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1 edge secondary
     sep segment 2 edge secondary
    #
    return
  • LSW2的配置文件

    #
    sysname LSW2
    #
    vlan batch 10 100 to 500
    #
    stp region-configuration
      instance 1 vlan 100 to 300
      instance 2 vlan 301 to 500
      active region-configuration
    #
    sep segment 1
     control-vlan 10
     protected-instance 1
    sep segment 2
     control-vlan 10
     protected-instance 2
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1
     sep segment 2
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1
     sep segment 2
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 100 to 300
    #
    return
  • LSW3的配置文件

    #
    sysname LSW3
    #
    vlan batch 10 100 to 500
    #
    stp region-configuration
      instance 1 vlan 100 to 300
      instance 2 vlan 301 to 500
      active region-configuration
    #
    sep segment 1
     control-vlan 10
     protected-instance 1
    sep segment 2
     control-vlan 10
     protected-instance 2
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1
     sep segment 2
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1
     sep segment 2
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 301 to 500
    #
    return
  • LSW4的配置文件

    #
    sysname LSW4
    #
    vlan batch 10 60 100 to 500
    #
    stp region-configuration
      instance 1 vlan 100 to 300
      instance 2 vlan 301 to 500
      active region-configuration
    #
    sep segment 1
     control-vlan 10
     protected-instance 1
    sep segment 2
     control-vlan 10
     protected-instance 2
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1
     sep segment 2
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 10 100 to 500
     stp disable
     sep segment 1
     sep segment 2
    #
    return
  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 100 to 300
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 100 to 300
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    vlan batch 301 to 500
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 301 to 500
    #
    return

相关信息

视频

如何配置SEP

翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84981

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页