所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于MAC地址划分VLAN示例(交换机下挂二层交换设备)

配置基于MAC地址划分VLAN示例(交换机下挂二层交换设备)

组网需求

某个公司的网络中,网络管理者将不同部门的员工划分到不同VLAN。各个部门的PC通过二层交换机接入公司网络。为了提高部门内的信息安全,要求只有本部门员工的PC才可以相互访问。

图4-27所示,PC1和PC2为同一部门员工的PC,通过VLAN 10访问公司网络并相互访问。PC3和PC4为另一个部门员工的PC,通过VLAN 20访问公司网络并相互访问。两个部门的员工,相互之间不能访问。即使PC移动到同一区域,也不能相互访问。

图4-27  配置基于MAC地址的VLAN划分组网图

配置思路

采用如下的思路配置基于MAC地址的VLAN划分:

  1. 创建VLAN,确定员工所属的VLAN。

  2. 配置PC的MAC地址与VLAN关联,实现根据报文中的源MAC地址划分VLAN。

  3. 配置各接口以正确的方式加入VLAN,实现二层转发。

操作步骤

  1. 配置Switch1

    # 创建VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch1
    [Switch1] vlan batch 10 20
    

    # 配置PC1和PC2的MAC地址与VLAN 10关联,PC3和PC4的MAC地址与VLAN 20关联。

    [Switch1] vlan 10
    [Switch1-vlan10] mac-vlan mac-address 11-11-11
    [Switch1-vlan10] mac-vlan mac-address 22-22-22
    [Switch1-vlan10] quit
    [Switch1] vlan 20
    [Switch1-vlan20] mac-vlan mac-address 33-33-33
    [Switch1-vlan20] mac-vlan mac-address 44-44-44
    [Switch1-vlan20] quit
    

    # 使能接口基于MAC地址划分VLAN功能。

    [Switch1] interface gigabitethernet 1/0/1
    [Switch1-GigabitEthernet1/0/1] mac-vlan enable
    [Switch1-GigabitEthernet1/0/1] quit
    

    # 配置连接二层交换机的接口GE1/0/1,以Untagged方式MAC地址关联的VLAN。

    [Switch1] interface gigabitethernet 1/0/1
    [Switch1-GigabitEthernet1/0/1] port link-type hybrid
    [Switch1-GigabitEthernet1/0/1] port hybrid untagged vlan 10 20
    [Switch1-GigabitEthernet1/0/1] quit
    

    # 配置连接公司网络的接口GE1/0/2,透传MAC地址关联的VLAN。

    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] port link-type trunk
    [Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 10 20
    [Switch1-GigabitEthernet1/0/2] quit
    

  2. 检查配置结果

    • PC1和PC2通过VLAN 10访问公司网络,PC3和PC4通过VLAN 20访问公司网络。
    • PC1、PC2、PC3和PC4如换成其他外来人员的PC则不能访问公司网络。

配置文件

Switch1的配置文件

#
sysname Switch1
#
vlan batch 10 20
#
vlan 10
 mac-vlan mac-address 0011-0011-0011 priority 0
 mac-vlan mac-address 0022-0022-0022 priority 0
vlan 20
 mac-vlan mac-address 0033-0033-0033 priority 0
 mac-vlan mac-address 0044-0044-0044 priority 0
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid untagged vlan 10 20
 mac-vlan enable
#
interface GigabitEthernet1/0/2
 port link-type trunk                                                           
 port trunk allow-pass vlan 10 20
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84635

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页