所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于VLAN的MAC地址学习限制示例

配置基于VLAN的MAC地址学习限制示例

组网需求

图2-16所示,用户网络1通过LSW1与Switch相连,Switch的接口为GE1/0/1。用户网络2通过LSW2与Switch相连,Switch的接口为GE1/0/2GE1/0/1GE1/0/2同属于VLAN2。为控制接入用户数,对VLAN2进行MAC地址学习的限制。

图2-16  配置基于VLAN的MAC地址学习限制组网图

配置思路

采用如下的思路配置基于VLAN的MAC地址学习限制:

  1. 创建VLAN,并将接口加入到VLAN中,实现二层转发功能。

  2. 配置VLAN的MAC地址学习限制,实现防止MAC地址攻击,控制接入用户数量。

操作步骤

  1. 配置MAC地址学习限制

    # 将GigabitEthernet1/0/1GigabitEthernet1/0/2加入VLAN2。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 2
    [Switch-vlan2] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 2
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 2
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 2
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 2
    [Switch-GigabitEthernet1/0/2] quit
    

    # 在VLAN2上配置MAC地址学习限制规则:最多可以学习100个MAC地址,超过最大MAC地址学习数量的报文继续转发但不加入MAC地址表,并进行告警提示。

    [Switch] vlan 2
    [Switch-vlan2] mac-limit maximum 100 action forward alarm enable
    [Switch-vlan2] return
    

  2. 验证配置结果

    # 在任意视图下执行display mac-limit命令,查看MAC地址学习限制规则是否配置成功。

    <Switch> display mac-limit
    MAC limit is enabled
    Total MAC limit rule count : 1
    
    PORT                 VLAN/VSI      SLOT Maximum Rate(ms) Action  Alarm
    ----------------------------------------------------------------------------
    -                    2                -    100     -     forward enable 
    

配置文件

以下仅给出Switch的配置文件。

#
sysname Switch
#
vlan batch 2
#
vlan 2
 mac-limit maximum 100 action forward
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid pvid vlan 2
 port hybrid untagged vlan 2
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid pvid vlan 2
 port hybrid untagged vlan 2
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85360

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页