所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MSTP功能示例

配置MSTP功能示例

组网需求

在一个复杂的网络中,由于冗余备份的需要,网络规划者一般都倾向于在设备之间部署多条物理链路,其中一条作为主用链路,其他作为备份链路。这样就难免会形成环路,若网络中存在环路,可能会引起广播风暴和MAC表项被破坏。为此,可以在网络中部署MSTP协议预防环路。MSTP可阻塞二层网络中的冗余链路,将网络修剪成树状,达到消除环路的目的。

图15-18所示,SwitchA、SwitchB、SwitchC和SwitchD都运行MSTP。为实现VLAN2~VLAN10和VLAN11~VLAN20的流量负载分担,MSTP引入了多实例。MSTP可设置VLAN映射表,把VLAN和生成树实例相关联。

图15-18  配置MSTP功能组网图

配置思路

采用以下思路配置MSTP功能:

  1. 在处于环形网络中的交换设备上配置MSTP基本功能。与PC相连的端口不用参与MSTP计算,将其设置为边缘端口。

  2. 配置保护功能,实现对设备或链路的保护。例如:在各实例的根桥设备指定端口配置根保护功能。

    说明:

    设备配置根保护功能后,如果根桥和备份根桥之间的链路down了,则配置根保护的端口状态会因为根保护功能生效直接变成discarding状态。

    为了提高可靠性,建议根桥和备份根桥之间的链路绑定Eth-Trunk。

  3. 配置设备的二层转发功能。

操作步骤

  1. 配置MSTP基本功能

    1. 配置SwitchA、SwitchB、SwitchC和SwitchD到域名为RG1的域内,创建实例MSTI1和实例MSTI2

      说明:
      当两台交换设备的以下配置都相同时,这两台交换设备属于同一个MST域。
      • MST域的域名。

      • 多生成树实例和VLAN的映射关系。

      • MST域的修订级别。

      # 配置SwitchA的MST域。

      <HUAWEI> system-view
      [HUAWEI] sysname SwitchA
      [SwitchA] stp region-configuration
      [SwitchA-mst-region] region-name RG1
      [SwitchA-mst-region] instance 1 vlan 2 to 10
      [SwitchA-mst-region] instance 2 vlan 11 to 20
      [SwitchA-mst-region] active region-configuration
      [SwitchA-mst-region] quit

      # 配置SwitchB的MST域。

      <HUAWEI> system-view
      [HUAWEI] sysname SwitchB
      [SwitchB] stp region-configuration
      [SwitchB-mst-region] region-name RG1
      [SwitchB-mst-region] instance 1 vlan 2 to 10
      [SwitchB-mst-region] instance 2 vlan 11 to 20
      [SwitchB-mst-region] active region-configuration
      [SwitchB-mst-region] quit

      # 配置SwitchC的MST域。

      <HUAWEI> system-view
      [HUAWEI] sysname SwitchC
      [SwitchC] stp region-configuration
      [SwitchC-mst-region] region-name RG1
      [SwitchC-mst-region] instance 1 vlan 2 to 10
      [SwitchC-mst-region] instance 2 vlan 11 to 20
      [SwitchC-mst-region] active region-configuration
      [SwitchC-mst-region] quit

      # 配置SwitchD的MST域。

      <HUAWEI> system-view
      [HUAWEI] sysname SwitchD
      [SwitchD] stp region-configuration
      [SwitchD-mst-region] region-name RG1
      [SwitchD-mst-region] instance 1 vlan 2 to 10
      [SwitchD-mst-region] instance 2 vlan 11 to 20
      [SwitchD-mst-region] active region-configuration
      [SwitchD-mst-region] quit
    2. 在域RG1内,配置MSTI1与MSTI2的根桥与备份根桥

      • 配置MSTI1的根桥与备份根桥

        # 配置SwitchA为MSTI1的根桥。

        [SwitchA] stp instance 1 root primary
        

        # 配置SwitchB为MSTI1的备份根桥。

        [SwitchB] stp instance 1 root secondary
        
      • 配置MSTI2的根桥与备份根桥

        # 配置SwitchB为MSTI2的根桥。

        [SwitchB] stp instance 2 root primary
        

        # 配置SwitchA为MSTI2的备份根桥。

        [SwitchA] stp instance 2 root secondary
        
    3. 配置实例MSTI1和MSTI2中将要被阻塞端口的路径开销值大于缺省值

      说明:
      • 端口路径开销值取值范围由路径开销计算方法决定,这里选择使用华为计算方法为例,配置实例MSTI1和MSTI2中将被阻塞端口的路径开销值为20000。

      • 同一网络内所有交换设备的端口路径开销应使用相同的计算方法。

      # 配置SwitchA的端口路径开销值的计算方法为华为计算方法。

      [SwitchA] stp pathcost-standard legacy
      

      # 配置SwitchB的端口路径开销计算方法为华为计算方法。

      [SwitchB] stp pathcost-standard legacy
      

      # 配置SwitchC的端口路径开销计算方法为华为计算方法,将端口GE1/0/2在实例MSTI2中的路径开销值配置为20000。

      [SwitchC] stp pathcost-standard legacy
      [SwitchC] interface gigabitethernet 1/0/2
      [SwitchC-GigabitEthernet1/0/2] stp instance 2 cost 20000
      [SwitchC-GigabitEthernet1/0/2] quit

      # 配置SwitchD的端口路径开销计算方法为华为计算方法,将端口GE1/0/2在实例MSTI1中的路径开销值配置为20000。

      [SwitchD] stp pathcost-standard legacy
      [SwitchD] interface gigabitethernet 1/0/2
      [SwitchD-GigabitEthernet1/0/2] stp instance 1 cost 20000
      [SwitchD-GigabitEthernet1/0/2] quit
    4. 使能MSTP,实现破除环路

      • 设备全局使能MSTP

        # 在SwitchA上启动MSTP。

        [SwitchA] stp enable
        

        # 在SwitchB上启动MSTP。

        [SwitchB] stp enable
        

        # 在SwitchC上启动MSTP。

        [SwitchC] stp enable
        

        # 在SwitchD上启动MSTP。

        [SwitchD] stp enable
        
      • 将与终端相连的端口设置为边缘端口

        # 配置SwitchC端口GE1/0/1为边缘端口。

        [SwitchC] interface gigabitethernet 1/0/1
        [SwitchC-GigabitEthernet1/0/1] stp edged-port enable
        [SwitchC-GigabitEthernet1/0/1] quit

        (可选)配置SwitchC的BPDU保护功能。

        [SwitchC] stp bpdu-protection

        # 配置SwitchD端口GE1/0/1为边缘端口。

        [SwitchD] interface gigabitethernet 1/0/1
        [SwitchD-GigabitEthernet1/0/1] stp edged-port enable
        [SwitchD-GigabitEthernet1/0/1] quit

        (可选)配置SwitchD的BPDU保护功能。

        [SwitchD] stp bpdu-protection
        说明:
        如果与边缘端口相连的是使能了STP功能的网络设备,配置BPDU保护功能后,如果边缘端口收到BPDU报文,边缘端口将会被shutdown,边缘端口属性不变。

  2. 配置保护功能,如在各实例的根桥设备的指定端口配置根保护功能

    # 在SwitchA端口GE1/0/1上启动根保护。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] stp root-protection
    [SwitchA-GigabitEthernet1/0/1] quit

    # 在SwitchB端口GE1/0/1上启动根保护。

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] stp root-protection
    [SwitchB-GigabitEthernet1/0/1] quit

  3. 配置处于环网中的设备的二层转发功能

    • 在交换设备SwitchA、SwitchB、SwitchC和SwitchD上创建VLAN2~20

      # 在SwitchA上创建VLAN2~20。

      [SwitchA] vlan batch 2 to 20
      

      # 在SwitchB上创建VLAN2~20。

      [SwitchB] vlan batch 2 to 20
      

      # 在SwitchC上创建VLAN2~20。

      [SwitchC] vlan batch 2 to 20
      

      # 在SwitchD上创建VLAN2~20。

      [SwitchD] vlan batch 2 to 20
      
    • 将交换设备上接入环路中的端口加入VLAN

      # 将SwitchA端口GE1/0/1加入VLAN。

      [SwitchA] interface gigabitethernet 1/0/1
      [SwitchA-GigabitEthernet1/0/1] port link-type trunk
      [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 20
      [SwitchA-GigabitEthernet1/0/1] quit

      # 将SwitchA端口Eth-Trunk1加入VLAN。

      [SwitchA] interface Eth-Trunk 1
      [SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/2
      [SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/3
      [SwitchA-Eth-Trunk1] port link-type trunk
      [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 2 to 20
      [SwitchA-Eth-Trunk1] quit

      # 将SwitchB端口GE1/0/1加入VLAN。

      [SwitchB] interface gigabitethernet 1/0/1
      [SwitchB-GigabitEthernet1/0/1] port link-type trunk
      [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 20
      [SwitchB-GigabitEthernet1/0/1] quit

      # 将SwitchB端口Eth-trunk1加入VLAN。

      [SwitchB] interface Eth-Trunk 1
      [SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/2
      [SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/3
      [SwitchB-Eth-Trunk1] port link-type trunk
      [SwitchB-Eth-Trunk1] port trunk allow-pass vlan 2 to 20
      [SwitchB-Eth-Trunk1] quit

      # 将SwitchC端口GE1/0/1加入VLAN。

      [SwitchC] interface gigabitethernet 1/0/1
      [SwitchC-GigabitEthernet1/0/1] port link-type access
      [SwitchC-GigabitEthernet1/0/1] port default vlan 2
      [SwitchC-GigabitEthernet1/0/1] quit

      # 将SwitchC端口GE1/0/2加入VLAN。

      [SwitchC] interface gigabitethernet 1/0/2
      [SwitchC-GigabitEthernet1/0/2] port link-type trunk
      [SwitchC-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 20
      [SwitchC-GigabitEthernet1/0/2] quit

      # 将SwitchC端口GE1/0/3加入VLAN。

      [SwitchC] interface gigabitethernet 1/0/3
      [SwitchC-GigabitEthernet1/0/3] port link-type trunk
      [SwitchC-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 to 20
      [SwitchC-GigabitEthernet1/0/3] quit

      # 将SwitchD端口GE1/0/1加入VLAN。

      [SwitchD] interface gigabitethernet 1/0/1
      [SwitchD-GigabitEthernet1/0/1] port link-type access
      [SwitchD-GigabitEthernet1/0/1] port default vlan 11
      [SwitchD-GigabitEthernet1/0/1] quit

      # 将SwitchD端口GE1/0/2加入VLAN。

      [SwitchD] interface gigabitethernet 1/0/2
      [SwitchD-GigabitEthernet1/0/2] port link-type trunk
      [SwitchD-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 20
      [SwitchD-GigabitEthernet1/0/2] quit

      # 将SwitchD端口GE1/0/3加入VLAN。

      [SwitchD] interface gigabitethernet 1/0/3
      [SwitchD-GigabitEthernet1/0/3] port link-type trunk
      [SwitchD-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 to 20
      [SwitchD-GigabitEthernet1/0/3] quit

  4. 验证配置结果

    在网络计算稳定后,执行以下操作,验证配置结果。

    说明:

    本配置举例以实例1和实例2为例,因此不用关注实例0中端口的状态。

    # 在SwitchA上执行display stp brief命令,查看端口状态和端口的保护类型,结果如下:

    [SwitchA] display stp brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       0    Eth-Trunk1                  DESI  FORWARDING      NONE
       1    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       1    Eth-Trunk1                  DESI  FORWARDING      NONE
       2    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       2    Eth-Trunk1                  ROOT  FORWARDING      NONE

    在MSTI1中,由于SwitchA是根桥,SwitchA的端口Eth-Trunk1和GE1/0/1成为指定端口。在MSTI2中,SwitchA的端口GE1/0/1成为指定端口,端口Eth-Trunk1成为根端口。

    # 在SwitchB上执行display stp brief命令,结果如下:

    [SwitchB] display stp brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       0    Eth-Trunk1                  ROOT  FORWARDING      NONE
       1    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       1    Eth-Trunk1                  ROOT  FORWARDING      NONE
       2    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       2    Eth-Trunk1                  DESI  FORWARDING      NONE

    在MSTI2中,由于SwitchB是根桥,端口GE1/0/1和Eth-Trunk1在MSTI2中成为指定端口。在MSTI1中,SwitchB的端口GE1/0/1成为指定端口,端口Eth-Trunk1成为根端口。

    # 在SwitchC上执行display stp interface brief命令,结果如下:

    [SwitchC] display stp interface gigabitethernet 1/0/3 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       1    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       2    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
    [SwitchC] display stp interface gigabitethernet 1/0/2 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/2        DESI  FORWARDING      NONE
       1    GigabitEthernet1/0/2        DESI  FORWARDING      NONE
       2    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE

    SwitchC的端口GE1/0/3在MSTI1和MSTI2中为根端口。SwitchC的另一个端口GE1/0/2,在MSTI2中被阻塞,在MSTI1中被计算为指定端口。

    # 在SwitchD上执行display stp interface brief命令,结果如下:

    [SwitchD] display stp interface gigabitethernet 1/0/3 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       1    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       2    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
    [SwitchD] display stp interface gigabitethernet 1/0/2 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE
       1    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE
       2    GigabitEthernet1/0/2        DESI  FORWARDING      NONE

    SwitchD的端口GE1/0/3在MSTI1和MSTI2中为根端口。SwitchD的另一个端口GE1/0/2,在MSTI1中被阻塞,在MSTI2中被计算为指定端口。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 2 to 20
    #
    stp instance 1 root primary
    stp instance 2 root secondary
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp root-protection
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 2 to 20
    #
    stp instance 1 root secondary
    stp instance 2 root primary
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp root-protection
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 2 to 20
    #
    stp bpdu-protection
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 2
     stp edged-port enable 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp instance 2 cost 20000
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 2 to 20
    #
    stp bpdu-protection
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 11
     stp edged-port enable 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp instance 1 cost 20000
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85191

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页