所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置HVRP示例

配置HVRP示例

组网需求

图21-5所示,企业网络中各交换机通过二层端口互联,组成二层网络。此二层网络通过STP来破除环路,其中SwitchA为根桥,SwitchD与SwitchE之间的链路被STP阻断。由于企业用户的不断增加,交换机的MAC地址表规格已经无法满足实际需求。企业希望在不升级交换机规格的情况下,能够继续增加用户数量。

图21-5  HVRP应用组网图

配置思路

可以配置HVRP功能实现上述需求,HVRP通过动态地注册和老化VLAN,只保留必需的VLAN。当VLAN内端口数小于或等于2时,就可以不学习MAC,进而减少交换机的MAC地址学习数量,扩大了设备支持下挂的用户容量。采用如下思路配置HVRP功能:

  1. 环网上设备使能STP,实现破除二层环路。

  2. 配置接口类型和加入的VLAN,实现二层互通。

  3. 使能全局HVRP功能和接口HVRP功能,实现动态地注册和老化VLAN,减少交换机的MAC地址学习数量。

操作步骤

  1. 环上设备使能STP,以SwitchD为例,STP环上其它设备SwitchA、SwitchB、SwitchC和SwitchE的配置与SwitchD类似,不再赘述。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchD
    [SwitchD] stp enable
    

  2. 设置SwitchA为根设备,从而阻塞SwitchD和SwitchE之间的链路。

    [SwitchA] stp root primary
    

  3. 创建VLAN,配置接口类型并加入VLAN,STP环上其它设备SwitchA、SwitchB、SwitchC和SwitchE的配置与SwitchD类似,不再赘述。

    [SwitchD] vlan batch 101 to 500
    [SwitchD] interface gigabitethernet 1/0/0
    [SwitchD-GigabitEthernet1/0/0] port link-type trunk
    [SwitchD-GigabitEthernet1/0/0] port trunk allow-pass vlan 101 to 500
    [SwitchD-GigabitEthernet1/0/0] quit
    [SwitchD] interface gigabitethernet 2/0/0
    [SwitchD-GigabitEthernet2/0/0] port link-type trunk
    [SwitchD-GigabitEthernet2/0/0] port trunk allow-pass vlan 101 to 500
    [SwitchD-GigabitEthernet2/0/0] quit
    [SwitchD] interface gigabitethernet 3/0/0
    [SwitchD-GigabitEthernet3/0/0] port link-type trunk
    [SwitchD-GigabitEthernet3/0/0] port trunk allow-pass vlan 101 to 200
    [SwitchD-GigabitEthernet3/0/0] quit

  4. 使能HVRP功能,STP环上其它设备SwitchA、SwitchB、SwitchC和SwitchE的配置与SwitchD类似,不再赘述。

    [SwitchD] hvrp enable
    [SwitchD] interface gigabitethernet 1/0/0
    [SwitchD-GigabitEthernet1/0/0] hvrp enable
    [SwitchD-GigabitEthernet1/0/0] quit
    [SwitchD] interface gigabitethernet 2/0/0
    [SwitchD-GigabitEthernet2/0/0] hvrp enable
    [SwitchD-GigabitEthernet2/0/0] quit
    

  5. 验证配置结果。

    配置完成后,使用命令display hvrp verbose可以查看到HVRP配置的详细信息。

    [SwitchD] display hvrp verbose
     HVRP is enabled globally.
     HVRP registervlan timer           :5s.
     HVRP registervlan age timer       :15s.
     HVRP age all VLAN                 :Disabled.
        HVRP Permanent-vlan :
        HVRP statistics on port GigabitEthernet1/0/0     (PORT_LINK_UP)
     Mstp Role        :
                             0 - designated
        HVRP statistics on port GigabitEthernet2/0/0     (PORT_LINK_UP)
     Mstp Role        :
                             0 - root
    

    在相同业务量的情况下,使用display mac-address命令查看MAC地址学习数量,配置HVRP后MAC地址学习数量明显比配置前少,证明HVRP功能减少了交换机的MAC地址学习数量。

配置文件

  • SwitchA的配置文件。

    #
    sysname SwitchA
    #
    vlan batch 101 to 500
    #
    stp instance 0 root primary
    #
    hvrp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    return
    
  • SwitchB的配置文件。

    #
    sysname SwitchB
    #
    vlan batch 101 to 500
    #
    hvrp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 301 to 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    return
    
  • SwitchC的配置文件。

    #
    sysname SwitchC
    #
    vlan batch 101 to 500
    #
    hvrp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 401 to 500
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    return
    
  • SwitchD的配置文件。

    #
    sysname SwitchD
    #
    vlan batch 101 to 500
    #
    hvrp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 200
    #
    return
    
  • SwitchE的配置文件。

    #
    sysname SwitchE
    #
    vlan batch 101 to 500
    #
    hvrp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 500
     hvrp enable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 201 to 300
    #
    return
    
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85968

下载量:1003

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页