所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Dot1q终结子接口实现同设备VLAN间通信示例

配置Dot1q终结子接口实现同设备VLAN间通信示例

组网需求

企业的不同部门拥有相同的业务,如上网、VoIP等业务,且各个部门中的用户位于不同的网段。目前存在不同的部门中相同的业务所属的VLAN不相同,现需要实现不同VLAN中的用户相互通信。

图8-7所示,部门1和部门2中拥有相同的上网业务,但是属于不同的VLAN且位于不同的网段。现需要实现部门1与部门2的用户互通。

图8-7  配置Dot1q终结子接口实现同设备VLAN间通信组网图

配置思路

采用如下的思路配置不同VLAN通过Switch互相通信。

  1. 配置各接口所属的VLAN ID。

  2. 配置子接口为Dot1q终结子接口。

  3. 配置子接口的IP地址。

说明:

VCMP的角色是Client时,不能配置VLAN终结子接口。

操作步骤

  1. 配置SwitchA的上行接口以Tagged方式加入VLAN10,用户侧接口以Untagged方式加入VLAN10;SwitchB的上行接口以Tagged方式加入VLAN20,用户侧接口以Untagged方式加入VLAN20。配置SwitchA和SwitchB的接口VLAN

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 20
    [SwitchB] interface gigabitethernet1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type access
    [SwitchB-GigabitEthernet1/0/1] port default vlan 20
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [SwitchB-GigabitEthernet1/0/2] quit
    

  2. 配置Switch上连接SwitchA的接口

    # 创建并配置以太网子接口GE1/0/1.1。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vcmp role silent
    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet1/0/1.1
    [Switch-GigabitEthernet1/0/1.1] dot1q termination vid 10
    [Switch-GigabitEthernet1/0/1.1] ip address 10.10.10.1 24
    [Switch-GigabitEthernet1/0/1.1] arp broadcast enable
    [Switch-GigabitEthernet1/0/1.1] quit
    

  3. 配置Switch上连接SwitchB的接口

    # 创建并配置以太网子接口GE1/0/2.1。

    [Switch] interface gigabitethernet1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/2.1
    [Switch-GigabitEthernet1/0/2.1] dot1q termination vid 20
    [Switch-GigabitEthernet1/0/2.1] ip address 10.10.20.1 24
    [Switch-GigabitEthernet1/0/2.1] arp broadcast enable
    [Switch-GigabitEthernet1/0/2.1] quit
    

  4. 检查配置结果

    在VLAN10中的PC1上配置缺省网关为GE1/0/1.1接口的IP地址10.10.10.1/24。

    在VLAN20中的PC2上配置缺省网关为GE1/0/2.1接口的IP地址10.10.20.1/24。

    配置完成后,VLAN10内的PC1与VLAN20内的PC2能够互相访问。

配置文件

Switch的配置文件

#
sysname Switch
#
vcmp role silent
#
interface GigabitEthernet1/0/1
 port link-type hybrid
#
interface GigabitEthernet1/0/1.1
 dot1q termination vid 10
 ip address 10.10.10.1 255.255.255.0
 arp broadcast enable
#
interface GigabitEthernet1/0/2
 port link-type hybrid
#
interface GigabitEthernet1/0/2.1
 dot1q termination vid 20
 ip address 10.10.20.1 255.255.255.0
 arp broadcast enable
#
return

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 10
#
return

SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 20
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 20
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84638

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页