所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置E-Trunk接入VPLS示例

配置E-Trunk接入VPLS示例

组网需求

在没有配置E-Trunk前,CE通过Eth-Trunk链路只能单归到一个PE设备。如果Eth-Trunk出现故障或者PE设备故障,CE将无法与PE设备继续进行通信。使用E-Trunk后,CE可以双归到PE上,从而把链路可靠性从单板级提高到了设备级。

图3-28所示,CE1分别通过一条LACP模式的Eth-Trunk与PE1和PE2相连,双归接入VPLS网络。

最初,CE1通过PE1与VPLS网络远端设备CE2通信。如果CE1与PE1之间的Eth-Trunk出现故障或者PE1设备故障,那么CE1将无法与CE2设备继续通信。为了保证业务不中断,此时,可在PE1与PE2设备上部署E-Trunk功能,使CE1到PE1的流量切换到PE2上,通过PE2与CE2继续通信。当CE1与PE1之间的Eth-Trunk故障或者PE1设备故障已恢复,流量重新切换到PE1上。

E-Trunk在PE1与PE2之间实现链路聚合组的备份,提高网络可靠性。

图3-28  配置E-Trunk接入VPLS组网图

Switch

接口

对应的三层接口

IP地址

PE1

GigabitEthernet1/0/1

-

-

GigabitEthernet1/0/2

-

-

GigabitEthernet1/0/3

VLANIF 100

10.1.1.1/24

Loopback1

-

1.1.1.9/32

PE2

GigabitEthernet1/0/1

-

-

GigabitEthernet1/0/2

-

-

GigabitEthernet1/0/3

VLANIF 200

10.1.2.1/24

Loopback1

-

2.2.2.9/32

PE3

GigabitEthernet1/0/1

VLANIF 100

10.1.1.2/24

GigabitEthernet1/0/2

VLANIF 200

10.1.2.2/24

GigabitEthernet1/0/3

GigabitEthernet1/0/3.1

-

Loopback1

-

3.3.3.9/32

CE1

GigabitEthernet1/0/1

-

-

GigabitEthernet1/0/2

-

-

GigabitEthernet1/0/3

-

-

GigabitEthernet1/0/4

-

-

CE2

GigabitEthernet1/0/3

-

-

配置思路

采用如下的思路配置E-Trunk接入VPLS:

  1. 配置E-Trunk,具体包括:

    • 在CE1分别与PE1和PE2之间创建Eth-Trunk,配置Eth-Trunk为LACP模式,并将成员加入Eth-Trunk。

    • 在PE1和PE2上创建E-Trunk,将LACP模式的Eth-Trunk加入到指定E-Trunk中。

    • 配置E-Trunk的属性,包括:

      • E-Trunk的优先级。

      • E-Trunk的LACP系统ID和优先级。

      • E-Trunk的Hello报文发送周期。

      • E-Trunk检测Hello报文的时间倍数。

      • E-Trunk源端和对端的IP地址。

    • 配置E-Trunk与BFD会话绑定。
  2. 配置CE接入VPLS基本功能,具体包括:
    • 在骨干网上配置路由协议实现互通。

    • 使能MPLS基本功能和LDP。

    • 在PE上使能MPLS L2VPN。

    • 创建并配置VSI,指定信令为LDP。

    • 创建Eth-Trunk子接口,然后将VSI与子接口绑定。

操作步骤

  1. 图3-28配置PW侧的接口所属的VLAN以及IP地址。在骨干网上配置路由协议实现互通,本示例中使用OSPF。

    # 配置PE1。

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan batch 100
    [PE1] interface gigabitethernet 1/0/3
    [PE1-GigabitEthernet1/0/3] port link-type trunk
    [PE1-GigabitEthernet1/0/3] port trunk allow-pass vlan 100
    [PE1-GigabitEthernet1/0/3] quit
    [PE1] interface vlanif 100
    [PE1-Vlanif100] ip address 10.1.1.1 24
    [PE1-Vlanif100] quit
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # 配置PE2。

    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan batch 200
    [PE2] interface gigabitethernet 1/0/3
    [PE2-GigabitEthernet1/0/3] port link-type trunk
    [PE2-GigabitEthernet1/0/3] port trunk allow-pass vlan 200
    [PE2-GigabitEthernet1/0/3] quit
    [PE2] interface vlanif 200
    [PE2-Vlanif200] ip address 10.1.2.1 24
    [PE2-Vlanif200] quit
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 2.2.2.9 32
    [PE2-LoopBack1] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 10.1.2.1 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    # 配置PE3。

    <HUAWEI> system-view
    [HUAWEI] sysname PE3
    [PE3] vlan batch 100 200
    [PE3] interface gigabitethernet 1/0/1
    [PE3-GigabitEthernet1/0/1] port link-type trunk
    [PE3-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [PE3-GigabitEthernet1/0/1] quit
    [PE3] interface gigabitethernet 1/0/2
    [PE3-GigabitEthernet1/0/2] port link-type trunk
    [PE3-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
    [PE3-GigabitEthernet1/0/2] quit
    [PE3] interface vlanif 100
    [PE3-Vlanif100] ip address 10.1.1.2 24
    [PE3-Vlanif100] quit
    [PE3] interface vlanif 200
    [PE3-Vlanif200] ip address 10.1.2.2 24
    [PE3-Vlanif200] quit
    [PE3] interface loopback 1
    [PE3-LoopBack1] ip address 3.3.3.9 32
    [PE3-LoopBack1] quit
    [PE3] ospf 1
    [PE3-ospf-1] area 0
    [PE3-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [PE3-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] network 10.1.2.2 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] quit
    [PE3-ospf-1] quit

    完成此步骤后,PE1、PE2和PE3之间通过OSPF协议发现的对方Loopback1的IP路由,并应能互相Ping通。在PE1、PE2和PE3上执行display ip routing-table命令可以看到已学到彼此的路由。

    说明:
    • 避免将PE上PW侧和AC侧的接口加入相同的VLAN中,否则可能引起环路。
    • 配置OSPF时,注意需要发布PE1、PE2和PE3的32位Loopback接口地址。

  2. 分别在CE1、PE1和PE2上创建Eth-Trunk,配置Eth-Trunk为LACP模式,并将成员接口加入Eth-Trunk,在CE1上配置二层转发功能。

    # 配置CE1。

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan batch 10
    [CE1] interface eth-trunk 20
    [CE1-Eth-Trunk20] port link-type trunk
    [CE1-Eth-Trunk20] port trunk allow-pass vlan 10
    [CE1-Eth-Trunk20] mode lacp
    [CE1-Eth-Trunk20] trunkport GigabitEthernet 1/0/1 to 1/0/4
    [CE1-Eth-Trunk20] quit

    # 配置PE1。

    [PE1] interface eth-trunk 10
    [PE1-Eth-Trunk10] port link-type trunk
    [PE1-Eth-Trunk10] mode lacp
    [PE1-Eth-Trunk10] trunkport GigabitEthernet 1/0/1 to 1/0/2
    [PE1-Eth-Trunk10] quit

    # 配置PE2。

    [PE2] interface eth-trunk 10
    [PE2-Eth-Trunk10] port link-type trunk
    [PE2-Eth-Trunk10] mode lacp
    [PE2-Eth-Trunk10] trunkport GigabitEthernet 1/0/1 to 1/0/2
    [PE2-Eth-Trunk10] quit

  3. 创建E-Trunk并配置E-Trunk属性,包括E-Trunk的LACP优先级和系统ID、E-Trunk优先级、检测Hello报文的时间倍数、Hello报文发送周期以及源端和对端的IP地址

    # 配置PE1。

    [PE1] e-trunk 1
    [PE1-e-trunk-1] quit
    [PE1] lacp e-trunk priority 1
    [PE1] lacp e-trunk system-id 00E0-FC00-0000
    [PE1] e-trunk 1
    [PE1-e-trunk-1] priority 10
    [PE1-e-trunk-1] timer hold-on-failure multiplier 3
    [PE1-e-trunk-1] timer hello 9
    [PE1-e-trunk-1] peer-address 2.2.2.9 source-address 1.1.1.9
    [PE1-e-trunk-1] quit

    # 配置PE2。

    [PE2] e-trunk 1
    [PE2-e-trunk-1] quit
    [PE2] lacp e-trunk priority 1
    [PE2] lacp e-trunk system-id 00E0-FC00-0000
    [PE2] e-trunk 1
    [PE2-e-trunk-1] priority 20
    [PE2-e-trunk-1] timer hold-on-failure multiplier 3
    [PE2-e-trunk-1] timer hello 9
    [PE2-e-trunk-1] peer-address 1.1.1.9 source-address 2.2.2.9
    [PE2-e-trunk-1] quit

  4. 将LACP模式的Eth-Trunk加入到指定E-Trunk中

    # 配置PE1。

    [PE1] interface eth-trunk 10
    [PE1-Eth-Trunk10] e-trunk 1
    [PE1-Eth-Trunk10] quit

    # 配置PE2。

    [PE2] interface eth-trunk 10
    [PE2-Eth-Trunk10] e-trunk 1
    [PE2-Eth-Trunk10] quit

  5. 配置E-Trunk与BFD会话绑定

    • 创建BFD会话。

      # 配置PE1。

      [PE1] bfd
      [PE1-bfd] quit
      [PE1] bfd hello1 bind peer-ip 2.2.2.9 source-ip 1.1.1.9
      [PE1-bfd-session-hello1] discriminator local 1
      [PE1-bfd-session-hello1] discriminator remote 2
      [PE1-bfd-session-hello1] commit
      [PE1-bfd-session-hello1] quit

      BFD会话绑定的源端和对端IP地址与E-Trunk源端和对端的IP地址必须一致。

      # 配置PE2。

      [PE2] bfd
      [PE2-bfd] quit
      [PE2] bfd hello2 bind peer-ip 1.1.1.9 source-ip 2.2.2.9
      [PE2-bfd-session-hello2] discriminator local 2
      [PE2-bfd-session-hello2] discriminator remote 1
      [PE2-bfd-session-hello2] commit
      [PE2-bfd-session-hello2] quit
    • 配置E-Trunk 1与BFD会话绑定

      # 配置PE1。

      [PE1] e-trunk 1
      [PE1-e-trunk-1] e-trunk track bfd-session session-name hello1
      [PE1-e-trunk-1] quit

      # 配置PE2。

      [PE2] e-trunk 1
      [PE2-e-trunk-1] e-trunk track bfd-session session-name hello2
      [PE2-e-trunk-1] quit

  6. 配置CE1接入VPLS基本功能。

    1. 在PE1、PE2和PE3上配置MPLS基本功能和LDP。

      # 配置PE1。

      [PE1] mpls lsr-id 1.1.1.9
      [PE1] mpls
      [PE1-mpls] quit
      [PE1] mpls ldp
      [PE1-mpls-ldp] quit
      [PE1] interface vlanif 100
      [PE1-Vlanif100] mpls
      [PE1-Vlanif100] mpls ldp
      [PE1-Vlanif100] quit

      # 配置PE2。

      [PE2] mpls lsr-id 2.2.2.9
      [PE2] mpls
      [PE2-mpls] quit
      [PE2] mpls ldp
      [PE2-mpls-ldp] quit
      [PE2] interface vlanif 200
      [PE2-Vlanif200] mpls
      [PE2-Vlanif200] mpls ldp
      [PE2-Vlanif200] quit

      # 配置PE3。

      [PE3] mpls lsr-id 3.3.3.9
      [PE3] mpls
      [PE3-mpls] quit
      [PE3] mpls ldp
      [PE3-mpls-ldp] quit
      [PE3] interface vlanif 100
      [PE3-Vlanif100] mpls
      [PE3-Vlanif100] mpls ldp
      [PE3-Vlanif100] quit
      [PE3] interface vlanif 200
      [PE3-Vlanif200] mpls
      [PE3-Vlanif200] mpls ldp
      [PE3-Vlanif200] quit

      配置完成后,在PE上执行display mpls ldp session命令可以看到对等体的Status项为“Operational”,即远端对等体关系已建立。

    2. 分别在PE1、PE2和PE3上使能MPLS L2VPN

      # 配置PE1。

      [PE1] mpls l2vpn
      [PE1-l2vpn] quit

      # 配置PE2。

      [PE2] mpls l2vpn
      [PE2-l2vpn] quit

      # 配置PE3。

      [PE3] mpls l2vpn
      [PE3-l2vpn] quit
    3. 分别在PE1、PE2和PE3上创建VSI ldp1,并指定VSI的信令为LDP。

      # 配置PE1。

      [PE1] vsi ldp1 static
      [PE1-vsi-ldp1] pwsignal ldp
      [PE1-vsi-ldp1-ldp] vsi-id 2
      [PE1-vsi-ldp1-ldp] peer 3.3.3.9
      [PE1-vsi-ldp1-ldp] quit
      [PE1-vsi-ldp1] quit

      # 配置PE2。

      [PE2] vsi ldp1 static
      [PE2-vsi-ldp1] pwsignal ldp
      [PE2-vsi-ldp1-ldp] vsi-id 2
      [PE2-vsi-ldp1-ldp] peer 3.3.3.9
      [PE2-vsi-ldp1-ldp] quit
      [PE2-vsi-ldp1] quit

      # 配置PE3。

      [PE3] vsi ldp1 static
      [PE3-vsi-ldp1] pwsignal ldp
      [PE3-vsi-ldp1-ldp] vsi-id 2
      [PE3-vsi-ldp1-ldp] peer 1.1.1.9
      [PE3-vsi-ldp1-ldp] peer 2.2.2.9
      [PE3-vsi-ldp1-ldp] quit
      [PE3-vsi-ldp1] quit
    4. 在PE1、PE2上配置Eth-Trunk子接口,将VSI与子接口进行绑定。

      # 配置PE1。

      [PE1] interface Eth-Trunk 10.1
      [PE1-Eth-Trunk10.1] dot1q termination vid 10
      [PE1-Eth-Trunk10.1] l2 binding vsi ldp1
      [PE1-Eth-Trunk10.1] quit

      # 配置PE2。

      [PE2] interface Eth-Trunk 10.1
      [PE2-Eth-Trunk10.1] dot1q termination vid 10
      [PE2-Eth-Trunk10.1] l2 binding vsi ldp1
      [PE2-Eth-Trunk10.1] quit
    5. 在PE3上配置子接口,将VSI与接口的绑定

      # 配置PE3。

      [PE3] interface gigabitethernet 1/0/3.1
      [PE3-GigabitEthernet1/0/3.1] dot1q termination vid 10
      [PE3-GigabitEthernet1/0/3.1] l2 binding vsi ldp1
      [PE3-GigabitEthernet1/0/3.1] quit

  7. 验证配置结果

    • 在CE1上执行命令display eth-trunk,查看Eth-Trunk接口的配置信息。

    • 执行命令display e-trunk,查看E-Trunk信息。

      # 查看PE1上的E-Trunk1的信息。

      [PE1] display e-trunk 1
                                  The E-Trunk information   
      E-TRUNK-ID : 1                          Revert-Delay-Time (s) : 120 
      Priority : 10                           System-ID : 00e0-0f74-eb00
      Peer-IP : 2.2.2.9                       Source-IP : 1.1.1.9
      State : Master                          Causation : PRI
      Send-Period (100ms) : 9                 Fail-Time (100ms) : 27
      Receive : 41                            Send : 42
      RecDrop : 0                             SndDrop : 0
      Peer-Priority : 20                      Peer-System-ID : 00e0-3b6c-6100
      Peer-Fail-Time (100ms) : 27             BFD-Session : hello1
      Description : -  
      Sequence : Disable
      --------------------------------------------------------------------------------   
                                  The Member information                               
      Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID    
      Eth-Trunk 10  Up             auto          Master  ETRUNK_MASTER    10   

      # 查看PE2上的E-Trunk1的信息。

      [PE2] display e-trunk 1
                                  The E-Trunk information   
      E-TRUNK-ID : 1                          Revert-Delay-Time (s) : 120 
      Priority : 20                           System-ID : 00e0-3b6c-6100
      Peer-IP : 1.1.1.9                       Source-IP : 2.2.2.9
      State : Backup                          Causation : PRI
      Send-Period (100ms) : 9                 Fail-Time (100ms) : 27
      Receive : 43                            Send : 42
      RecDrop : 3                             SndDrop : 0
      Peer-Priority : 10                      Peer-System-ID : 00e0-0f74-eb00
      Peer-Fail-Time (100ms) : 27             BFD-Session : hello2
      Description : -  
      Sequence : Disable
      --------------------------------------------------------------------------------   
                                  The Member information                               
      Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID    
      Eth-Trunk 10  Down           auto          Backup  ETRUNK_BACKUP    10   

      通过以上显示信息可以看到,PE1上E-Trunk的优先级为10,E-Trunk的状态为Master。PE2上E-Trunk的优先级为20,E-Trunk的状态为Backup,实现了设备间的冗余备份功能。

配置文件

  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 10
     mode lacp
    #
    interface GigabitEthernet1/0/1
     eth-trunk 20
    #
    interface GigabitEthernet1/0/2
     eth-trunk 20
    #
    interface GigabitEthernet1/0/3
     eth-trunk 20
    #
    interface GigabitEthernet1/0/4
     eth-trunk 20
    #
    return       
  • PE1的配置文件

    #
    sysname PE1
    #
    vlan batch 100
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    bfd
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls l2vpn
    #
    vsi ldp1 static
     pwsignal ldp
      vsi-id 2
      peer 3.3.3.9 
    #
    mpls ldp
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    e-trunk 1
     priority 10
     peer-address 2.2.2.9 source-address 1.1.1.9
     timer hello 9
     timer hold-on-failure multiplier 3
     e-trunk track bfd-session session-name hello1
    #
    interface Eth-Trunk10
     port link-type trunk
     mode lacp
     e-trunk 1
    #
    interface Eth-Trunk10.1
     dot1q termination vid 10
     l2 binding vsi ldp1
    #
    interface GigabitEthernet1/0/1
     eth-trunk 10
    #
    interface GigabitEthernet1/0/2
     eth-trunk 10
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bfd hello1 bind peer-ip 2.2.2.9 source-ip 1.1.1.9
     discriminator local 1
     discriminator remote 2
     commit
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 200
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    bfd
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls l2vpn
    #
    vsi ldp1 static
     pwsignal ldp
      vsi-id 2
      peer 3.3.3.9
    #
    mpls ldp
    #
    interface Vlanif200
     ip address 10.1.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    e-trunk 1
     priority 20
     peer-address 1.1.1.9 source-address 2.2.2.9
     timer hello 9
     timer hold-on-failure multiplier 3
     e-trunk track bfd-session session-name hello2
    #
    interface Eth-Trunk10
     port link-type trunk
     mode lacp
     e-trunk 1
    #
    interface Eth-Trunk10.1
     dot1q termination vid 10
     l2 binding vsi ldp1
    #
    interface GigabitEthernet1/0/1
     eth-trunk 10
    #
    interface GigabitEthernet1/0/2
     eth-trunk 10
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    bfd hello2 bind peer-ip 1.1.1.9 source-ip 2.2.2.9
     discriminator local 2
     discriminator remote 1
     commit
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    return
  • PE3的配置文件

    #
    sysname PE3
    #
    vlan batch 100 200
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls l2vpn
    #
    vsi ldp1 static
     pwsignal ldp
      vsi-id 2
      peer 1.1.1.9
      peer 2.2.2.9
    #
    mpls ldp
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif200
     ip address 10.1.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/3.1
     dot1q termination vid 10
     l2 binding vsi ldp1
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84293

下载量:1000

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页