所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于接口的二层协议透明传输示例

配置基于接口的二层协议透明传输示例

组网需求

图22-6所示,CE设备为企业处于不同地域网络的边缘设备,PE1和PE2为运营商网络的边缘设备。企业的两个网络是二层网络,并且通过运营商网络实现互联。为了防止二层网络形成环路,网络中运行STP协议,并且企业用户希望STP只在用户自有网络中运行以生成正确的生成树。

图22-6  配置基于接口的二层协议透明传输组网图

配置思路

采用如下思路配置基于接口的二层协议透明传输的基本功能:

  1. 配置CE的STP功能,破除二层网络中的环路。

  2. 把PE的CE侧接口加入到指定的VLAN中,实现PE设备对指定用户VLAN报文的转发。

  3. 配置PE基于接口的二层协议透明传输功能,实现STP协议报文不上送PE设备的CPU进行处理。

操作步骤

  1. 使能CE设备的生成树计算功能

    # 配置CE1。

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan 100
    [CE1-vlan100] quit
    [CE1] stp enable
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port link-type hybrid
    [CE1-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [CE1-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [CE1-GigabitEthernet1/0/0] quit
    

    # 配置CE2。

    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] vlan 100
    [CE2-vlan100] quit
    [CE2] stp enable
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] port link-type hybrid
    [CE2-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [CE2-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [CE2-GigabitEthernet1/0/0] quit
    

  2. 将PE1和PE2的接口GE1/0/0加入到VLAN100中,PE设备使能二层协议透明传输功能

    # 配置PE1。

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan 100
    [PE1-vlan100] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] port link-type hybrid
    [PE1-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [PE1-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [PE1-GigabitEthernet1/0/0] l2protocol-tunnel stp enable
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface GigabitEthernet 1/0/2
    [PE1-GigabitEthernet1/0/2] port link-type trunk
    [PE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 100
    [PE1-GigabitEthernet1/0/2] quit

    # 配置PE2。

    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan 100
    [PE2-vlan100] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] port link-type hybrid
    [PE2-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [PE2-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [PE2-GigabitEthernet1/0/0] l2protocol-tunnel stp enable
    [PE2-GigabitEthernet1/0/0] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] port link-type trunk
    [PE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 100
    [PE2-GigabitEthernet1/0/2] quit

  3. 配置PE替换接收到CE的STP协议报文的目的MAC地址

    # 配置PE1

    [PE1] l2protocol-tunnel stp group-mac 0100-0100-0100
    

    # 配置PE2

    [PE2] l2protocol-tunnel stp group-mac 0100-0100-0100
    

  4. 配置CE2设备的优先级为4096

    [CE2] stp priority 4096
    

  5. 检查配置结果

    # 配置完成后,在PE上使用display l2protocol-tunnel group-mac命令可以查看透明传输的二层协议名称、协议类型、协议报文的组播目的MAC地址、Group MAC地址以及报文的优先级。

    以PE1的显示为例。

    [PE1] display l2protocol-tunnel group-mac stp
    Protocol         EncapeType ProtocolType Protocol-MAC   Group-MAC      Pri      
    -----------------------------------------------------------------------------   
    stp              llc        dsap 0x42    0180-c200-0000 0100-0100-0100 0        
                                ssap 0x42                                           

    # 等待30秒,在CE1和CE2设备上执行display stp命令可以检查MSTP的根。CE1和CE2之间完成了生成树计算功能。CE1上的GE1/0/0为根(Root)端口,CE2上的GE1/0/0为指定(Designated)端口。

    [CE1] display stp brief
     MSTID   Port                        Role  STP State     Protection     
        0    GigabitEthernet1/0/0       ROOT  FORWARDING      NONE
    
    [CE2] display stp brief
     MSTID   Port                        Role  STP State     Protection     
        0    GigabitEthernet1/0/0       DESI  FORWARDING      NONE
    

配置文件

  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 100
    #
    interface GigabitEthernet1/0/0
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    vlan batch 100 
    #
    stp instance 0 priority 4096
    #
    interface GigabitEthernet1/0/0
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
  • PE1的配置文件

    #
    sysname PE1
    #
    vlan batch 100
    #
    l2protocol-tunnel stp group-mac 0100-0100-0100
    #
    interface GigabitEthernet1/0/0
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     l2protocol-tunnel stp enable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 100
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 100
    #
    l2protocol-tunnel stp group-mac 0100-0100-0100
    #
    interface GigabitEthernet1/0/0
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     l2protocol-tunnel stp enable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 100
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84701

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页