所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RRPP多实例相切环示例

配置RRPP多实例相切环示例

组网需求

图18-42所示,采用环网结构时,为了提高对网络的利用率,希望空闲链路也承担数据流量的转发,不同VLAN数据按照不同路径进行转发,实现业务流量的负载分担。

图18-42  配置RRPP多实例相切环组网图

数据准备

域1、域2和域3中的保护VLAN以及保护VLAN所属实例详见表18-14

表18-14  实例与保护VLAN的映射关系表

Domain ID

Control VLAN

Data VLAN

Instance ID

域1

VLAN 5、6

VLAN 100~200

Instance 1

域2

VLAN 10、11

VLAN 201~300

Instance 2

域3(UPED)

VLAN 20、21

VLAN 100~300

Instance 1、2、3

域3(UPEE、UPEF、UPEG)

VLAN 20、21

VLAN 100~300

Instance 1

3个环中的主节点以及主节点上的主、副端口详见表18-15

表18-15  主节点以及主、副端口信息表

Ring ID

Master Node

Primary Port

Secondary Port

域1环1

UPED

GE1/0/0

GE2/0/0

域2环1

UPED

GE2/0/0

GE1/0/0

域3环1

UPEF

GE1/0/0

GE2/0/0

配置思路

采用如下的思路配置RRPP多实例相交环示例:

  1. 创建不同的RRPP域和控制VLAN,为后续配置RRPP环做好准备。

  2. 将各RRPP域上需要通过的VLAN数据映射到对应的实例,为后续配置保护VLAN做好准备。

  3. 配置设备上将要加入RRPP的各接口,使其可以通过RRPP环上需要通过的VLAN数据,并去使能与RRPP相冲突的功能(例如STP功能)。

  4. 在各RRPP域中,配置保护VLAN并创建RRPP环。
    1. 将UPEA、UPEB、UPEC、UPED配置为域1的环1和域2的环1。

    2. 将UPED、UPEE、UPEF、UPEG配置为域3的环1。

    3. 配置UPED为域1环1和域2环1的主节点,UPEA、UPEB、UPEC为传输节点。

    4. 配置UPEF为域3环1的主节点,UPED、UPEE、UPEG为传输节点。

  5. 在各设备上使能RRPP环和RRPP协议,使得RRPP功能生效。

操作步骤

  1. 创建实例,映射允许通过的数据VLAN和控制VLAN。

    # 配置UPEA。UPEB、UPEC、UPED、UPEE、UPEF和UPEG的配置与UPEA相同,此处省略,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname UPEA
    [UPEA] stp region-configuration 
    [UPEA-mst-region] instance 1 vlan 5 6 100 to 200
    [UPEA-mst-region] instance 2 vlan 10 11 201 to 300
    [UPEA-mst-region] active region-configuration
    [UPEA-mst-region] quit

  2. 配置加入RRPP环的端口

    # 配置UPEA。UPEB、UPEC、UPED、UPEE、UPEF和UPEG的配置与UPEA相同,此处省略,详见配置文件。

    [UPEA] vlan batch 100 to 300
    [UPEA] interface gigabitethernet 1/0/0
    [UPEA-GigabitEthernet1/0/0] port link-type trunk
    [UPEA-GigabitEthernet1/0/0] undo port trunk allow-pass vlan 1
    [UPEA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100 to 300
    [UPEA-GigabitEthernet1/0/0] stp disable
    [UPEA-GigabitEthernet1/0/0] quit
    [UPEA] interface gigabitethernet 2/0/0
    [UPEA-GigabitEthernet2/0/0] port link-type trunk
    [UPEA-GigabitEthernet2/0/0] undo port trunk allow-pass vlan 1
    [UPEA-GigabitEthernet2/0/0] port trunk allow-pass vlan 100 to 300
    [UPEA-GigabitEthernet2/0/0] stp disable
    [UPEA-GigabitEthernet2/0/0] quit

  3. 创建RRPP域,配置保护VLAN和控制VLAN

    # 配置UPEA。UPEB、UPEC、UPED、UPEE、UPEF和UPEG的配置与UPEA类似,此处省略,详见配置文件。

    [UPEA] rrpp domain 1
    [UPEA-rrpp-domain-region1] protected-vlan reference-instance 1
    [UPEA-rrpp-domain-region1] control-vlan 5
    [UPEA-rrpp-domain-region1] quit
    [UPEA] rrpp domain 2
    [UPEA-rrpp-domain-region2] protected-vlan reference-instance 2
    [UPEA-rrpp-domain-region2] control-vlan 10
    [UPEA-rrpp-domain-region2] quit

  4. 创建RRPP环

    # 配置UPEA为域1环1的传输节点,并指定主副接口。

    [UPEA] rrpp domain 1
    [UPEA-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEA-rrpp-domain-region1] ring 1 enable
    [UPEA-rrpp-domain-region1] quit

    # 配置UPEA为域2环1的传输节点,并指定主副接口。

    [UPEA] rrpp domain 2
    [UPEA-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEA-rrpp-domain-region2] ring 1 enable
    [UPEA-rrpp-domain-region2] quit

    # 配置UPEB为域1环1的传输节点,并指定主副接口。

    [UPEB] rrpp domain 1
    [UPEB-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEB-rrpp-domain-region1] ring 1 enable
    [UPEB-rrpp-domain-region1] quit

    # 配置UPEB为域2环1的传输节点,并指定主副接口。

    [UPEB] rrpp domain 2
    [UPEB-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEB-rrpp-domain-region2] ring 1 enable
    [UPEB-rrpp-domain-region2] quit

    # 配置UPEC为域1环1的传输节点,并指定主副接口。

    [UPEC] rrpp domain 1
    [UPEC-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEC-rrpp-domain-region1] ring 1 enable
    [UPEC-rrpp-domain-region1] quit

    # 配置UPEC为域2环1的传输节点,并指定主副接口。

    [UPEC] rrpp domain 2
    [UPEC-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEC-rrpp-domain-region2] ring 1 enable
    [UPEC-rrpp-domain-region2] quit

    # 配置UPED为域1环1的主节点,主接口为GE1/0/0,副接口为GE2/0/0

    [UPED] rrpp domain 1
    [UPED-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPED-rrpp-domain-region1] ring 1 enable
    [UPED-rrpp-domain-region1] quit

    # 配置UPED为域2环1的主节点,主接口为GE2/0/0,副接口为GE1/0/0

    [UPED] rrpp domain 2
    [UPED-rrpp-domain-region2] ring 1 node-mode master primary-port gigabitethernet 2/0/0 secondary-port gigabitethernet 1/0/0 level 0
    [UPED-rrpp-domain-region2] ring 1 enable
    [UPED-rrpp-domain-region2] quit

    # 配置UPED为域3环1的传输节点,并指定主副接口。

    [UPED] rrpp domain 3
    [UPED-rrpp-domain-region3] ring 1 node-mode transit primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 2/0/1 level 0
    [UPED-rrpp-domain-region3] ring 1 enable
    [UPED-rrpp-domain-region3] quit

    # 配置UPEE为域3环1的传输节点,并指定主副接口。

    [UPEE] rrpp domain 3
    [UPEE-rrpp-domain-region3] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEE-rrpp-domain-region3] ring 1 enable
    [UPEE-rrpp-domain-region3] quit

    # 配置UPEF为域3环1的主节点,主接口为GE1/0/0,副接口为GE2/0/0

    [UPEF] rrpp domain 3
    [UPEF-rrpp-domain-region3] ring 1 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEF-rrpp-domain-region3] ring 1 enable
    [UPEF-rrpp-domain-region3] quit

    # 配置UPEG为域3环1的传输节点,并指定主副接口。

    [UPEG] rrpp domain 3
    [UPEG-rrpp-domain-region3] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEG-rrpp-domain-region3] ring 1 enable
    [UPEG-rrpp-domain-region3] quit

  5. 使能RRPP协议

    # 配置UPEA。UPEB、UPEC、UPED、UPEE、UPEF和UPEG的配置与UPEA相同,此处省略,详见配置文件。

    [UPEA] rrpp enable

  6. 检查配置结果

    # 经过以上配置,在网络计算稳定后,执行以下操作,验证配置结果。以UPED为例。在UPED上执行display rrpp brief命令,查看结果如下:

    [UPED] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , E - Edge , A - Assistant-Edge
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: HW
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 3
    
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    Ring   Ring    Node     Primary/Common           Secondary/Edge          Is
    ID     Level   Mode     Port                     Port                    Enabled
    ----------------------------------------------------------------------------
    1      0       M        GigabitEthernet1/0/0     GigabitEthernet2/0/0    Yes
    
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    Ring   Ring    Node     Primary/Common           Secondary/Edge          Is
    ID     Level   Mode     Port                     Port                    Enabled
    ----------------------------------------------------------------------------
    1      0       M        GigabitEthernet2/0/0     GigabitEthernet1/0/0    Yes
    
    Domain Index   : 3
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 1 to 3
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    Ring   Ring    Node     Primary/Common           Secondary/Edge          Is
    ID     Level   Mode     Port                     Port                    Enabled
    ----------------------------------------------------------------------------
    1      0       T        GigabitEthernet1/0/1     GigabitEthernet2/0/1    Yes

    可以看到UPED的上已经使能了RRPP协议。

    在域1中:

    主控制VLAN为5,保护VLAN为Instance 1映射的VLAN。

    UPED为环1的主节点,主端口为GigabitEthernet1/0/0,副端口为GigabitEthernet2/0/0

    在域2中:

    主控制VLAN为10,保护VLAN为Instance 2映射的VLAN。

    UPED为环1的主节点。主端口为GigabitEthernet2/0/0,副端口为GigabitEthernet1/0/0

    在域3中:

    主控制VLAN为20,保护VLAN为Instance 1 to 3映射的VLAN。

    UPED为环1的传输节点。主端口为GigabitEthernet1/0/1,副端口为GigabitEthernet2/0/1

    在UPED上执行display rrpp verbose domain命令,查看结果如下:

    # 查看UPED在域1中的详细信息。

    [UPED] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
    Secondary port : GigabitEthernet2/0/0               Port status: BLOCKED

    可以看到域1的控制VLAN是VLAN5,保护VLAN是Instance 1映射的VLAN。

    UPED在域1中是主节点,节点状态为Complete。

    主端口是GigabitEthernet1/0/0,副端口是GigabitEthernet2/0/0

    # 查看UPED在域2中的详细信息。

    [UPED] display rrpp verbose domain 2
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet2/0/0               Port status: UP
    Secondary port : GigabitEthernet1/0/0               Port status: BLOCKED

    可以看到域2的控制VLAN是VLAN10,保护VLAN是Instance 2映射的VLAN。

    UPED在域2中是主节点,节点状态为Complete。

    主端口是GigabitEthernet2/0/0,副端口是GigabitEthernet1/0/0

    # 查看UPED在域3中的详细信息。

    [UPED] display rrpp verbose domain 3
    Domain Index   : 3
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 1 to 3
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/1               Port status: UP
    Secondary port : GigabitEthernet2/0/1               Port status: UP

    可以看到域3的控制VLAN是VLAN20,保护VLAN是Instance 1 to 3映射的VLAN。

    UPED在域3中是传输节点,节点状态为LinkUp。

    主端口是GigabitEthernet1/0/1,副端口是GigabitEthernet2/0/1

配置文件

  • UPEA的配置文件

    #
    sysname UPEA
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
  • UPEB的配置文件

    #
    sysname UPEB
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
  • UPEC的配置文件

    #
    sysname UPEC
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
  • UPED的配置文件

    #
    sysname UPED
    #
    vlan batch 5 to 6 10 to 11 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     instance 3 vlan 20 to 21
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode master primary-port GigabitEthernet2/0/0 secondary-port GigabitEthernet1/0/0 level 0
     ring 1 enable
    rrpp domain 3
     control-vlan 20
     protected-vlan reference-instance 1 to 3
     ring 1 node-mode transit primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet2/0/1 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    return
  • UPEE的配置文件

    #
    sysname UPEE
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 3
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    return
  • UPEF的配置文件

    #
    sysname UPEF
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 3
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    return
  • UPEG的配置文件

    #
    sysname UPEG
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 3
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300
     stp disable
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84386

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页