所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基本QinQ示例

配置基本QinQ示例

组网需求

图10-9所示,网络中有两个企业,企业1有两个分支,企业2有两个分支。这两个企业的各办公地的企业网都分别和运营商网络中的SwitchA和SwitchB相连,且公网中存在其它厂商设备,其外层VLAN Tag的TPID值为0x9100。

现需要实现:
  • 企业1和企业2独立划分VLAN,两者互不影响。
  • 各企业两分支之间流量通过公网透明传输,相同业务之间互通,不同业务之间互相隔离。
可通过配置QinQ来实现以上需求。利用公网提供的VLAN100使企业1互通,利用公网提供的VLAN200使企业2互通,不同企业之间互相隔离。并通过在连接其它厂商设备的接口上配置修改QinQ外层VLAN Tag的TPID值,来实现与其它厂商设备的互通。
图10-9  配置基本QinQ示例组网图

配置思路

采用如下的思路配置QinQ:

  1. 在SwitchA和SwitchB上均创建VLAN100和VLAN200,配置连接业务的接口为QinQ类型,并分别加入VLAN。实现不同业务添加不同的外层VLAN Tag。

  2. 配置SwitchA和SwitchB上连接公网的接口加入相应VLAN,实现允许VLAN100和200的报文通过。

  3. 在SwitchA和SwitchB连接公网的接口上配置外层VLAN tag的TPID值,实现与其它厂商设备的互通。

操作步骤

  1. 创建VLAN

    # 在SwitchA上创建VLAN100和VLAN200。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 200
    

    # 在SwitchB上创建VLAN100和VLAN200。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 200
    

  2. 配置接口类型为QinQ

    # 在SwitchA上配置接口GE1/0/1、GE1/0/2的类型为QinQ,GE1/0/1的外层tag为VLAN100,GE1/0/2的外层tag为VLAN200。SwitchB的配置与SwitchA类似,不再赘述。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type dot1q-tunnel
    [SwitchA-GigabitEthernet1/0/1] port default vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type dot1q-tunnel
    [SwitchA-GigabitEthernet1/0/2] port default vlan 200
    [SwitchA-GigabitEthernet1/0/2] quit
    

  3. 配置Switch连接公网侧的接口

    # 在SwitchA上配置接口GE1/0/3加入VLAN100和VLAN200。SwitchB的配置与SwitchA类似,不再赘述。

    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 100 200
    [SwitchA-GigabitEthernet1/0/3] quit

  4. 配置外层VLAN tag的TPID值

    # 在SwitchA上配置外层VLAN tag的TPID值为0x9100。

    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] qinq protocol 9100
    

    # 在SwitchB上配置外层VLAN tag的TPID值为0x9100。

    [SwitchB] interface gigabitethernet 1/0/3
    [SwitchB-GigabitEthernet1/0/3] qinq protocol 9100
    

  5. 验证配置结果

    从企业1一处分支内任意VLAN的一台PC ping企业1另外一处分支同一VLAN内的PC,如果可以ping通则表示企业1内部可以互相通信。

    从企业2一处分支内任意VLAN的一台PC ping企业2另外一处分支同一VLAN内的PC,如果可以ping通则表示企业2内部可以互相通信。

    从企业1一处分支内任意VLAN的一台PC ping企业2任意一处分支同一VLAN内的PC,如果不能ping通则表示企业1和企业2之间相互隔离。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    interface GigabitEthernet1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface GigabitEthernet1/0/3
     qinq protocol 9100
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface GigabitEthernet1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface GigabitEthernet1/0/3
     qinq protocol 9100
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return

相关信息

视频

如何配置QinQ

翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:90330

下载量:1014

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页