所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过Loopback Detection检测设备下挂网络环路示例

配置通过Loopback Detection检测设备下挂网络环路示例

组网需求

图20-8所示,某企业新组建的部门网络接入到汇聚交换机Switch,部门网络所属VLAN为100。新建网络可能因连接或配置错误而产生环路,进而影响到Switch及其上行网络的通信。

用户希望能在Switch上检测到新建网络中的环路,防止环路影响Switch及其所连网络的正常通信。

图20-8  配置通过Loopback Detection检测设备下挂网络环路示例组网图

配置思路

由于新建部门网络仅有VLAN 100,因此可以在Switch上配置Loopback Detection功能,检测该网络是否存在环路。可采用如下思路配置Loopback Detection功能:

  1. Switch的接口GE1/0/1上使能Loopback Detection功能,并配置对指定VLAN进行环路检测,实现对下行网络环路的检测。
  2. 配置Loopback Detection功能的相关参数,实现Switch在检测到环路后能及时关闭接口GE1/0/1,防止环路影响Switch及其所连网络的正常通信。
说明:

新建网络中的交换设备上需要配置接口的链路类型为Trunk或Hybrid,并允许相应的VLAN通过,以保证新建网络内以及新建网络与Switch间的二层互通。

操作步骤

  1. 使能接口Loopback Detection功能

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] loopback-detect enable
    [Switch-GigabitEthernet1/0/1] quit

  2. 配置接口对指定VLAN进行环路检测

    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 100
    [Switch-GigabitEthernet1/0/1] loopback-detect packet vlan 100
    [Switch-GigabitEthernet1/0/1] quit

  3. 配置Loopback Detection功能的相关参数

    # 配置Loopback Detection检测报文的发送周期。

    [Switch] loopback-detect packet-interval 10

    # 配置Loopback Detection处理动作。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] loopback-detect action shutdown
    [Switch-GigabitEthernet1/0/1] quit

  4. 验证配置结果

    1. 执行命令display loopback-detect检查配置是否成功。

      [Switch] display loopback-detect                                              
      Loopback-detect sending-packet interval: 10
      
      (A): Auto Loopback-detect                                                                                                           
      -----------------------------------------------------------------                                                                   
      Interface                     RecoverTime  Action     Status                                                                        
      -----------------------------------------------------------------
      GigabitEthernet1/0/1          30           shutdown   NORMAL
      -----------------------------------------------------------------

      上述显示信息表明配置成功。

    2. 在下挂网络中构造环路,然后执行命令display loopback-detect检查接口GE1/0/1是否关闭。

      [Switch] display loopback-detect 
      Loopback-detect sending-packet interval: 10                                     
                                                                                      
      (A): Auto Loopback-detect                                                                                                           
      -----------------------------------------------------------------                                                                   
      Interface                     RecoverTime  Action     Status                                                                        
      -----------------------------------------------------------------
      GigabitEthernet1/0/1          30           shutdown   SHUTDOWN
      -----------------------------------------------------------------

      上述显示信息表明,接口GE1/0/1被关闭了。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100
#
loopback-detect packet-interval 10
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 100
 loopback-detect packet vlan 100
 loopback-detect enable
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84465

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页