所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过VLANIF实现同VLAN不同网段通信示例

配置通过VLANIF实现同VLAN不同网段通信示例

组网需求

图4-32所示,某企业网络中,同一VLAN的主机分别属于两个网段10.1.1.1/24和10.1.2.1/24,要求这两个网段的主机都可以通过Switch访问Internet,且这两个网段中的主机能够互通。

图4-32  配置通过VLANIF实现同VLAN不同网段通信组网图

配置思路

针对上述需求,如果在Switch的VLANIF接口上只配置一个IP地址,则只有一个网段的主机能够通过Switch访问Internet。为了使局域网内所有主机都能够通过Switch访问Internet,需要配置VLANIF接口的从IP地址。为了使两个网段中的主机能够互通,两个网段中的主机需要将此主从IP地址分别设置为网关。

可采用如下思路配置通过VLANIF实现同VLAN不同网段用户的通信:

  1. 配置VLAN并将各接口加入VLAN。

  2. 配置VLANIF接口及其IP地址,使两网段的主机间能够互通。

  3. 配置上行路由,使主机可通过Switch访问Internet。

操作步骤

  1. 配置VLAN并将各接口加入VLAN

    # 创建VLAN10和VLAN20。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # 配置接口GE1/0/1GE1/0/2加入VLAN 10,GE1/0/3加入VLAN 20。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 10
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type trunk
    [Switch-GigabitEthernet1/0/3] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet1/0/3] quit
    

  2. 配置VLANIF接口

    # 创建并配置VLANIF10的主IP地址为10.1.1.1/24、从IP地址为10.1.2.1/24,创建并配置VLANIF20的IP地址为10.10.10.1/24。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.1.1 24
    [Switch-Vlanif10] ip address 10.1.2.1 24 sub
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.10.10.1 24
    [Switch-Vlanif20] quit
    

  3. 配置上行路由

    # 配置OSPF基本功能,发布用户网段以及Switch与Router之间的互联网段。

    [Switch] ospf
    [Switch-ospf-1] area 0
    [Switch-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [Switch-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [Switch-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255
    [Switch-ospf-1-area-0.0.0.0] quit
    [Switch-ospf-1] quit
    
    说明:
    Router上需要进行如下配置:
    • 将连接Switch的接口以Tagged方式加入VLAN20,并指定VLANIF20的IP地址与10.10.10.1在同一网段。
    • 配置OSPF基本功能,并发布Switch与Router之间的互联网段。

    具体配置请参见使用设备的产品文档,本文不再赘述。

  4. 验证配置结果

    配置Host1的IP地址为10.1.1.2/24,缺省网关为VLANIF10接口的主IP地址10.1.1.1;配置Host2的IP地址为10.1.2.2/24,缺省网关为VLANIF10接口的从IP地址10.1.2.1。

    配置完成后,Host1和Host2能够互相Ping通,且都可以Ping通Router连接Switch的接口的IP地址10.10.10.2/24,也就都可以访问Internet。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10 20
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
 ip address 10.1.2.1 255.255.255.0 sub
#
interface Vlanif20
 ip address 10.10.10.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 10
# 
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 20
#
ospf 1
 area 0.0.0.0
  network 10.1.1.0 0.0.0.255
  network 10.1.2.0 0.0.0.255
  network 10.10.10.0 0.0.0.255
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84855

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页