所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于协议划分VLAN示例

配置基于协议划分VLAN示例

组网需求

某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务所采用的协议各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

图4-29所示,Switch收到的用户报文有多种业务,所采用的协议各不相同。VLAN10中的用户采用IPv4协议与远端用户通信,而VLAN20中的用户采用IPv6协议与远端服务器通信。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLAN ID分流到不同的远端服务器上以实现业务互通。

图4-29  基于协议划分VLAN组网图

配置思路

采用如下的思路配置基于协议划分VLAN:

  1. 创建VLAN,确定每种业务所属的VLAN。

  2. 关联协议和VLAN,实现根据接口接收到的报文所属的协议(族)类型给报文分配不同的VLAN ID。

  3. 配置接口加入VLAN,允许基于协议的VLAN通过当前接口。
  4. 关联接口和协议VLAN。当有关联的协议进入关联的接口时,系统自动为该协议分配已经划分好的VLAN ID。

操作步骤

  1. 创建VLAN

    # 在Switch1上配置VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch1
    [Switch1] vlan batch 10 20

  2. 配置基于协议划分VLAN

    # 在Switch1上配置VLAN10与协议IPv4关联。

    [Switch1] vlan 10
    [Switch1-vlan10] protocol-vlan ipv4
    [Switch1-vlan10] quit

    # 在Switch1上配置VLAN20与协议IPv6关联。

    [Switch1] vlan 20
    [Switch1-vlan20] protocol-vlan ipv6
    [Switch1-vlan20] quit

  3. 配置接口关联协议VLAN

    # 在Switch1上配置接口GE1/0/2与VLAN10关联,优先级是5。

    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] protocol-vlan vlan 10 all priority 5
    [Switch1-GigabitEthernet1/0/2] quit

    # 在Switch1上配置接口GE1/0/3与VLAN20关联,优先级是6。

    [Switch1] interface gigabitethernet 1/0/3
    [Switch1-GigabitEthernet1/0/3] protocol-vlan vlan 20 all priority 6
    [Switch1-GigabitEthernet1/0/3] quit

  4. 配置接口

    # 在Switch1上配置接口GE1/0/1允许VLAN10和VLAN20通过。

    [Switch1] interface gigabitethernet 1/0/1
    [Switch1-GigabitEthernet1/0/1] port link-type trunk
    [Switch1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20
    [Switch1-GigabitEthernet1/0/1] quit

    # 在Switch1上配置接口GE1/0/2以untagged方式允许VLAN10通过。

    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] port link-type hybrid
    [Switch1-GigabitEthernet1/0/2] port hybrid untagged vlan 10
    [Switch1-GigabitEthernet1/0/2] quit

    # 在Switch1上配置接口GE1/0/3以untagged方式允许VLAN20通过。

    [Switch1] interface gigabitethernet 1/0/3
    [Switch1-GigabitEthernet1/0/3] port link-type hybrid
    [Switch1-GigabitEthernet1/0/3] port hybrid untagged vlan 20
    [Switch1-GigabitEthernet1/0/3] quit

    # 在Switch上配置接口GE1/0/1允许VLAN10和VLAN20通过。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20
    [Switch-GigabitEthernet1/0/1] quit

    # 在Switch上配置接口GE1/0/2允许VLAN10通过。

    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/2] quit

    # 在Switch上配置接口GE1/0/3允许VLAN20通过。

    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type trunk
    [Switch-GigabitEthernet1/0/3] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet1/0/3] quit

  5. 验证配置结果

    上述配置完成后,在Switch1上执行命令display protocol-vlan interface all,可以查看接口关联基于协议划分VLAN的配置信息。

    [Switch1] display protocol-vlan interface all
    -------------------------------------------------------------------------------
     Interface                VLAN    Index        Protocol Type           Priority
    -------------------------------------------------------------------------------
     GigabitEthernet1/0/2     10      0            IPv4                    5
     GigabitEthernet1/0/3     20      0            IPv6                    6
    

配置文件

  • Switch1的配置文件

    #
    sysname Switch1
    #
    vlan batch 10 20
    #
    vlan 10
     protocol-vlan 0 ipv4
    vlan 20
     protocol-vlan 0 ipv6
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid untagged vlan 10
     protocol-vlan vlan 10 0 priority 5
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid untagged vlan 20
     protocol-vlan vlan 20 0 priority 6
    #
    return
  • Switch的配置文件

    #
    sysname Switch
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85934

下载量:1003

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页