所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置AIS功能示例

配置AIS功能示例

组网需求

以太网告警指示信息功能用于在子层检测到故障情况后能够止住上层告警,以减少对网管冲突。

图10-12所示,CE1、CE2分别接入PE1和PE2。PE之间建立VLAN连接。

在PE上部署AIS功能,在CE设备上使能告警抑制功能。在此嵌套场景下,低级别MD的MEP检测到故障后,则会向网管设备发送告警。经过一段时间后,高级别MD的MEP也会检测到故障,从而向网管设备发送相同的告警。在此情况下,需要抑制高级别MD的MEP向网管设备发送相同的告警。

图10-12  配置AIS功能组网图

配置思路

采用如下的思路配置AIS功能:

  1. 配置PE之间MD、CE之间MD,并且PE之间MD的level级别低于CE之间MD的level级别,以实现对高级别告警抑制。

  2. 配置告警抑制功能,以实现不同级别的MD对检测到的相同故障的告警进行抑制。

操作步骤

  1. 配置VLAN连接

    # 配置PE1。

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan batch 2 10
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] port link-type trunk
    [PE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 10
    [PE1-GigabitEthernet1/0/1] quit
    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] port link-type trunk
    [PE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 10
    [PE1-GigabitEthernet1/0/2] quit

    # 配置PE2。

    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan batch 2 10
    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] port link-type trunk
    [PE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 10
    [PE2-GigabitEthernet1/0/1] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] port link-type trunk
    [PE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 10
    [PE2-GigabitEthernet1/0/2] quit

    # 配置CE1。

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan batch 10
    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [CE1-GigabitEthernet1/0/1] quit

    # 配置CE2。

    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] vlan batch 10
    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] port link-type trunk
    [CE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [CE2-GigabitEthernet1/0/1] quit

  2. 配置以太网CFM的基本功能

    在PE上配置以太网CFM的基本功能。MD的名称是md1,MA的名称是ma1,并且配置MA与VLAN绑定。

    # 配置PE1

    [PE1] cfm enable
    [PE1] cfm md md1 level 3
    [PE1-md-md1] ma ma1
    [PE1-md-md1-ma-ma1] map vlan 2
    [PE1-md-md1-ma-ma1] quit
    [PE1-md-md1] quit

    # 配置PE2

    [PE2] cfm enable
    [PE2] cfm md md1 level 3
    [PE2-md-md1] ma ma1
    [PE2-md-md1-ma-ma1] map vlan 2
    [PE2-md-md1-ma-ma1] quit
    [PE2-md-md1] quit

    在CE上配置以太网CFM的基本功能。MD的名称是md2,MA的名称是ma2。

    # 配置CE1

    [CE1] cfm enable
    [CE1] cfm md md2 level 6
    [CE1-md-md2] ma ma2
    [CE1-md-md2-ma-ma2] map vlan 10
    [CE1-md-md2-ma-ma2] quit
    [CE1-md-md2] quit

    # 配置CE2

    [CE2] cfm enable
    [CE2] cfm md md2 level 6
    [CE2-md-md2] ma ma2
    [CE2-md-md2-ma-ma2] map vlan 10
    [CE2-md-md2-ma-ma2] quit
    [CE2-md-md2] quit

  3. 在PE上配置CE侧接口的Inward型的MEP

    # 配置PE1

    [PE1] cfm md md1
    [PE1-md-md1] ma ma1
    [PE1-md-md1-ma-ma1] mep mep-id 31 interface gigabitethernet 1/0/1 inward
    [PE1-md-md1-ma-ma1] mep ccm-send enable
    [PE1-md-md1-ma-ma1] remote-mep mep-id 32
    [PE1-md-md1-ma-ma1] remote-mep ccm-receive enable
    [PE1-md-md1-ma-ma1] quit
    [PE1-md-md1] quit

    # 配置PE2

    [PE2] cfm md md1
    [PE2-md-md1] ma ma1
    [PE2-md-md1-ma-ma1] mep mep-id 32 interface gigabitethernet 1/0/1 inward
    [PE2-md-md1-ma-ma1] mep ccm-send enable
    [PE2-md-md1-ma-ma1] remote-mep mep-id 31
    [PE2-md-md1-ma-ma1] remote-mep ccm-receive enable
    [PE2-md-md1-ma-ma1] quit
    [PE2-md-md1] quit

  4. 在CE上配置Outward类型的MEP

    # 配置CE1

    [CE1] cfm md md2
    [CE1-md-md2] ma ma2
    [CE1-md-md2-ma-ma2] mep mep-id 61 interface gigabitethernet 1/0/1 outward
    [CE1-md-md2-ma-ma2] ccm-interval 10000
    [CE1-md-md2-ma-ma2] mep ccm-send enable
    [CE1-md-md2-ma-ma2] remote-mep mep-id 62
    [CE1-md-md2-ma-ma2] remote-mep ccm-receive enable
    [CE1-md-md2-ma-ma2] quit
    [CE1-md-md2] quit

    # 配置CE2

    [CE2] cfm md md2
    [CE2-md-md2] ma ma2
    [CE2-md-md2-ma-ma2] mep mep-id 62 interface gigabitethernet 1/0/1 outward
    [CE2-md-md2-ma-ma2] ccm-interval 10000
    [CE2-md-md2-ma-ma2] mep ccm-send enable
    [CE2-md-md2-ma-ma2] remote-mep mep-id 61
    [CE2-md-md2-ma-ma2] remote-mep ccm-receive enable
    [CE2-md-md2-ma-ma2] quit
    [CE2-md-md2] quit

  5. 验证CFM配置结果。

    # 在CE1和PE1上执行命令display cfm remote-mep,可以查看到MEP信息。

    [CE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md2
     Level              : 6
     MA Name            : ma2
     RMEP ID            : 62
     VLAN ID            : 10
     VSI Name           : --
     L2VC ID            : --
     MAC                : 00e0-0003-0003
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up  
    [PE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md1
     Level              : 3
     MA Name            : ma1
     RMEP ID            : 32
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up  

  6. 配置AIS功能

    # 配置PE1

    [PE1] cfm md md1
    [PE1-md-md1] ma ma1
    [PE1-md-md1-ma-ma1] ais enable
    [PE1-md-md1-ma-ma1] ais link-status interface gigabitethernet 1/0/2
    [PE1-md-md1-ma-ma1] ais level 6
    [PE1-md-md1-ma-ma1] ais interval 1
    [PE1-md-md1-ma-ma1] ais vlan vid 10 mep 31
    [PE1-md-md1-ma-ma1] quit
    [PE1-md-md1] quit

    # 配置PE2

    [PE2] cfm md md1
    [PE2-md-md1] ma ma1
    [PE2-md-md1-ma-ma1] ais enable
    [PE2-md-md1-ma-ma1] ais link-status interface gigabitethernet 1/0/2
    [PE2-md-md1-ma-ma1] ais level 6
    [PE2-md-md1-ma-ma1] ais interval 1
    [PE2-md-md1-ma-ma1] ais vlan vid 10 mep 32
    [PE2-md-md1-ma-ma1] quit
    [PE2-md-md1] quit

  7. 使能告警抑制功能

    # 配置CE1

    [CE1] cfm md md2
    [CE1-md-md2] ma ma2
    [CE1-md-md2-ma-ma2] ais enable
    [CE1-md-md2-ma-ma2] ais suppress-alarm
    [CE1-md-md2-ma-ma2] quit
    [CE1-md-md2] quit

    # 配置CE2

    [CE2] cfm md md2
    [CE2-md-md2] ma ma2
    [CE2-md-md2-ma-ma2] ais enable
    [CE2-md-md2-ma-ma2] ais suppress-alarm
    [CE2-md-md2-ma-ma2] quit
    [CE2-md-md2] quit

  8. 验证配置结果

    # 完成以上配置后,在PE1设备上接口GE1/0/2接口下执行shutdown命令

    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] shutdown
    [PE1-GigabitEthernet1/0/2] quit

    # 在PE1上执行display cfm ma md md1 ma ma1命令,可以看到“Sending Ais Packet”字段的值为“Yes”;在CE1上执行display cfm ma md md2 ma ma2命令,“Suppressing Alarms”字段的值为“Yes”。

    [PE1] display cfm ma md md1 ma ma1
      MD Name            : md1
      MD Name Format     : string
      Level              : 3
      MIP Create-type    : none
      SenderID TLV-type  : defer
      MA Name            : ma1
      MA Name Format     : string
      Interval           : 1000
      Priority           : 7
      VLAN ID            : 2
      VSI Name           : --
      L2VC ID            : --
      MEP Number         : 1
      RMEP Number        : 1
      Suppressing Alarms : No
      Sending AIS Packet : Yes
      Interface TLV      : disabled 
      RDI Track-action   : all-enabled
    [CE1] display cfm ma md md2 ma ma2
      MD Name            : md2
      MD Name Format     : string
      Level              : 6
      MIP Create-type    : none
      SenderID TLV-type  : defer
      MA Name            : ma2
      MA Name Format     : string
      Interval           : 10000
      Priority           : 7
      VLAN ID            : 10
      VSI Name           : --
      L2VC ID            : --
      MEP Number         : 1
      RMEP Number        : 1
      Suppressing Alarms : Yes
      Sending AIS Packet : No
      Interface TLV      : disabled 
      RDI Track-action   : all-enabled

配置文件

  • PE1的配置文件

    #
    sysname PE1
    #
    vlan batch 2 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    cfm md md1 level 3
     ma ma1
      map vlan 2
      mep mep-id 31 interface GigabitEthernet1/0/1 inward
      mep ccm-send mep-id 31 enable
      remote-mep mep-id 32
      remote-mep ccm-receive mep-id 32 enable
      ais enable
      ais level 6
      ais vlan vid 10 mep 31
      ais link-status interface GigabitEthernet1/0/2
    #
    return 
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 2 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    cfm md md1 level 3
     ma ma1
      map vlan 2
      mep mep-id 32 interface GigabitEthernet1/0/1 inward
      mep ccm-send mep-id 32 enable
      remote-mep mep-id 31
      remote-mep ccm-receive mep-id 31 enable
      ais enable
      ais level 6
      ais vlan vid 10 mep 32
      ais link-status interface GigabitEthernet1/0/2
    #
    return 
  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    cfm md md2 level 6
     ma ma2
      map vlan 10
      ccm-interval 10000
      mep mep-id 61 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 61 enable
      remote-mep mep-id 62
      remote-mep ccm-receive mep-id 62 enable
      ais enable
      ais suppress-alarm
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    vlan batch 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    cfm md md2 level 6
     ma ma2
      map vlan 10
      ccm-interval 10000
      mep mep-id 62 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 62 enable
      remote-mep mep-id 61
      remote-mep ccm-receive mep-id 61 enable
      ais enable
      ais suppress-alarm
    #
    return
翻译
下载文档
更新时间:2019-04-18

文档编号:EDOC1000141468

浏览量:10216

下载量:794

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页