所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置CFM和CFM联动示例

配置CFM和CFM联动示例

组网需求

随着网络的快速发展,IP网络越来越多的承载语音、视频等多种业务,这些业务对网络的高可靠性提出了更高的要求,从而网络要求更快的故障感知能力和故障处理速度。

通常在网络中部署链路检测协议,实现与相邻设备之间链路连通性及其故障的检测。但是面对越来越复杂的网络环境,要想依靠单一的检测技术完成网络中所有链路的故障检测几乎无法实现。因此需要在对网络环境和用户需求进行细致分析的基础上,综合运用各种检测技术实现链路的故障检测和故障传递。

图9-21所示,SwitchA、SwitchB和SwitchC二层互通,用户希望:

  • 能够监测链路SwitchA到SwitchB和SwitchB到SwitchC链路连通性状况。

  • 当SwitchA到SwitchB之间链路发生故障时,远端SwitchC设备能够感知到该故障。

图9-21  配置CFM和CFM联动组网图

配置思路

采用如下的思路配置CFM和CFM联动功能:

  1. 创建VLAN,并将相关接口加入对应的VLAN。

  2. 在SwitchA和SwitchB、SwitchB和SwitchC之间分别配置CFM功能,以实现对链路的监测。

  3. 在SwitchB和SwitchC上配置CFM和CFM的联动功能。

操作步骤

  1. 创建VLAN,并将相关接口加入对应的VLAN。

    # 配置SwitchA。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit

    # 配置SwitchB。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 10 20
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] port link-type trunk
    [SwitchB-GigabitEthernet2/0/1] port trunk allow-pass vlan 20
    [SwitchB-GigabitEthernet2/0/1] quit

    # 配置SwitchC。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 20
    [SwitchC] interface gigabitethernet 2/0/1
    [SwitchC-GigabitEthernet2/0/1] port link-type trunk
    [SwitchC-GigabitEthernet2/0/1] port trunk allow-pass vlan 20
    [SwitchC-GigabitEthernet2/0/1] quit

  2. 配置SwitchA和SwitchB之间的CFM功能。

    # 配置SwitchA。

    [SwitchA] cfm enable
    [SwitchA] cfm md md1
    [SwitchA-md-md1] ma ma1
    [SwitchA-md-md1-ma-ma1] map vlan 10
    [SwitchA-md-md1-ma-ma1] mep mep-id 1 interface gigabitethernet 1/0/1 outward
    [SwitchA-md-md1-ma-ma1] remote-mep mep-id 2
    [SwitchA-md-md1-ma-ma1] mep ccm-send enable
    [SwitchA-md-md1-ma-ma1] remote-mep ccm-receive enable
    [SwitchA-md-md1-ma-ma1] quit
    [SwitchA-md-md1] quit

    # 配置SwitchB。

    [SwitchB] cfm enable
    [SwitchB] cfm md md1
    [SwitchB-md-md1] ma ma1
    [SwitchB-md-md1-ma-ma1] map vlan 10
    [SwitchB-md-md1-ma-ma1] mep mep-id 2 interface gigabitethernet 1/0/1 outward
    [SwitchB-md-md1-ma-ma1] remote-mep mep-id 1
    [SwitchB-md-md1-ma-ma1] mep ccm-send enable
    [SwitchB-md-md1-ma-ma1] remote-mep ccm-receive enable
    [SwitchB-md-md1-ma-ma1] quit
    [SwitchB-md-md1] quit

  3. 配置SwitchB和SwitchC之间的CFM功能。

    # 配置SwitchB。

    [SwitchB] cfm md md1
    [SwitchB-md-md1] ma ma2
    [SwitchB-md-md1-ma-ma2] map vlan 20
    [SwitchB-md-md1-ma-ma2] mep mep-id 1 interface gigabitethernet 2/0/1 outward
    [SwitchB-md-md1-ma-ma2] remote-mep mep-id 2
    [SwitchB-md-md1-ma-ma2] mep ccm-send enable
    [SwitchB-md-md1-ma-ma2] remote-mep ccm-receive enable
    [SwitchB-md-md1-ma-ma2] quit
    [SwitchB-md-md1] quit

    # 配置SwitchC。

    [SwitchC] cfm enable
    [SwitchC] cfm md md1
    [SwitchC-md-md1] ma ma2
    [SwitchC-md-md1-ma-ma2] map vlan 20
    [SwitchC-md-md1-ma-ma2] mep mep-id 2 interface gigabitethernet 2/0/1 outward
    [SwitchC-md-md1-ma-ma2] remote-mep mep-id 1
    [SwitchC-md-md1-ma-ma2] mep ccm-send enable
    [SwitchC-md-md1-ma-ma2] remote-mep ccm-receive enable
    [SwitchC-md-md1-ma-ma2] quit
    [SwitchC-md-md1] quit

    在SwitchB上执行display cfm remote-mep查看CFM状态,显示结果为UP。

    [SwitchB] display cfm remote-mep
    The total number of RMEPs is : 2
    The status of RMEPs : 2 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md1
     Level              : 0
     MA Name            : ma1
     RMEP ID            : 1
     VLAN ID            : 10
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0025-9efb-494a
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up
    
     MD Name            : md1
     Level              : 0
     MA Name            : ma2
     RMEP ID            : 2
     VLAN ID            : 20
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0002-0003-0161
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up

  4. 配置CFM和CFM的联动。

    # 配置SwitchA与SwitchB之间的CFM和SwitchB与SwitchC之间的CFM的双向联动。

    [SwitchB] oam-mgr
    [SwitchB-oam-mgr] oam-bind cfm md md1 ma ma1 cfm md md1 ma ma2
    [SwitchB-oam-mgr] quit

  5. 检查配置结果。

    # 关闭SwitchB的接口GE2/0/1

    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] shutdown
    [SwitchB-GigabitEthernet2/0/1] quit

    # 在SwitchA上执行命令display cfm remote-mep查看SwitchA和SwitchB之间的CFM状态,显示CFM的状态为Down。

    [SwitchA]display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 0 up, 1 down, 0 disable
    --------------------------------------------------
     MD Name            : md1
     Level              : 0
     MA Name            : ma1
     RMEP ID            : 2
     VLAN ID            : 10
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : down
     Alarm Status       : RDI
     Interface TLV      : --
     Connect Status     : up

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    cfm md md1
     ma ma1
      map vlan 10
      mep mep-id 1 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 1 enable
      remote-mep mep-id 2
      remote-mep ccm-receive mep-id 2 enable
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    cfm md md1
     ma ma1
      map vlan 10
      mep mep-id 2 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 2 enable
      remote-mep mep-id 1
      remote-mep ccm-receive mep-id 1 enable
     ma ma2
      map vlan 20
      mep mep-id 1 interface GigabitEthernet2/0/1 outward
      mep ccm-send mep-id 1 enable
      remote-mep mep-id 2
      remote-mep ccm-receive mep-id 2 enable
    #
    oam-mgr
     oam-bind ingress cfm md md1 ma ma1 egress cfm md md1 ma ma2
     oam-bind ingress cfm md md1 ma ma2 egress cfm md md1 ma ma1
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    cfm enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    cfm md md1
     ma ma2
      map vlan 20
      mep mep-id 2 interface GigabitEthernet2/0/1 outward
      mep ccm-send mep-id 2 enable
      remote-mep mep-id 1
      remote-mep ccm-receive mep-id 1 enable
    #
    return
翻译
下载文档
更新时间:2019-04-18

文档编号:EDOC1000141468

浏览量:8810

下载量:783

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页