所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Smart Link通知VPLS模块感知链路切换示例

配置Smart Link通知VPLS模块感知链路切换示例

组网需求

图6-20所示,CE1通过PE2和PE1的dot1q子接口双归接入VPLS网络,CE1两个接口间运行Smart Link协议,正常情况下只有主链路传送业务数据。

如果主链路故障,Smart Link协议将打开阻断的接口,业务数据从该接口传送到相连的PE设备。需要引入一种机制,通知VPLS模块清除本端VSI转发表项,同时触发相关设备清空VSI的转发表,以将CE2的回程业务流量引到正常的链路。

图6-20  配置CE通过Smart Link双归接入VPLS示例组网图

配置思路

采用如下的思路配置CE通过Smart Link双归接入VPLS:

  1. 配置VPLS。
  2. CE1上配置Smart Link,通过PE1和PE2双上行接入到VPLS网络。
  3. CE1上使能回切功能,使得故障回复后,流量切换到相对稳定的原主链路上。
  4. CE1上使能发送Flush报文功能。
  5. PE1和PE2两台设备相应接口上使能Flush报文接收功能和接口收到Flush报文后通知VPLS模块功能,使得网络对端的CE2可以迅速感知CE1端的网络变化。
  6. 在CE1上使能Smart Link组功能。

操作步骤

  1. 在PE1、PE2、PE3和PE4上配置VPLS网络

    略。具体配置方法请参见S7700, S9700 V200R010C00 配置指南-VPN》 VPLS配置。

  2. 配置Dot1q子接口接入VPLS

    略。具体配置方法请参见S7700, S9700 V200R010C00 配置指南-以太网交换》 QinQ配置。

  3. 在CE1上配置VLAN,并将上行链路接口加入该VLAN中

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan batch 10
    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [CE1-GigabitEthernet1/0/1] quit
    [CE1] interface gigabitethernet 1/0/2
    [CE1-GigabitEthernet1/0/2] port link-type trunk
    [CE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [CE1-GigabitEthernet1/0/2] quit

  4. 在PE1和PE2上配置VLAN,并将下行链路接口加入该VLAN中

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan batch 10
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] port link-type trunk
    [PE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [PE1-GigabitEthernet1/0/1] quit
    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] port link-type trunk
    [PE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [PE1-GigabitEthernet1/0/2] quit
    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan batch 10
    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] port link-type trunk
    [PE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [PE2-GigabitEthernet1/0/1] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] port link-type trunk
    [PE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [PE2-GigabitEthernet1/0/2] quit

  5. 将去使能STP功能的上行接口加入Smart Link组并指定为主接口或从接口

    # 去使能接口的STP功能。

    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] stp disable
    [CE1-GigabitEthernet1/0/1] quit
    [CE1] interface gigabitethernet 1/0/2
    [CE1-GigabitEthernet1/0/2] stp disable
    [CE1-GigabitEthernet1/0/2] quit

    # 配置Smart Link组的主接口和从接口。

    [CE1] smart-link group 1
    [CE1-smlk-group1] port gigabitethernet 1/0/1 master
    [CE1-smlk-group1] port gigabitethernet 1/0/2 slave
    

  6. 使能回切功能并设置回切时间

    [CE1-smlk-group1] restore enable
    [CE1-smlk-group1] timer wtr 30
    

  7. 使能发送Flush报文功能,并指定发送Flush报文的密码为SHA加密方式。

    [CE1-smlk-group1] flush send control-vlan 10 password sha huawei-123
    

  8. 使能PE1和PE2接收Flush报文功能和接口收到Flush报文后通知VPLS模块功能

    # 配置PE1,并指定接收Flush报文的密码为SHA加密方式。

    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] smart-link flush receive control-vlan 10 password sha huawei-123
    [PE1-GigabitEthernet1/0/2] stp disable
    [PE1-GigabitEthernet1/0/2] smart-link vpls-notify enable
    [PE1-GigabitEthernet1/0/2] quit
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] smart-link flush receive control-vlan 10 password sha huawei-123
    [PE1-GigabitEthernet1/0/1] stp disable
    [PE1-GigabitEthernet1/0/1] quit
    

    # 配置PE2,并指定接收Flush报文的密码为SHA加密方式。

    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] smart-link flush receive control-vlan 10 password sha huawei-123
    [PE2-GigabitEthernet1/0/1] stp disable
    [PE2-GigabitEthernet1/0/1] smart-link vpls-notify enable
    [PE2-GigabitEthernet1/0/1] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] smart-link flush receive control-vlan 10 password sha huawei-123
    [PE2-GigabitEthernet1/0/2] stp disable
    [PE2-GigabitEthernet1/0/2] quit
    

  9. 使能Smart Link组功能

    [CE1-smlk-group1] smart-link enable
    [CE1-smlk-group1] quit

  10. 验证配置结果

    # 使用display smart-link group命令查看CE1上的Smart Link组信息。如果显示如下信息,则表示配置成功。

    • Smart Link组功能已经使能
    • 控制VLAN编号为10
    • 接口GigabitEthernet1/0/1为主接口且处于Active状态,接口GigabitEthernet1/0/2为从接口且处于Inactive
    [CE1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
          Member              Role    State     Flush Count  Last-Flush-Time
      ----------------------------------------------------------------------
    
      GigabitEthernet1/0/1    Master  Active    1            2009/01/05 10:33:46 UTC+05:00
      GigabitEthernet1/0/2    Slave   Inactive  0            0000/00/00 00:00:00 UTC+05:00

    # 使用shutdown命令关闭接口GigabitEthernet1/0/1,可以看到接口GigabitEthernet1/0/1处于Inactive状态,接口GigabitEthernet1/0/2为Active状态。

    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] shutdown
    [CE1-GigabitEthernet1/0/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
          Member              Role    State     Flush Count  Last-Flush-Time
      ----------------------------------------------------------------------
    
      GigabitEthernet1/0/1    Master  Inactive  1            2009/01/05 10:33:46 UTC+05:00
      GigabitEthernet1/0/2    Slave   Active    1            2009/01/05 10:37:58 UTC+05:00

配置文件

说明:

本例只介绍Smart Link的相关配置,有关VPLS的配置文件请参见S7700, S9700 V200R010C00 配置指南-VPN》 VPLS配置。

  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    smart-link group 1
     restore enable
     smart-link enable
     port GigabitEthernet1/0/1 master
     port GigabitEthernet1/0/2 slave
     timer wtr 30
     flush send control-vlan 10 password sha %^%#tqK>L$S,8A/:R*FU_f1QXJuxI]JC(O+n$G@D)&(2rGp\&|y&Z$Z/kI.5n>7K%^%#
    #
    return
  • PE1的配置文件

    #
    sysname PE1
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#iG"AHS*M.0TW{@,rv$aE$9v7E]kVgV~#81Dh'Ab@Z;_sO\-arQ_a6PW8Eho*%^%#
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#.I*]L+_l:W@+F7ZAPK'JPu0=+q3+lBeE!}8F6z5-Kv.d'Q8EB'o{\l9,$3W#%^%#
     smart-link vpls-notify enable
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#ZEztD1c"="ST$-:J<500`&vh'}vg~(X2.o~~v6L;B;^mX0RpU!hphI-&b<7L%^%#
     smart-link vpls-notify enable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#n),g7Yzan"a\*>DH)Pg=LF@g'y2mA2C`&jVRT%~ILcg+0^|#L.ik\OKpE0#Q%^%#
    #
    return
翻译
下载文档
更新时间:2019-04-18

文档编号:EDOC1000141468

浏览量:8635

下载量:783

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页