所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置BFD多跳检测示例

配置BFD多跳检测示例

组网需求

图2-22所示,SwitchA和SwitchC为非直连设备,通过配置静态路由互通。用户希望可以实现对设备间链路故障的快速检测。

图2-22  配置BFD多跳检测组网图

配置思路

采用如下思路配置BFD多跳检测:

SwitchA和SwitchC上分别配置BFD会话,实现SwitchA到SwitchC间多跳路径的检测。

操作步骤

  1. 配置设备间的网络互连

    # 配置设备各接口的IP地址,以SwitchA为例。SwitchB和SwitchC的配置与SwitchA类似,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit

  2. 配置静态路由,使SwitchA、SwitchC之间有可达路由

    # SwitchC的配置与SwitchA类似,具体配置过程略,详见配置文件。

    [SwitchA] ip route-static 10.2.1.0 24 10.1.1.2
    

  3. 配置多跳BFD检测

    # 在SwitchA上配置与SwitchC之间的BFD会话。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd atoc bind peer-ip 10.2.1.2
    [SwitchA-bfd-session-atoc] discriminator local 10
    [SwitchA-bfd-session-atoc] discriminator remote 20
    [SwitchA-bfd-session-atoc] commit
    [SwitchA-bfd-session-atoc] quit

    # 在SwitchC上配置与SwitchA之间的BFD会话。

    [SwitchC] bfd
    [SwitchC-bfd] quit
    [SwitchC] bfd ctoa bind peer-ip 10.1.1.1
    [SwitchC-bfd-session-ctoa] discriminator local 20
    [SwitchC-bfd-session-ctoa] discriminator remote 10
    [SwitchC-bfd-session-ctoa] commit
    [SwitchC-bfd-session-ctoa] quit

  4. 验证配置结果

    配置完成后,在SwitchA和SwitchC上执行display bfd session all verbose命令,可以看到建立了一个BFD会话,且状态为Up。以SwitchA上的显示为例:

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 4097       (Multi Hop) State : Up      Name : atoc              
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.2.1.2                                             
      Bind Interface         : -                                                    
      Track Interface        : -     
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000      
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 254        
      Proc Interface Status  : Disable          Process PST            : Disable    
      WTR Interval (ms)      : -                   
      Active Multi           : 3                DSCP                   : - 
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : -                Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 1/0
    

    # 对SwitchA的GE1/0/1接口执行shutdown操作,模拟链路故障。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] shutdown
    [SwitchA-GigabitEthernet1/0/1] quit

    配置完成后,在SwitchA和SwitchC上执行display bfd session all verbose命令,可以看到建立了一个多跳检测的BFD会话,且会话状态为Down。以SwitchA上的显示为例:

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 4097       (Multi Hop) State : Down      Name : atoc              
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.2.1.2                                             
      Bind Interface         : -                                             
      Track Interface        : -     
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 13000            Actual Rx Interval (ms): 13000      
      Local Detect Multi     : 3                Detect Interval (ms)   : -          
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 254        
      Proc Interface Status  : Disable          Process PST            : Disable    
      WTR Interval (ms)      : -                   
      Active Multi           : 3                DSCP                   : - 
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : 16897            Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 0/1
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    bfd atoc bind peer-ip 10.2.1.2
     discriminator local 10
     discriminator remote 20
     commit
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet2/0/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    bfd
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    bfd ctoa bind peer-ip 10.1.1.1
     discriminator local 20
     discriminator remote 10
     commit
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
翻译
下载文档
更新时间:2019-04-18

文档编号:EDOC1000141468

浏览量:8714

下载量:783

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页