所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-可靠性

本文档针对设备可靠性业务,主要包括BFD配置、DLDP配置、VRRP配置、Smart Link和Monitor Link配置、EFM配置、CFM配置、Y.1731配置和MAC Swap配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置CFM和EFM联动示例

配置CFM和EFM联动示例

组网需求

随着网络的快速发展,IP网络越来越多的承载语音、视频等多种业务,这些业务对网络的高可靠性提出了更高的要求,从而运营商网络要求更快的故障感知能力和故障处理速度。

通常在网络中部署链路检测协议,实现与相邻设备之间链路连通性及其故障的检测。但是面对越来越复杂的网络环境,要想依靠单一的检测技术完成网络中所有链路的故障检测几乎无法实现。因此需要在对网络环境和用户需求进行细致分析的基础上,综合运用各种检测技术实现链路的故障检测。

图9-22所示,CE1双归接入PE1和PE3设备。用户希望
  • 能够监测CE1到PE3、PE3到PE4和PE4到CE2之间链路的连通性。

  • 当CE1到PE3之间链路发生故障时,远端CE2设备能够感知该故障,避免用户侧流量继续发往PE4设备。

  • 当PE3到PE4之间链路发生故障时,远端CE1或者CE2设备能够感知该故障。

  • 当CE1到PE3之间链路发生故障时,实现主用链路到备用链路的切换。

图9-22  配置EFM与CFM联动功能组网图

配置思路

采用如下思路配置EFM功能:
  1. 在CE1到PE3和CE2到PE4之间部署EFM协议,自动检测CE1到PE3和CE2到PE4之间链路的连通性。

  2. 在PE3到PE4之间部署CFM协议,自动检测PE3到PE4之间链路的连通性。

  3. 在CE2设备上配置EFM和接口联动,当EFM检测到CE1到PE3之间链路故障时,实将接口置为逻辑Down。

  4. 在PE3和PE4设备上配置CFM和EFM联动功能,当CFM或者EFM检测到链路故障时,实现故障的双向传递。

操作步骤

  1. 配置EFM基本功能

    # 全局使能CE1的EFM功能。

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] efm enable

    # 全局使能CE2的EFM功能。

    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] efm enable

    # 全局使能PE3的EFM功能。

    <HUAWEI> system-view
    [HUAWEI] sysname PE3
    [PE3] efm enable

    # 全局使能PE4的EFM功能。

    <HUAWEI> system-view
    [HUAWEI] sysname PE4
    [PE4] efm enable

    # 使能CE1上接口GE1/0/1的EFM功能。

    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] efm enable
    [CE1-GigabitEthernet1/0/1] quit

    # 使能CE2上接口GE1/0/1的EFM功能。

    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] efm enable
    [CE2-GigabitEthernet1/0/1] quit

    # 使能PE3上接口GE1/0/1的EFM功能。

    [PE3] interface gigabitethernet 1/0/1
    [PE3-GigabitEthernet1/0/1] efm enable
    [PE3-GigabitEthernet1/0/1] quit

    # 使能PE4上接口GE1/0/1的EFM功能。

    [PE4] interface gigabitethernet 1/0/1
    [PE4-GigabitEthernet1/0/1] efm enable
    [PE4-GigabitEthernet1/0/1] quit

    # 检查配置结果

    如果PE3和CE1、PE4和CE2的EFM配置正确,CE1上接口GE1/0/1和PE3上接口GE1/0/1或者CE2上接口GE1/0/1和PE4上接口GE1/0/1上接口成功协商后进入握手阶段,此时分别在CE1、CE2或者PE3、PE4上执行display efm session { all | interface interface-type interface-num }命令,可看到接口GE1/0/1的EFM协议状态为detect

    [CE1] display efm session all
      Interface                 EFM State                   Loopback Timeout
      ----------------------------------------------------------------------
      GigabitEthernet1/0/1     detect                        --

  2. 配置CFM基本功能

    本示例以VLAN的OUTWARD型MEP为例配置CFM基本功能。

    # 配置PE3设备的CFM基本功能

    [PE3] vlan 2
    [PE3-vlan2] quit
    [PE3] interface gigabitethernet 1/0/2
    [PE3-GigabitEthernet1/0/2] port link-type trunk
    [PE3-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [PE3-GigabitEthernet1/0/2] quit
    [PE3] cfm enable
    [PE3] cfm md md1
    [PE3-md-md1] ma ma1
    [PE3-md-md1-ma-ma1] map vlan 2
    [PE3-md-md1-ma-ma1] mep mep-id 1 interface gigabitethernet 1/0/2 outward
    [PE3-md-md1-ma-ma1] remote-mep mep-id 2
    [PE3-md-md1-ma-ma1] mep ccm-send enable
    [PE3-md-md1-ma-ma1] remote-mep ccm-receive enable
    [PE3-md-md1-ma-ma1] quit
    [PE3-md-md1] quit

    # 配置PE4设备的CFM基本功能

    [PE4] vlan 2
    [PE4-vlan2] quit
    [PE4] interface gigabitethernet 1/0/2
    [PE4-GigabitEthernet1/0/2] port link-type trunk
    [PE4-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [PE4-GigabitEthernet1/0/2] quit
    [PE4] cfm enable
    [PE4] cfm md md1
    [PE4-md-md1] ma ma1
    [PE4-md-md1-ma-ma1] map vlan 2
    [PE4-md-md1-ma-ma1] mep mep-id 2 interface gigabitethernet 1/0/2 outward
    [PE4-md-md1-ma-ma1] remote-mep mep-id 1
    [PE4-md-md1-ma-ma1] mep ccm-send enable
    [PE4-md-md1-ma-ma1] remote-mep ccm-receive enable
    [PE4-md-md1-ma-ma1] quit
    [PE4-md-md1] quit

    # 检查配置结果

    如果PE3和PE4的CFM配置正确,此时在PE3或者PE4上执行display cfm remote-mep命令,可看到“CFM Status”字段的值为状态为Up。

    [PE3] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md1
     Level              : 0
     MA Name            : ma1
     RMEP ID            : 2
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5411
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up

  3. 配置EFM和CFM联动

    # 在PE3上配置EFM与CFM联动。

    [PE3] oam-mgr
    [PE3-oam-mgr] oam-bind cfm md md1 ma ma1 efm interface gigabitethernet 1/0/1
    [PE3-oam-mgr] quit

    # 在PE4上配置EFM与CFM联动。

    [PE4] oam-mgr
    [PE4-oam-mgr] oam-bind cfm md md1 ma ma1 efm interface gigabitethernet 1/0/1
    [PE4-oam-mgr] quit

  4. 在CE2上配置EFM和接口联动功能

    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] efm trigger if-down
    [CE2-GigabitEthernet1/0/1] quit

  5. 检查配置结果。

    # 联动功能配置完成后,可以在CE1设备上接口GE1/0/1接口下执行shutdown命令,模拟CE1和PE3之间链路故障。

    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] shutdown
    [CE1-GigabitEthernet1/0/1] quit

    # 在CE2接口GE1/0/1上执行display interface interface-type interface-num命令查看当前接口的状态,可以看到字段“Line protocol current state”的值为DOWN (EFM down),表示故障从CE1到PE3侧传递到PE4到CE2侧。

    [CE2] display interface gigabitethernet 1/0/1
    GigabitEthernet1/0/1 current state : UP
    Line protocol current state : DOWN (EFM down)
    ...
    
    说明:

    此处只列了display interface gigabitethernet 1/0/1命令需要关注的显式信息,“...”表示省略。

配置文件

  • CE1的配置文件

    #                                                                               
    sysname CE1                                                                
    #                                                                               
    efm enable                                        
    #                                                                            
    interface GigabitEthernet1/0/1            
     efm enable
    #                                                                               
    return                                   
  • PE3的配置文件

    #                                                                               
    sysname PE3                                                                
    #                                                                               
    vlan batch 2                                                                   
    #                                                                               
    cfm enable                                                                     
    #                                                                               
    efm enable                                                                      
    #                                                                        
    interface GigabitEthernet1/0/1                                                  
     efm enable                                                                     
    #                                                                               
    interface GigabitEthernet1/0/2                     
     port link-type trunk                                                                    
     port trunk allow-pass vlan 2                                                   
    #
    cfm md md1                                                                     
     ma ma1                                                                        
      map vlan 2                                                                   
      mep mep-id 1 interface GigabitEthernet1/0/2 outward          
      mep ccm-send mep-id 1 enable                                                 
      remote-mep mep-id 2                                                          
      remote-mep ccm-receive mep-id 2 enable                                       
    #                                                                               
    oam-mgr                                                                         
     oam-bind ingress cfm md md1 ma ma1 egress efm interface GigabitEthernet1/0/1   
     oam-bind ingress efm interface GigabitEthernet1/0/1 egress cfm md md1 ma ma1   
    #                                                                           
    return                                                     
  • PE4的配置文件

    #                                                                               
    sysname PE4                                                                
    #                                                                               
    vlan batch 2                                                                   
    #                                                                               
    cfm enable                                                                     
    #                                                                               
    efm enable                                                                      
    #                                                               
    interface GigabitEthernet1/0/1                                                  
     efm enable                                                                     
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                                     
     port trunk allow-pass vlan 2                                                   
    #
    cfm md md1                                                                     
     ma ma1                                                                        
      map vlan 2                                                                   
      mep mep-id 2 interface GigabitEthernet1/0/2 outward                          
      mep ccm-send mep-id 2 enable                                                 
      remote-mep mep-id 1                                                          
      remote-mep ccm-receive mep-id 1 enable                                       
    #                                                                               
    oam-mgr                                                                         
     oam-bind ingress cfm md md1 ma ma1 egress efm interface GigabitEthernet1/0/1   
     oam-bind ingress efm interface GigabitEthernet1/0/1 egress cfm md md1 ma ma1   
    #                                                                            
    return                                                                         
    
  • CE2的配置文件

    #                                                                               
    sysname CE2                                                                
    #                                                                               
    efm enable                                        
    #                                                                            
    interface GigabitEthernet1/0/1                                                  
     efm enable
     efm trigger if-down 
    #                                                                               
    return
翻译
下载文档
更新时间:2019-04-18

文档编号:EDOC1000141468

浏览量:8524

下载量:782

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页