所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置ISATAP隧道示例

配置ISATAP隧道示例

组网需求

图12-14所示,IPv4网络中的IPv6主机为Windows 7系统,需要将IPv6主机通过边界设备接入到IPv6网络。IPv6主机和边界设备均支持ISATAP。要求在IPv6主机和边界设备之间配置ISATAP隧道。

图12-14  配置ISATAP隧道组网图

配置思路

配置ISATAP隧道的思路如下:

  1. 在交换机Switch_1上配置IPv4/IPv6双协议栈,使设备可以同时和IPv4网络以及IPv6网络进行通信。

  2. 在交换机Switch_1上配置ISATAP隧道,使IPv6主机可以通过ISATAP隧道进行通信。

  3. 在交换机Switch_2上配置到ISATAP主机的静态路由。

操作步骤

  1. 配置ISATAP边界设备

    # 配置业务环回聚合接口。

    说明:

    此处做业务环回聚合的接口必须是空闲的,没有承载业务的接口。

    <Quidway> system-view
    [Quidway] sysname Switch_1
    [Switch_1] interface eth-trunk 1
    [Switch_1-Eth-Trunk1] service type tunnel
    [Switch_1-Eth-Trunk1] quit
    [Switch_1] interface gigabitethernet 1/0/3
    [Switch_1-GigabitEthernet1/0/3] eth-trunk 1
    [Switch_1-GigabitEthernet1/0/3] quit
    

    # 使能IPv4/IPv6双协议栈,配置各接口地址。

    [Switch_1] ipv6
    [Switch_1] vlan batch 100 200
    [Switch_1] interface gigabitethernet 1/0/1
    [Switch_1-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch_1-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch_1-GigabitEthernet1/0/1] quit
    [Switch_1] interface gigabitethernet 1/0/2
    [Switch_1-GigabitEthernet1/0/2] port hybrid pvid vlan 200
    [Switch_1-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [Switch_1-GigabitEthernet1/0/2] quit
    [Switch_1] interface vlanif 100
    [Switch_1-Vlanif100] ipv6 enable
    [Switch_1-Vlanif100] ipv6 address fc00:2::1/64
    [Switch_1-Vlanif100] quit
    [Switch_1] interface vlanif 200
    [Switch_1-Vlanif200] ip address 10.1.1.1 255.0.0.0
    [Switch_1-Vlanif200] quit

    # 配置ISATAP隧道。

    [Switch_1] interface tunnel 1
    [Switch_1-Tunnel1] tunnel-protocol ipv6-ipv4 isatap
    [Switch_1-Tunnel1] eth-trunk 1
    [Switch_1-Tunnel1] ipv6 enable
    [Switch_1-Tunnel1] ipv6 address fc00:1::/64 eui-64
    [Switch_1-Tunnel1] source vlanif 200
    [Switch_1-Tunnel1] undo ipv6 nd ra halt
    [Switch_1-Tunnel1] quit

  2. 配置ISATAP主机

    # 使用如下的命令添加一条到边界设备的静态路由(主机的IPv4地址为10.1.1.2/8)。

    C:\> netsh interface ipv6 isatap set router 10.1.1.1
    C:\> netsh
    netsh> interface
    netsh interface> ipv6
    netsh interface ipv6>isatap
    netsh interface ipv6 isatap>set router 10.1.1.1 enabled 1440

  3. 配置Switch_2

    # 配置接口的IPv6地址。

    <Quidway> system-view
    [Quidway] sysname Switch_2
    [Switch_2] ipv6
    [Switch_2] vlan batch 100
    [Switch_2] interface gigabitethernet 1/0/1
    [Switch_2-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch_2-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch_2-GigabitEthernet1/0/1] quit
    [Switch_2] interface vlanif 100
    [Switch_2-Vlanif100] ipv6 enable
    [Switch_2-Vlanif100] ipv6 address fc00:2::2/64
    [Switch_2-Vlanif100] quit
    

    # 配置静态路由。

    [Switch_2] ipv6 route-static fc00:1:: 64 fc00:2::1
    

  4. 验证配置结果

    # 在ISATAP设备上查看Tunnel1的IPv6状态为Up。

    [Switch_1] display ipv6 interface tunnel 1
    Tunnel1 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::5EFE:A01:101
      Global unicast address(es):
        FC00:1::5EFE:A01:101, subnet is FC00:1::/64
      Joined group address(es):
        FF02::1:FF01:101
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND reachable time is 30000 milliseconds
      ND retransmit interval is 1000 milliseconds
      ND stale time is 1200 seconds
      ND advertised reachable time is 0 milliseconds
      ND advertised retransmit interval is 0 milliseconds
      ND router advertisement max interval 600 seconds, min interval 200 seconds
      ND router advertisements live for 1800 seconds
      ND router advertisements hop-limit 64 
      Hosts use stateless autoconfig for addresses

    # 在ISATAP设备上Ping向ISATAP主机上的隧道接口全球单播地址。

    [Switch_1] ping ipv6 FC00:1::5EFE:10.1.1.2
      PING FC00:1::5EFE:10.1.1.2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=1 hop limit=64  time = 4 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=3 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=4 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=5 hop limit=64  time = 2 ms
    
      --- FC00:1::5EFE:10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 2/2/4 ms

    # 在ISATAP主机上Ping向ISATAP设备的全球单播地址。

    C:\> ping fc00:1::5efe:10.1.1.1
    
    Pinging fc00:1::5efe:10.1.1.1
    from fc00:1::5efe:10.1.1.2 with 32 bytes of data:
    
    Reply from fc00:1::5efe:10.1.1.1: time=1ms
    Reply from fc00:1::5efe:10.1.1.1: time=1ms
    Reply from fc00:1::5efe:10.1.1.1:  time=1ms
    Reply from fc00:1::5efe:10.1.1.1: time=1ms
    Ping statistics for fc00:1::5efe:10.1.1.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms

    # 在Switch_2上Ping向ISATAP主机上的隧道接口全球单播地址。

    [Switch_2] ping ipv6 FC00:1::5EFE:10.1.1.2
      PING FC00:1::5EFE:10.1.1.2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=1 hop limit=64  time = 4 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=3 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=4 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=5 hop limit=64  time = 2 ms
    
      --- FC00:1::5EFE:10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 2/2/4 ms

配置文件

  • Switch_1的配置文件

    #
    sysname Switch_1
    #
    ipv6
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ipv6 enable 
     ipv6 address FC00:2::1/64
    #
    interface Vlanif200
     ip address 10.1.1.1 255.0.0.0
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:1::/64 eui-64
     undo ipv6 nd ra halt
     tunnel-protocol ipv6-ipv4 isatap
     source Vlanif200
     eth-trunk 1
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    return
  • Switch_2的配置文件

    #
    sysname Switch_2
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ipv6 enable 
     ipv6 address FC00:2::2/64
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ipv6 route-static FC00:1:: 64 FC00:2::1 
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141518

浏览量:13680

下载量:292

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页