所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置DNS客户端示例

配置DNS客户端示例

组网需求

由于IP地址难于记忆,用户希望通过DNS域名请求方式访问网络服务器。用户希望输入域名部分字段,DNS服务器就可以正确解析,达到用户访问正确网络服务的效果。例如DNS客户端在访问该主机huawei.com时,用户只需要输入“huawei”即可。对于一些常用的域名,用户希望能够快速访问,提高域名解析的效率。

图4-3  配置DNS客户端组网图

配置思路

DNS的配置思路如下:

  1. 在SwitchA上配置静态DNS表项,实现与HostB和HostC进行通信的功能。

  2. 在SwitchA上配置动态DNS功能,实现SwitchA以动态DNS查询方式与网络服务器进行通信的功能。

  3. 在SwitchA配置域名后缀,实现SwitchA可以实现域名后缀列表功能。

  4. 配置Switch上的OSPF路由,实现各设备之间的路由可达。

操作步骤

  1. 配置设备SwitchA

    # 配置VLANIF101接口的IP地址。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 101
    [SwitchA-vlan101] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 101
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 101
    [SwitchA-Vlanif101] ip address 10.1.1.2 255.255.0.0
    [SwitchA-Vlanif101] quit

    # 配置OSPF。

    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.0.0 0.0.255.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # 配置静态DNS表项。

    [SwitchA] ip host hostB 10.4.1.1
    [SwitchA] ip host hostC 10.4.1.2

    # 使能DNS域名解析功能。

    [SwitchA] dns resolve

    # 配置DNS服务器的IP地址。

    [SwitchA] dns server 10.3.1.2

    # 配置域名后缀net。

    [SwitchA] dns domain net

    # 配置域名后缀com。

    [SwitchA] dns domain com
    [SwitchA] quit
    说明:

    若要完成对域名的解析,还需要在SwitchB和SwitchC上配置OSPF,以保证设备之间路由可达。SwitchB和SwitchC的OSPF具体配置参看配置文件。

  2. 验证配置结果

    # 在设备SwitchA上执行ping hostB命令,可以ping通,且对应的目的地址为10.4.1.1。

    <SwitchA> ping hostB 
      PING hostB (10.4.1.1): 56  data bytes, press CTRL_C to break                   
        Reply from 10.4.1.1: bytes=56 Sequence=1 ttl=254 time=1 ms                   
        Reply from 10.4.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms                   
        Reply from 10.4.1.1: bytes=56 Sequence=3 ttl=254 time=1 ms                   
        Reply from 10.4.1.1: bytes=56 Sequence=4 ttl=254 time=1 ms                   
        Reply from 10.4.1.1: bytes=56 Sequence=5 ttl=254 time=1 ms                   
                                                                                    
      --- hostB ping statistics ---                                                 
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 1/1/1 ms  

    # 在设备SwitchA上执行ping huawei.com命令,可以ping通,且对应的目的地址为10.2.1.3。

    <SwitchA> ping huawei.com
      PING huawei.com (10.2.1.3): 56  data bytes, press CTRL_C to break
        Reply from 10.2.1.3: bytes=56 Sequence=1 ttl=126 time=6 ms
        Reply from 10.2.1.3: bytes=56 Sequence=2 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=3 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=4 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=5 ttl=126 time=4 ms
    
      --- huawei.com ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 4/4/6 ms
    
    

    # 在设备SwitchA上执行ping huawei命令,可以ping通,且对应的域名变为huawei.com,目的地址为10.2.1.3。

    <SwitchA> ping huawei
      PING huawei.com (10.2.1.3): 56  data bytes, press CTRL_C to break
        Reply from 10.2.1.3: bytes=56 Sequence=1 ttl=126 time=6 ms
        Reply from 10.2.1.3: bytes=56 Sequence=2 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=3 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=4 ttl=126 time=4 ms
        Reply from 10.2.1.3: bytes=56 Sequence=5 ttl=126 time=4 ms
    
      --- huawei.com ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 4/4/6 ms
    

    # 在SwitchA用display ip host命令可以查看到静态DNS表项中主机名和IP地址的对应关系。

    <SwitchA> display ip host
    Host                 Age        Flags  Address
    hostB                0          static 10.4.1.1
    hostC                0          static 10.4.1.2 

    # 在SwitchA用display dns dynamic-host命令可以查看到动态缓存区中的动态DNS表项信息。

    <SwitchA> display dns dynamic-host
    No  Domain-name         IpAddress      TTL    Alias
    1   huawei.com          10.2.1.3        114

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
ip host hostB 10.4.1.1
ip host hostC 10.4.1.2
#
vlan batch 101
#
dns resolve
dns server 10.3.1.2
dns domain net
dns domain com
#
interface Vlanif101
 ip address 10.1.1.2 255.255.0.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 101
#
ospf 1
 area 0.0.0.0
  network 10.1.0.0 0.0.255.255
#
return

SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 100 to 101
#
interface Vlanif101
 ip address 10.1.1.1 255.255.0.0
#
interface Vlanif100
 ip address 10.2.1.1 255.255.0.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 100
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 101
#
interface LoopBack0
 ip address 10.4.1.1 255.255.255.255
#
ospf 1
 area 0.0.0.0
  network 10.1.0.0 0.0.255.255
  network 10.2.0.0 0.0.255.255
  network 10.4.1.1 0.0.0.0
#
return

SwitchC的配置文件

#
sysname SwitchC
#
vlan batch 100 to 101
#
interface Vlanif100
 ip address 10.2.1.2 255.255.0.0
#
interface Vlanif101
 ip address 10.3.1.1 255.255.0.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 100
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 101
#
interface LoopBack0
 ip address 10.4.1.2 255.255.255.255
#
ospf 1
 area 0.0.0.0
  network 10.2.0.0 0.0.255.255
  network 10.3.0.0 0.0.255.255
  network 10.4.1.2 0.0.0.0
#
return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141518

浏览量:13852

下载量:292

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页