所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置6PE示例

配置6PE示例

组网需求

图12-15所示,设备PE1和PE2支持6PE特性,设备CE1和CE2支持IPv6协议。PE设备之间是运营商的IPv4/MPLS网络,PE之间需要建立IPv4的IBGP连接,IGP使用OSPF路由协议。CE设备所在的网络为IPv6网络,PE与CE之间使用IPv6地址以静态路由方式交换路由信息。

要求使用6PE特性将用户的IPv6网络通过运营商的IPv4/MPLS网络连接起来。

图12-15  配置6PE组网图

说明:

执行MPLS相关命令需要购买License。

配置思路

配置6PE思路如下:

  1. 使能IPv6功能并配置IPv4/IPv6双协议栈。

  2. 使能MPLS功能。

  3. 配置6PE对等体。

  4. 配置CE接口的IPv6地址和静态路由。

操作步骤

  1. 使能IPv6功能,配置IPv4/IPv6双协议栈

    # 配置PE1,使能IPv6功能。

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] ipv6

    # 配置PE2,使能IPv6功能。

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] ipv6

    # 配置PE1接口VLANIF100的IPv6地址及接口Loopback0的地址。

    [PE1] vlan batch 100 200
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [PE1-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface vlanif 100
    [PE1-Vlanif100] ipv6 enable
    [PE1-Vlanif100] ipv6 address fc00:3::1 64
    [PE1-Vlanif100] quit
    [PE1] interface loopback 0
    [PE1-LoopBack0] ip address 1.1.1.9 255.255.255.255
    [PE1-LoopBack0] quit

    # 配置PE2接口VLANIF100的IPv6地址及接口Loopback0的地址。

    [PE2] vlan batch 100 200
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [PE2-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [PE2-GigabitEthernet1/0/0] quit
    [PE2] interface vlanif 100
    [PE2-Vlanif100] ipv6 enable
    [PE2-Vlanif100] ipv6 address fc00:4::1 64
    [PE2-Vlanif100] quit
    [PE2] interface loopback 0
    [PE2-LoopBack0] ip address 2.2.2.9 255.255.255.255
    [PE2-LoopBack0] quit

  2. 使能MPLS功能

    说明:

    本例PE直连,需要通过label advertise命令配置出节点向倒数第二跳正常分配标签。

    # 配置PE1接口VLANIF200的地址,使能MPLS和LDP协议。

    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] lsp-trigger all
    [PE1-mpls] label advertise non-null
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] port hybrid pvid vlan 200
    [PE1-GigabitEthernet2/0/0] port hybrid untagged vlan 200
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface vlanif 200
    [PE1-Vlanif200] ip address 4.3.5.1 255.255.255.0
    [PE1-Vlanif200] mpls
    [PE1-Vlanif200] mpls ldp
    [PE1-Vlanif200] quit
    

    # 配置PE2接口VLANIF200的地址,使能MPLS和LDP协议。

    [PE2] mpls lsr-id 2.2.2.9
    [PE2] mpls
    [PE2-mpls] lsp-trigger all
    [PE2-mpls] label advertise non-null
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] port hybrid pvid vlan 200
    [PE2-GigabitEthernet2/0/0] port hybrid untagged vlan 200
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] interface vlanif 200
    [PE2-Vlanif200] ip address 4.3.5.2 255.255.255.0
    [PE2-Vlanif200] mpls
    [PE2-Vlanif200] mpls ldp
    [PE2-Vlanif200] quit

    # 在PE1上配置OSPF,触发LSP的建立。

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 4.3.5.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # 在PE2上配置OSPF,触发LSP的建立。

    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 4.3.5.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

  3. 配置6PE对等体

    # 在PE1上配置IBGP,使能对等体的6PE功能,并引入IPv6的直连路由。

    [PE1] bgp 65100
    [PE1-bgp] peer 2.2.2.9 as-number 65100
    [PE1-bgp] peer 2.2.2.9 connect-interface loopback 0
    [PE1-bgp] ipv6-family
    [PE1-bgp-af-ipv6] import-route direct
    [PE1-bgp-af-ipv6] peer 2.2.2.9 enable
    [PE1-bgp-af-ipv6] peer 2.2.2.9 label-route-capability
    [PE1-bgp-af-ipv6] quit
    [PE1-bgp] quit

    # 在PE2上配置IBGP,使能对等体的6PE功能,并引入IPv6的直连路由。

    [PE2] bgp 65100
    [PE2-bgp] peer 1.1.1.9 as-number 65100
    [PE2-bgp] peer 1.1.1.9 connect-interface loopback 0
    [PE2-bgp] ipv6-family
    [PE2-bgp-af-ipv6] import-route direct
    [PE2-bgp-af-ipv6] peer 1.1.1.9 enable
    [PE2-bgp-af-ipv6] peer 1.1.1.9 label-route-capability
    [PE2-bgp-af-ipv6] quit
    [PE2-bgp] quit

  4. 配置CE接口的IPv6地址和静态路由

    # 配置CE1,建立与PE1的IPv6连接。

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] ipv6
    [CE1] vlan batch 100
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [CE1-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface vlanif 100
    [CE1-Vlanif100] ipv6 enable
    [CE1-Vlanif100] ipv6 address fc00:3::2 64
    [CE1-Vlanif100] quit
    [CE1] ipv6 route-static :: 0 fc00:3::1

    # 配置CE2,建立与PE2的IPv6连接。

    <Quidway> system-view
    [Quidway] sysname CE2
    [CE2] ipv6
    [CE2] vlan batch 100
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] port hybrid pvid vlan 100
    [CE2-GigabitEthernet1/0/0] port hybrid untagged vlan 100
    [CE2-GigabitEthernet1/0/0] quit
    [CE2] interface vlanif 100
    [CE2-Vlanif100] ipv6 enable
    [CE2-Vlanif100] ipv6 address fc00:4::2 64
    [CE2-Vlanif100] quit
    [CE2] ipv6 route-static :: 0 fc00:4::1

  5. 检查配置结果

    # 从CE1上可以Ping通CE2的IPv6地址。

    [CE1] ping ipv6 FC00:4::2
    PING FC00:4::2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:4::2
        bytes=56 Sequence=1 hop limit=63  time = 50 ms
        Reply from FC00:4::2
        bytes=56 Sequence=2 hop limit=63  time = 1 ms
        Reply from FC00:4::2
        bytes=56 Sequence=3 hop limit=63  time = 1 ms
        Reply from FC00:4::2
        bytes=56 Sequence=4 hop limit=63  time = 1 ms
        Reply from FC00:4::2
        bytes=56 Sequence=5 hop limit=63  time = 1 ms
    
      --- FC00:4::2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/10/50 ms 

配置文件

  • PE1的配置文件

    #
    sysname PE1
    #
    ipv6
    #
    vlan batch 100 200
    #
    mpls lsr-id 1.1.1.9
    mpls
     label advertise non-null
     lsp-trigger all
    #
    mpls ldp
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:3::1/64
    #
    interface Vlanif200
     ip address 4.3.5.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet2/0/0
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface LoopBack0
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 65100
     peer 2.2.2.9 as-number 65100
     peer 2.2.2.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.9 enable
     #
     ipv6-family unicast
      undo synchronization
      import-route direct
      peer 2.2.2.9 enable
      peer 2.2.2.9 label-route-capability
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 4.3.5.0 0.0.0.255
    #
    return
  • PE2的配置文件

    #
    sysname PE2
    #
    ipv6
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    mpls
     label advertise non-null
     lsp-trigger all
    #
    mpls ldp
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:4::1/64
    #
    interface Vlanif200
     ip address 4.3.5.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet2/0/0
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface LoopBack0
     ip address 2.2.2.9 255.255.255.255
    #
    bgp 65100
     peer 1.1.1.9 as-number 65100
     peer 1.1.1.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
     #
     ipv6-family unicast
      undo synchronization
      import-route direct
      peer 1.1.1.9 enable
      peer 1.1.1.9 label-route-capability
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 4.3.5.0 0.0.0.255
    #
    return
  • CE1的配置文件

    #
    sysname CE1
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:3::2/64
    #
    interface GigabitEthernet1/0/0
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ipv6 route-static :: 0 FC00:3::1
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:4::2/64
    #
    interface GigabitEthernet1/0/0
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ipv6 route-static :: 0 FC00:4::1
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141518

浏览量:14024

下载量:292

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页