所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置静态BFD检测静态LSP示例

配置静态BFD检测静态LSP示例

组网需求

图2-4所示,PE、P为MPLS骨干网设备,骨干网上已建立静态LSP来承载网络业务。

目前网络业务对实时性的要求越来越高,例如VoIP,在线游戏,在线视频业务等,链路发生故障导致的数据丢失对这些业务造成比较严重的影响。现要求当主用LSP故障时,流量能够快速切换到备份LSP,尽可能地避免流量的丢失。因此需要配置静态BFD检测静态LSP来实现快速检测静态LSP。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图2-4  建立静态LSP的组网

配置思路

采用如下思路配置静态BFD检测静态LSP:

  1. 在PE、P上配置OSPF,实现骨干网的IP连通性。
  2. 在PE、P上配置静态LSP,实现创建静态LSP承载网络业务。
  3. 由于静态LSP只能用静态BFD检测,因此在PE上配置静态BFD,实现快速检测静态LSP。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置PE_1。P_1、P_2和PE_2的配置与PE_1类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname PE_1
    [PE_1] interface loopback 1
    [PE_1-LoopBack1] ip address 1.1.1.9 32
    [PE_1-LoopBack1] quit
    [PE_1] vlan batch 100 300
    [PE_1] interface vlanif 100
    [PE_1-Vlanif100] ip address 172.1.1.1 24
    [PE_1-Vlanif100] quit
    [PE_1] interface vlanif 300
    [PE_1-Vlanif300] ip address 172.3.1.1 24
    [PE_1-Vlanif300] quit
    [PE_1] interface gigabitethernet1/0/1
    [PE_1-GigabitEthernet1/0/1] port link-type trunk
    [PE_1-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [PE_1-GigabitEthernet1/0/1] quit
    [PE_1] interface gigabitethernet2/0/2
    [PE_1-GigabitEthernet2/0/2] port link-type trunk
    [PE_1-GigabitEthernet2/0/2] port trunk allow-pass vlan 300
    [PE_1-GigabitEthernet2/0/2] quit
    

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置PE_1。P_1、P_2和PE_2的配置与PE_1类似,不再赘述。

    [PE_1] ospf 1
    [PE_1-ospf-1] area 0
    [PE_1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE_1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [PE_1-ospf-1-area-0.0.0.0] network 172.3.1.0 0.0.0.255
    [PE_1-ospf-1-area-0.0.0.0] quit
    [PE_1-ospf-1] quit

  3. 配置PE_1的接口VLANIF300的cost值为1000

    [PE_1] interface vlanif 300 
    [PE_1-Vlanif300] ospf cost 1000 
    [PE_1-Vlanif300] quit

    上述配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了到达彼此的路由,且PE_1到PE_2路由的出接口为Vlanif100。

  4. 在各节点使能MPLS基本功能

    # 配置PE_1。

    [PE_1] mpls lsr-id 1.1.1.9 
    [PE_1] mpls 
    [PE_1-mpls] quit

    # 配置P_1。

    [P_1] mpls lsr-id 2.2.2.9 
    [P_1] mpls 
    [P_1-mpls] quit

    # 配置P_2。

    [P_2] mpls lsr-id 3.3.3.9 
    [P_2] mpls 
    [P_2-mpls] quit

    # 配置PE_2。

    [PE_2] mpls lsr-id 4.4.4.9 
    [PE_2] mpls 
    [PE_2-mpls] quit

  5. 配置各接口的MPLS能力

    # 配置PE_1。

    [PE_1] interface vlanif 100
    [PE_1-Vlanif100] mpls
    [PE_1-Vlanif100] quit
    [PE_1] interface vlanif 300
    [PE_1-Vlanif300] mpls
    [PE_1-Vlanif300] quit

    # 配置P_1。

    [P_1] interface vlanif 100
    [P_1-Vlanif100] mpls
    [P_1-Vlanif100] quit
    [P_1] interface vlanif 200
    [P_1-Vlanif200] mpls
    [P_1-Vlanif200] quit

    # 配置P_2。

    [P_2] interface vlanif 300
    [P_2-Vlanif300] mpls
    [P_2-Vlanif300] quit
    [P_2] interface vlanif 400
    [P_2-Vlanif400] mpls
    [P_2-Vlanif400] quit

    # 配置PE_2。

    [PE_2] interface vlanif 200
    [PE_2-Vlanif200] mpls
    [PE_2-Vlanif200] quit
    [PE_2] interface vlanif 400
    [PE_2-Vlanif400] mpls
    [PE_2-Vlanif400] quit

  6. 配置静态LSP1,其中PE_1为Ingress,P_1为Transit,PE_2为Egress。

    # 配置Ingress PE_1。

    [PE_1] static-lsp ingress LSP1 destination 4.4.4.9 32 nexthop 172.1.1.2 out-label 20

    # 配置Transit P_1。

    [P_1] static-lsp transit LSP1 incoming-interface vlanif 100 in-label 20 nexthop 172.2.1.2 out-label 40

    # 配置Egress PE_2。

    [PE_2] static-lsp egress LSP1 incoming-interface vlanif 200 in-label 40

  7. 配置静态LSP2,其中PE_1为Ingress,P_2为Transit,PE_2为Egress。

    # 配置Ingress PE_1。

    [PE_1] static-lsp ingress LSP2 destination 4.4.4.9 32 nexthop 172.3.1.2 out-label 30

    # 配置Transit P_2。

    [P_2] static-lsp transit LSP2 incoming-interface vlanif 300 in-label 30 nexthop 172.4.1.2 out-label 60

    # 配置Egress PE_2。

    [PE_2] static-lsp egress LSP2 incoming-interface vlanif 400 in-label 60

    配置完成后,在PE_1上执行命令ping lsp ip 4.4.4.9 32,可以ping通。

    然后在各节点上用display mpls static-lsp verbose命令查看静态LSP的详细信息。以PE_1的显示为例:

    [PE_1] display mpls static-lsp verbose
    No             : 1
    LSP-Name       : LSP1
    LSR-Type       : Ingress
    FEC            : 4.4.4.9/32
    In-Label       : NULL 
    Out-Label      : 20
    In-Interface   : -
    Out-Interface  : Vlanif100
    NextHop        : 172.1.1.2
    Static-Lsp Type: Normal
    Lsp Status     : Up
    
    No             : 2
    LSP-Name       : LSP2
    LSR-Type       : Ingress
    FEC            : 4.4.4.9/32
    In-Label       : NULL
    Out-Label      : 30
    In-Interface   : -
    Out-Interface  : Vlanif300
    NextHop        : 172.3.1.2
    Static-Lsp Type: Normal
    Lsp Status     : Down

  8. 配置BFD会话检测静态LSP1

    # 在Ingress PE_1上配置BFD会话,其中本地标识符是1,远端标识符是2,发送报文的时间间隔是100毫秒,接收报文的时间间隔是100毫秒,并且能够修改端口状态表。

    [PE_1] bfd
    [PE_1-bfd] quit
    [PE_1] bfd pe1tope2 bind static-lsp LSP1
    [PE_1-bfd-lsp-session-pe1tope2] discriminator local 1
    [PE_1-bfd-lsp-session-pe1tope2] discriminator remote 2
    [PE_1-bfd-lsp-session-pe1tope2] min-tx-interval 100
    [PE_1-bfd-lsp-session-pe1tope2] min-rx-interval 100
    [PE_1-bfd-lsp-session-pe1tope2] process-pst
    [PE_1-bfd-lsp-session-pe1tope2] commit
    [PE_1-bfd-lsp-session-pe1tope2] quit

    # 在Egress PE_2上配置BFD会话,通过IP链路向Ingress PE_1通告静态LSP故障。

    [PE_2] bfd
    [PE_2-bfd] quit
    [PE_2] bfd pe2tope1 bind peer-ip 1.1.1.9
    [PE_2-bfd-session-pe2tope1] discriminator local 2
    [PE_2-bfd-session-pe2tope1] discriminator remote 1
    [PE_2-bfd-session-pe2tope1] min-tx-interval 100
    [PE_2-bfd-session-pe2tope1] min-rx-interval 100
    [PE_2-bfd-session-pe2tope1] commit
    [PE_2-bfd-session-pe2tope1] quit

    # 在PE_1上执行display bfd session all查看配置结果,可以看到在PE_1上BFD会话已经Up。

    [PE_1] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type        InterfaceName            
    --------------------------------------------------------------------------------
    1     2          4.4.4.9         Up        S_STA_LSP   - 
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0    

    # 在PE_2上执行display bfd session all查看配置结果。

    [PE_2] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type        InterfaceName            
    --------------------------------------------------------------------------------
    2     1          1.1.1.9         Up        S_IP_PEER         -                  
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0  
    

  9. 检测配置结果

    # 对P_1的GE2/0/2接口进行shutdown操作,模拟静态LSP故障。

    [P_1] interface gigabitethernet2/0/2
    [P_1-GigabitEthernet2/0/2] shutdown

    # 在PE上执行display bfd session all,查看BFD的状态。

    [PE_2] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type        InterfaceName            
    --------------------------------------------------------------------------------
    2     1          1.1.1.9         Down      S_IP_PEER         -                  
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 0/1   

配置文件

  • PE_1的配置文件

    #
    sysname PE_1
    #
    vlan batch 100 300
    #
    bfd
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     ospf cost 1000
     mpls
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 100 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 300 
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.3.1.0 0.0.0.255
    #
    static-lsp ingress LSP1 destination 4.4.4.9 32 nexthop 172.1.1.2 out-label 20 
    static-lsp ingress LSP2 destination 4.4.4.9 32 nexthop 172.3.1.2 out-label 30 
    #
    bfd pe1tope2 bind static-lsp LSP1
     discriminator local 1 
     discriminator remote 2
     min-tx-interval 100
     min-rx-interval 100
     process-pst
     commit
    #
    return
  • P_1的配置文件

    #
    sysname P_1
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 100 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 200 
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
    #
    static-lsp transit LSP1 incoming-interface Vlanif100 in-label 20 nexthop 172.2.1.2 out-label 40 
    #
    return
  • P_2的配置文件

    #
    sysname P_2
    #
    vlan batch 300 400
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     mpls
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 300 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 400 
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.3.1.0 0.0.0.255
      network 172.4.1.0 0.0.0.255
    #
    static-lsp transit LSP2 incoming-interface Vlanif300 in-label 30 nexthop 172.4.1.2 out-label 60
    #
    return
  • PE_2的配置文件

    #
    sysname PE_2
    #
    vlan batch 200 400
    #
    bfd
    #
    mpls lsr-id 4.4.4.9
    mpls
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 200 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 400 
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    bfd pe2tope1 bind peer-ip 1.1.1.9
     discriminator local 2 
     discriminator remote 1
     min-tx-interval 100
     min-rx-interval 100
     commit
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
      network 172.4.1.0 0.0.0.255
    #
    static-lsp egress LSP1 incoming-interface Vlanif200 in-label 40
    static-lsp egress LSP2 incoming-interface Vlanif400 in-label 60
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8159

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页