所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
引用CR-LSP属性模板建立CR-LSP示例

引用CR-LSP属性模板建立CR-LSP示例

组网需求

图5-37中,在LSRA和LSRC之间建立了MPLS TE隧道,其主路径为LSRA→LSRB→LSRC。现需求为当主CR-LSP故障时,流量切换到备份CR-LSP上。

另外,LSRA由于业务需求需要创建多条MPLS TE隧道,用户希望能简化设备上的配置。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图5-37  引用CR-LSP属性模板建立CR-LSP组网图

配置思路

采用如下思路配置实现用户需求:

  1. 配置各接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS、MPLS TE、RSVP-TE、CSPF功能,使能OSPF TE。

  3. 为了简化设备配置,可以引用CR-LSP属性模板建立CR-LSP。分别为主CR-LSP、热备份CR-LSP和普通备份CR-LSP配置不同的CR-LSP属性模板。

  4. 在主隧道入节点创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE,引用CR-LSP属性模板建立主CR-LSP。

  5. 在主隧道入节点配置CR-LSP热备份功能和普通备份功能,实现为当主CR-LSP故障时,流量切换到备份CR-LSP上。创建备份CR-LSP时,引用CR-LSP属性模板。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF

    # 配置LSRA。按图5-37配置各设备的接口IP地址,其中LSRB、LSRC、LSRE和LSRF的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100 400 600
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 400
    [LSRA-Vlanif400] ip address 172.4.1.1 255.255.255.0
    [LSRA-Vlanif400] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] ip address 172.6.1.1 255.255.255.0
    [LSRA-Vlanif600] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type trunk
    [LSRA-GigabitEthernet2/0/0] port trunk allow-pass vlan 600
    [LSRA-GigabitEthernet2/0/0] quit
    [LSRA] interface gigabitethernet 3/0/0
    [LSRA-GigabitEthernet3/0/0] port link-type trunk
    [LSRA-GigabitEthernet3/0/0] port trunk allow-pass vlan 400
    [LSRA-GigabitEthernet3/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.4.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.6.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    配置完成后,在各节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。以LSRA的显示为例:

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 16       Routes : 18                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  OSPF    10   1           D   172.1.1.2       Vlanif100
            3.3.3.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
                        OSPF    10   2           D   172.4.1.2       Vlanif400
                        OSPF    10   2           D   172.6.1.2       Vlanif600
            5.5.5.9/32  OSPF    10   1           D   172.4.1.2       Vlanif400
            6.6.6.9/32  OSPF    10   1           D   172.6.1.2       Vlanif600
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.4.1.0/24  Direct  0    0           D   172.4.1.1       Vlanif400
          172.4.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif400
          172.5.1.0/24  OSPF    10   2           D   172.4.1.2       Vlanif400
          172.6.1.0/24  Direct  0    0           D   172.6.1.1       Vlanif600
          172.6.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif600
          172.7.1.0/24  OSPF    10   2           D   172.6.1.2       Vlanif600
    

  2. 配置MPLS基本能力,使能MPLS TE、RSVP-TE和CSPF

    # 配置LSRA。LSRB、LSRC、LSRE和LSRF的配置与LSRA类似,不再赘述。其中,只需在主隧道的入节点上使能CSPF。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 400
    [LSRA-Vlanif400] mpls
    [LSRA-Vlanif400] mpls te
    [LSRA-Vlanif400] mpls rsvp-te
    [LSRA-Vlanif400] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] mpls
    [LSRA-Vlanif600] mpls te
    [LSRA-Vlanif600] mpls rsvp-te
    [LSRA-Vlanif600] quit
    

  3. 配置OSPF TE

    # 配置LSRA。LSRB、LSRC、LSRE和LSRF的配置与LSRA类似,不再赘述。

    [LSRA] ospf
    [LSRA-ospf-1] opaque-capability enable
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  4. 配置CR-LSP属性模板及其显式路径

    # 配置主CR-LSP的显式路径。

    [LSRA] explicit-path pri-path
    [LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [LSRA-explicit-path-pri-path] next hop 3.3.3.9
    [LSRA-explicit-path-pri-path] quit

    # 配置热备份CR-LSP的显式路径。

    [LSRA] explicit-path hotstandby-path
    [LSRA-explicit-path-hotstandby-path] next hop 172.4.1.2
    [LSRA-explicit-path-hotstandby-path] next hop 172.5.1.2
    [LSRA-explicit-path-hotstandby-path] next hop 3.3.3.9
    [LSRA-explicit-path-hotstandby-path] quit

    # 配置普通备份CR-LSP的显式路径。

    [LSRA] explicit-path ordinary-path
    [LSRA-explicit-path-ordinary-path] next hop 172.6.1.2
    [LSRA-explicit-path-ordinary-path] next hop 172.7.1.2
    [LSRA-explicit-path-ordinary-path] next hop 3.3.3.9
    [LSRA-explicit-path-ordinary-path] quit

    # 配置建立主CR-LSP引用的属性模板。

    [LSRA] lsp-attribute lsp_attribute_pri
    [LSRA-lsp-attribute-lsp_attribute_pri] explicit-path pri-path
    [LSRA-lsp-attribute-lsp_attribute_pri] commit
    [LSRA-lsp-attribute-lsp_attribute_pri] quit

    # 配置建立热备份CR-LSP引用的属性模板。

    [LSRA] lsp-attribute lsp_attribute_hotstandby
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] explicit-path hotstandby-path
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] hop-limit 12
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] commit
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] quit

    # 配置建立普通备份CR-LSP引用的属性模板。

    [LSRA] lsp-attribute lsp_attribute_ordinary
    [LSRA-lsp-attribute-lsp_attribute_ordinary] explicit-path ordinary-path
    [LSRA-lsp-attribute-lsp_attribute_ordinary] hop-limit 15
    [LSRA-lsp-attribute-lsp_attribute_ordinary] commit
    [LSRA-lsp-attribute-lsp_attribute_ordinary] quit

  5. 在入节点LSRA上创建主CR-LSP的MPLS TE Tunnel

    # 配置主CR-LSP的MPLS TE隧道接口,引用属性模板创建主CR-LSP。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopBack 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 3.3.3.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te primary-lsp-constraint lsp-attribute lsp_attribute_pri
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    在LSRA上执行命令display interface tunnel 1查看隧道状态,可发现隧道状态为Up。

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-01-22 16:57:00                                
    Description:
    ...

  6. 在入节点配置CR-LSP热备份和普通备份

    # 配置LSRA,引用属性模板创建热备份和普通备份CR-LSP。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] mpls te hotstandby-lsp-constraint 1 lsp-attribute lsp_attribute_hotstandby
    [LSRA-Tunnel1] mpls te ordinary-lsp-constraint 1 lsp-attribute lsp_attribute_ordinary
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    在LSRA上执行display mpls te tunnel-interface命令查看隧道信息,可以看到备份CR-LSP已经成功建立。

    [LSRA] display mpls te tunnel-interface
        ----------------------------------------------------------------            
                                   Tunnel1                                      
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Primary LSP                                          
        Session ID          :  100                                                  
        Ingress LSR ID      :  1.1.1.9          Egress LSR ID:  3.3.3.9             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 5                    
        Hot-Standby LSP State  : UP                                                 
          Main LSP State       : READY               LSP ID  : 32772                
                                                                           

  7. 检查配置结果

    完成上述配置之后,可以在LSRA上执行display mpls te tunnel-interface lsp-constraint命令查看属性模板的各配置项。

    [LSRA] display mpls te tunnel-interface lsp-constraint
        Tunnel Name                     :  Tunnel1
        Primary-lsp-constraint Name     :  lsp_attribute_pri
        Hotstandby-lsp-constraint Number:  1
        Hotstandby-lsp-constraint Name  :  lsp_attribute_hotstandby
        Ordinary-lsp-constraint Number  :  1
        Ordinary-lsp-constraint Name    :  lsp_attribute_ordinary
    

    # LSRA上执行display mpls te tunnel verbose命令,可以看到隧道引用属性模板建立主CR-LSP和热备份CR-LSP。

    [LSRA] display mpls te tunnel verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                          
        Tunnel Interface Name   :  Tunnel1                                          
        TunnelIndex             :  1           LSP Index         :  2048            
        Session ID              :  100         LSP ID            :  5               
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif100                                        
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  1                                                
        ER-Hop Table Index      :  0           AR-Hop Table Index:  0               
        C-Hop Table Index       :  1                                                
        PrevTunnelIndexInSession:  2           NextTunnelIndexInSession:  -         
        PSB Handle              :  8194                                             
        Created Time            :  2013-09-16 14:53:15+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
                                                                                    
        No                      :  2                                                
        Tunnel-Name             :  Tunnel1                                          
        Tunnel Interface Name   :  Tunnel1                                          
        TunnelIndex             :  2           LSP Index         :  2050            
        Session ID              :  100         LSP ID            :  32772           
        LSR Role                :  Ingress     LSP Type          :  Hot-Standby     
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif400                                        
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  1                                                
        ER-Hop Table Index      :  1           AR-Hop Table Index:  1               
        C-Hop Table Index       :  2                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  1         
        PSB Handle              :  8195                                             
        Created Time            :  2013-09-16 14:53:15+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
    

    # 在LSRA的GE1/0/0和GE3/0/0上执行shutdown命令。

    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] shutdown
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 3/0/0
    [LSRA-GigabitEthernet3/0/0] shutdown
    [LSRA-GigabitEthernet3/0/0] quit

    # LSRA上执行display mpls te tunnel verbose命令,可以看到使用属性模板成功建立普通CR-LSP。

    [LSRA] display mpls te tunnel verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                          
        Tunnel Interface Name   :  Tunnel1                                          
        TunnelIndex             :  2           LSP Index         :  2048            
        Session ID              :  100         LSP ID            :  32774           
        LSR Role                :  Ingress     LSP Type          :  Ordinary        
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif600                                        
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  1                                                
        ER-Hop Table Index      :  2           AR-Hop Table Index:  1               
        C-Hop Table Index       :  2                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8196                                             
        Created Time            :  2013-09-16 15:00:08+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100 400 600
    #
    mpls lsr-id 1.1.1.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te                                                                   
     mpls te cspf 
    #
    explicit-path hotstandby-path
     next hop 172.4.1.2
     next hop 172.5.1.2
     next hop 3.3.3.9 
    #
    explicit-path ordinary-path
     next hop 172.6.1.2
     next hop 172.7.1.2
     next hop 3.3.3.9 
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 3.3.3.9 
    #
    lsp-attribute lsp_attribute_hotstandby
     explicit-path hotstandby-path
     hop-limit 12
     commit
    #
    lsp-attribute lsp_attribute_ordinary
     explicit-path ordinary-path
     hop-limit 15
     commit
    #
    lsp-attribute lsp_attribute_pri
     explicit-path pri-path
     commit
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #    
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 100
     mpls te primary-lsp-constraint lsp-attribute lsp_attribute_pri
     mpls te hotstandby-lsp-constraint 1 lsp-attribute lsp_attribute_hotstandby
     mpls te ordinary-lsp-constraint 1 lsp-attribute lsp_attribute_ordinary
     mpls te record-route 
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255
      network 172.6.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    # 
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 500 700
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0                                                       
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRF的配置文件

    #
    sysname LSRF
    #
    vlan batch 600 700
    #
    mpls lsr-id 6.6.6.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 6.6.6.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 6.6.6.9 0.0.0.0                                                       
      network 172.6.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8302

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页