所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置手工TE FRR示例

配置手工TE FRR示例

组网需求

图5-47所示,主CR-LSP是LSRA→LSRB→LSRC→LSRD,要求对LSRB→LSRC这段链路通过FRR进行链路保护。

建立一条Bypass CR-LSP,使用路径LSRB→LSRE→LSRC。LSRB是本地修复节点PLR,LSRC是汇聚点MP。

要求使用显式路径方式建立MPLS TE的主隧道和旁路隧道。使用的信令协议是RSVP-TE。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图5-47  配置手工TE FRR组网图

配置思路

采用如下的思路配置手工TE FRR:

  1. 配置各接口的IP地址,全局使能IS-IS协议,配置网络实体名称。在各接口(包括Loopback接口)上使能IS-IS。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS、MPLS TE、RSVP-TE、CSPF功能。使能IS-IS TE,改变cost类型。

  3. 在主隧道入节点创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE。

  4. 在入节点的主隧道接口下使能TE FRR。

  5. 在被保护链路的旁路隧道入节点即LSRB创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE,同时指定被保护链路的接口。

操作步骤

  1. 配置各接口的IP地址

    # 配置LSRA。按图5-47配置各设备的接口IP地址,其中LSRB、LSRC、LSRD和LSRE的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    

  2. 配置IS-IS协议发布路由

    # 配置LSRA。LSRB、LSRC、LSRD和LSRE的配置与LSRA类似,不再赘述。

    [LSRA] isis 1
    [LSRA-isis-1] network-entity 00.0005.0000.0000.0001.00
    [LSRA-isis-1] is-level level-2
    [LSRA-isis-1] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] isis enable 1
    [LSRA-Vlanif100] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] isis enable 1
    [LSRA-LoopBack1] quit

    配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了到对方的路由。以LSRA的显示为例:

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 13       Routes : 13                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  ISIS-L2 15   10          D   172.1.1.2       Vlanif100
            3.3.3.9/32  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
            4.4.4.9/32  ISIS-L2 15   30          D   172.1.1.2       Vlanif100
            5.5.5.9/32  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
          172.3.1.0/24  ISIS-L2 15   30          D   172.1.1.2       Vlanif100
          172.4.1.0/24  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
          172.5.1.0/24  ISIS-L2 15   30          D   172.1.1.2       Vlanif100
    

  3. 配置MPLS基本能力,使能MPLS TE、CSPF和RSVP-TE及IS-IS TE

    # 配置LSRA。LSRB、LSRC、LSRD和LSRE的配置与LSRA类似,不再赘述。其中,CSPF只要在主隧道入节点LSRA和旁路隧道入节点LSRB上使能即可,LSRC、LSRD和LSRE上无需使能CSPF。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    [LSRA] isis
    [LSRA-isis-1] cost-style wide
    [LSRA-isis-1] traffic-eng level-2
    [LSRA-isis-1] quit

  4. 在入节点LSRA上创建主CR-LSP的MPLS TE Tunnel

    # 配置主CR-LSP的显式路径。

    [LSRA] explicit-path pri-path
    [LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [LSRA-explicit-path-pri-path] next hop 172.3.1.2
    [LSRA-explicit-path-pri-path] next hop 4.4.4.9
    [LSRA-explicit-path-pri-path] quit

    # 配置主CR-LSP的MPLS TE隧道接口。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 4.4.4.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te path explicit-path pri-path

    # 使能TE FRR。

    [LSRA-Tunnel1] mpls te fast-reroute
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    配置完成后,在LSRA上执行display interface tunnel命令,可以看到Tunnel1的状态为Up。

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-01-21 10:58:49                                
    Description:
    ...

    在LSRA上执行display mpls te tunnel verbose命令,可以看到隧道接口的详细信息。

    [LSRA] display mpls te tunnel verbose
        No                      :  1
        Tunnel-Name             :  Tunnel1
        Tunnel Interface Name   :  Tunnel1
        TunnelIndex             :  0           LSP Index         :  2048
        Session ID              :  100         LSP ID            :  3
        LSR Role                :  Ingress     LSP Type          :  Primary  
        Ingress LSR ID          :  1.1.1.9
        Egress LSR ID           :  4.4.4.9
        In-Interface            :  -
        Out-Interface           :  Vlanif100
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0
        IncludeAllAff           :  0x0
        LspConstraint           :  -
        ER-Hop Table Index      :  1           AR-Hop Table Index:  0
        C-Hop Table Index       :  1
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -
        PSB Handle              :  8253
        Created Time            :  2013-09-16 17:57:06+00:00 
        RSVP LSP Type           :  -    
        --------------------------------
                  DS-TE Information
        --------------------------------
        Bandwidth Reserved Flag :  Unreserved
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0
        Setup-Priority          :  7           Hold-Priority     :  7
        --------------------------------
                    FRR Information
        --------------------------------
        Primary LSP Info
        TE Attribute Flag       :  0x63        Protected Flag    :  0x0
        Bypass In Use           :  Not Exists
        Bypass Tunnel Id        :  -
        BypassTunnel            :  -
        Bypass LSP ID           :  -           FrrNextHop        :  -
        ReferAutoBypassHandle   :  -
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -
        Bypass Attribute(Not configured)
        Setup Priority          :  -           Hold Priority     :  -
        HopLimit                :  -           Bandwidth         :  -
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -
        IncludeAllGroup         :  -
        Bypass Unbound Bandwidth Info(Kbit/sec)
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -
        --------------------------------
                   BFD Information
        --------------------------------
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -
        NextLspId               :  -           PrevLspId         :  -

  5. 在作为PLR的LSRB上配置Bypass CR-LSP

    # 配置Bypass CR-LSP的显式路径。

    [LSRB] explicit-path by-path
    [LSRB-explicit-path-by-path] next hop 172.4.1.2
    [LSRB-explicit-path-by-path] next hop 172.5.1.2
    [LSRB-explicit-path-by-path] next hop 3.3.3.9
    [LSRB-explicit-path-by-path] quit

    # 配置Bypass CR-LSP的隧道接口。

    [LSRB] interface tunnel 2
    [LSRB-Tunnel2] ip address unnumbered interface loopback 1
    [LSRB-Tunnel2] tunnel-protocol mpls te
    [LSRB-Tunnel2] destination 3.3.3.9
    [LSRB-Tunnel2] mpls te tunnel-id 300
    [LSRB-Tunnel2] mpls te path explicit-path by-path
    [LSRB-Tunnel2] mpls te bypass-tunnel
    

    # 将Bypass CR-LSP绑定到被保护的接口。

    [LSRB-Tunnel2] mpls te protected-interface vlanif 200
    [LSRB-Tunnel2] mpls te commit
    [LSRB-Tunnel2] quit

    配置完成后,在LSRB上执行display interface tunnel命令可以看到接口Tunnel2的状态为Up。

    在节点上执行display mpls lsp命令,可以看到LSP表项,并且LSRB和LSRC上有两条CR-LSP经过。

    [LSRA] display mpls lsp
    -------------------------------------------------------------------------------
                     LSP Information: RSVP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    4.4.4.9/32         NULL/1032     -/Vlanif100                             
    

    在节点上执行display mpls te tunnel命令,可以看到隧道的建立情况,LSRB和LSRC上有两条隧道经过。

    [LSRA] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    1.1.1.9          4.4.4.9          3       --/1032          I  Tunnel1
    
    [LSRB] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    1.1.1.9          4.4.4.9          3       1032/1040        T  Tunnel1
    2.2.2.9          3.3.3.9          2       --/1025          I  Tunnel2
    
    [LSRC] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    1.1.1.9          4.4.4.9          3       1040/3           T  Tunnel1
    2.2.2.9          3.3.3.9          2       3/--             E  Tunnel2
    
    [LSRD] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    1.1.1.9          4.4.4.9          3       3/--             E  Tunnel1
    
    [LSRE] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    2.2.2.9          3.3.3.9          2       1025/3           T  Tunnel2
    

    在LSRB上执行display mpls te tunnel name Tunnel1 verbose命令,可以看到旁路隧道绑定到出接口VLANIF200,目前未被使用。

    [LSRB] display mpls te tunnel name Tunnel1 verbose
        No                      :  1
        Tunnel-Name             :  Tunnel1
        Tunnel Interface Name   :  - 
        TunnelIndex             :  1           LSP Index         :  4098
        Session ID              :  100         LSP ID            :  3
        LSR Role                :  Transit
        Ingress LSR ID          :  1.1.1.9
        Egress LSR ID           :  4.4.4.9
        In-Interface            :  Vlanif100
        Out-Interface           :  Vlanif200
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0
        IncludeAllAff           :  0x0
        ER-Hop Table Index      :  1           AR-Hop Table Index:  0
        C-Hop Table Index       :  -
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -
        PSB Handle              :  8247  
        Created Time            :  2013-09-16 17:59:06+00:00 
        RSVP LSP Type           :  -             
        --------------------------------
                  DS-TE Information
        --------------------------------
        Bandwidth Reserved Flag :  Unreserved
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0
        Setup-Priority          :  7           Hold-Priority     :  7
        --------------------------------
                    FRR Information
        --------------------------------
        Primary LSP Info
        TE Attribute Flag       :  0x63        Protected Flag    :  0x1
        Bypass In Use           :  Not Used
        Bypass Tunnel Id        :  15
        BypassTunnel            :  Tunnel Index[Tunnel2], InnerLabel[1040]
        Bypass LSP ID           :  2           FrrNextHop        :  172.5.1.2
        ReferAutoBypassHandle   :  -
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -
        Bypass Attribute(Not configured)
        Setup Priority          :  -           Hold Priority     :  -
        HopLimit                :  -           Bandwidth         :  -
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -
        IncludeAllGroup         :  -
        Bypass Unbound Bandwidth Info(Kbit/sec)
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -
        --------------------------------
                   BFD Information
        --------------------------------
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -
        NextLspId               :  -           PrevLspId         :  -

  6. 检查配置结果

    # 使PLR上被保护的出接口失效。

    [LSRB] interface vlanif 200
    [LSRB-Vlanif200] shutdown
    [LSRB-Vlanif200] quit

    在LSRA上执行命令display interface tunnel 1,查看主CR-LSP的状态,可以看到Tunnel接口仍然处于UP状态。

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-01-21 10:58:49                                
    Description:
    ...
    在LSRA上执行tracert lsp te tunnel 1命令来查看隧道经过的路径。
    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to break.
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.1.1.2/[1032 ]                  
      1     172.1.1.2          2 ms    Transit   172.4.1.2/[1040 1025 ]             
      2     172.4.1.2          2 ms    Transit   172.5.1.2/[3 ]                     
      3     172.5.1.2          1 ms    Transit   172.3.1.2/[3 ]                     
      4     4.4.4.9            11 ms   Egress                                       

    由此可以确认链路已切换到Bypass CR-LSP。

    说明:

    如果在TE FRR切换后马上执行display mpls te tunnel-interface命令查看隧道接口的详细信息,会看到两条处于Up状态的CR-LSP。这是因为TE FRR采用Make-before-break方式建立新的CR-LSP,旧的CR-LSP在新CR-LSP建立成功后过一段时间才被删除。

    在LSRB上执行display mpls te tunnel name Tunnel1 verbose命令,可以看到旁路隧道被使用。

    [LSRB] display mpls te tunnel name Tunnel1 verbose
        No                      :  1
        Tunnel-Name             :  Tunnel1
        Tunnel Interface Name   :  -                   
        TunnelIndex             :  1           LSP Index         :  4098
        Session ID              :  100         LSP ID            :  3
        LSR Role                :  Transit
        Ingress LSR ID          :  1.1.1.9
        Egress LSR ID           :  4.4.4.9
        In-Interface            :  Vlanif100
        Out-Interface           :  Vlanif200
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0
        IncludeAllAff           :  0x0
        ER-Hop Table Index      :  -           AR-Hop Table Index:  2
        C-Hop Table Index       :  - 
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -
        PSB Handle              :  8247 
        Created Time            :  2013-09-16 18:17:06+00:00     
        RSVP LSP Type           :  -  
        --------------------------------
                  DS-TE Information
        --------------------------------
        Bandwidth Reserved Flag :  Unreserved
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0
        Setup-Priority          :  7           Hold-Priority     :  7
        --------------------------------
                    FRR Information
        --------------------------------
        Primary LSP Info
        TE Attribute Flag       :  0x63        Protected Flag    :  0x1
        Bypass In Use           :  In Use
        Bypass Tunnel Id        :  15
        BypassTunnel            :  Tunnel Index[Tunnel2], InnerLabel[1040]
        Bypass LSP ID           :  2           FrrNextHop        :  172.5.1.2
        ReferAutoBypassHandle   :  -
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -
        Bypass Attribute(Not configured)
        Setup Priority          :  -           Hold Priority     :  -
        HopLimit                :  -           Bandwidth         :  -
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -
        IncludeAllGroup         :  -
        Bypass Unbound Bandwidth Info(Kbit/sec)
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -
        --------------------------------
                   BFD Information
        --------------------------------
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -
        NextLspId               :  -           PrevLspId         :  -

    # 在PLR上配置TE FRR的扫描定时器的扫描时间间隔权值为120。

    [LSRB] mpls
    [LSRB-mpls] mpls te timer fast-reroute 120
    [LSRB-mpls] quit

    # 使PLR上被保护的出接口重新生效。

    [LSRB] interface vlanif 200
    [LSRB-Vlanif200] undo shutdown

    在LSRA上查看主CR-LSP的状态,执行命令display interface tunnel 1,可以看到Tunnel接口处于Up状态。

    等待一段时间后,在LSRB上执行display mpls te tunnel name Tunnel1 verbose命令,可以看到Tunnel1的Bypass In Use的状态为Not Used,表明数据流已切回到VLANIF200传输。

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 172.3.1.2
     next hop 4.4.4.9
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0001.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.9
     mpls te tunnel-id 100
     mpls te record-route label
     mpls te path explicit-path pri-path
     mpls te fast-reroute
     mpls te commit
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200 400
    #
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls te timer fast-reroute 120
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path by-path
     next hop 172.4.1.2
     next hop 172.5.1.2
     next hop 3.3.3.9
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0002.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 300
     mpls te record-route
     mpls te path explicit-path by-path
     mpls te bypass-tunnel
     mpls te protected-interface Vlanif200
     mpls te commit
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 300 500
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0003.00
     traffic-eng level-2
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 300
    #
    mpls lsr-id 4.4.4.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0004.00
     traffic-eng level-2
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0005.00
     traffic-eng level-2
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
     isis enable 1
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8843

下载量:344

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页