所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LDP LSP建立的触发策略示例(Ingress和Egress)

配置LDP LSP建立的触发策略示例(Ingress和Egress)

组网需求

图3-16所示,LSRA、LSRD是MPLS骨干网的边缘设备,性能较低。各LSR接口上使能MPLS LDP后,LDP LSP将自动建立,由于网络规模庞大(本例中间节点只给出两台设备),会建立大量的LSP导致资源的浪费。要求能够尽量减少边缘设备上LSP建立的数量,减轻设备的负担。

图3-16  配置LDP LSP建立的触发策略组网

配置思路

配置LDP LSP建立的触发策略,可以实现此需求。采用如下配置思路:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。

  2. 在LSR上配置本地LDP会话,实现建立LDP LSP。

  3. 在LSRA和LSRD上配置LDP LSP建立的触发策略,实现有效的减少边缘设备上LSP的数量,减轻设备的负担。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSRA。LSRB、LSRC和LSRD的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] interface loopback 0
    [LSRA-LoopBack0] ip address 1.1.1.9 32
    [LSRA-LoopBack0] quit
    [LSRA] vlan batch 10
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] ip address 10.1.1.1 24
    [LSRA-Vlanif10] quit
    [LSRA] interface gigabitethernet 1/0/1
    [LSRA-GigabitEthernet1/0/1] port link-type trunk
    [LSRA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [LSRA-GigabitEthernet1/0/1] quit

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。LSRB、LSRC和LSRD的配置与LSRA类似,不再赘述。

    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  3. 配置节点和接口的MPLS及MPLS LDP基本能力

    # 配置LSRA。LSRB、LSRC和LSRD的配置与LSRA类似,不再赘述。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] quit  
    [LSRA] mpls ldp  
    [LSRA-mpls-ldp] quit  
    [LSRA] interface vlanif 10  
    [LSRA-Vlanif10] mpls  
    [LSRA-Vlanif10] mpls ldp
    [LSRA-Vlanif10] quit

    # 配置完成后,在各节点上执行display mpls lsp命令,可以看到LDP LSP的建立情况。以LSRA的显示为例。

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         3/NULL        -/-
    2.2.2.9/32         NULL/3        -/Vlanif10
    2.2.2.9/32         1024/3        -/Vlanif10
    3.3.3.9/32         NULL/1025     -/Vlanif10
    3.3.3.9/32         1022/1025     -/Vlanif10
    4.4.4.9/32         NULL/4118     -/Vlanif10
    4.4.4.9/32         4105/4118     -/Vlanif10

  4. 根据LSP控制需求来配置IP前缀列表,在LSRA和LSRD上使用此IP前缀列表对用于LSP的路由进行过滤。

    # 在LSRA配置IP前缀列表,只允许1.1.1.9/32和4.4.4.9/32来建立LSP。

    [LSRA] ip ip-prefix FilterOnIngress permit 1.1.1.9 32
    [LSRA] ip ip-prefix FilterOnIngress permit 4.4.4.9 32
    [LSRA] mpls
    [LSRA-mpls] lsp-trigger ip-prefix FilterOnIngress
    [LSRA-mpls] quit

    # 在LSRD配置IP前缀列表,只允许1.1.1.9/32和4.4.4.9/32来建立LSP。

    [LSRD] ip ip-prefix FilterOnEgress permit 1.1.1.9 32
    [LSRD] ip ip-prefix FilterOnEgress permit 4.4.4.9 32
    [LSRD] mpls
    [LSRD-mpls] lsp-trigger ip-prefix FilterOnEgress
    [LSRD-mpls] quit

  5. 检查配置结果

    # 配置完成后,在LSRA和LSRD上执行display mpls lsp命令,可以看到LDP LSP的建立情况。

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         3/NULL        -/-
    2.2.2.9/32         1024/3        -/Vlanif10
    3.3.3.9/32         1022/1025     -/Vlanif10
    4.4.4.9/32         NULL/4118     -/Vlanif10
    4.4.4.9/32         4105/4118     -/Vlanif10  

    从以上显示信息可以看到,由于配置了LDP LSP的控制策略,节点上只存在以LSRA为Ingress的关于1.1.1.9/32和4.4.4.9/32的LDP LSP,以及其他不是以LSRA为Ingress的LDP LSP

    [LSRD] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         NULL/4110     -/Vlanif30
    1.1.1.9/32         4100/4110     -/Vlanif30
    2.2.2.9/32         1023/1028     -/Vlanif30
    3.3.3.9/32         1027/3        -/Vlanif30
    4.4.4.9/32         3/NULL        -/-       

    从以上显示信息可以看到,由于配置了LDP LSP的控制策略,节点上只存在以LSRD为Ingress的关于1.1.1.9/32和4.4.4.9/32的LDP LSP,以及其他不是以LSRD为Ingress的LDP LSP

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.9
    mpls
     lsp-trigger ip-prefix FilterOnIngress
    #
    mpls ldp
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack0
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    ip ip-prefix FilterOnIngress index 10 permit 1.1.1.9 32
    ip ip-prefix FilterOnIngress index 20 permit 4.4.4.9 32
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20 30
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.3.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack0
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 30
    #
    mpls lsr-id 4.4.4.9
    mpls
     lsp-trigger ip-prefix FilterOnEgress
    #
    mpls ldp
    #
    interface Vlanif30
     ip address 10.3.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack0
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 10.3.1.0 0.0.0.255
    #
    ip ip-prefix FilterOnEgress index 10 permit 1.1.1.9 32
    ip ip-prefix FilterOnEgress index 20 permit 4.4.4.9 32
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8129

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页