所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MPLS TE Auto FRR示例

配置MPLS TE Auto FRR示例

组网需求

图5-48所示,要求创建一条沿显式路径:LSRA→LSRB→LSRC→LSRD的主隧道。在入节点LSRA创建一条节点保护的旁路隧道用来保护节点LSRB,在中间节点LSRB上创建一条链路保护的旁路隧道用来保护LSRB→LSRC之间的链路。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图5-48  配置MPLS TE Auto FRR组网图

配置思路

采用如下的思路配置MPLS TE Auto FRR:

  1. 配置各接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS、MPLS TE、RSVP-TE、CSPF功能,使能OSPF TE。

  3. 在主隧道入节点的MPLS视图下使能MPLS TE Auto FRR,配置节点保护。在旁路隧道入节点的MPLS视图下使能MPLS TE Auto FRR,同时配置链路保护。

  4. 在主隧道入节点创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE。

  5. 在主隧道入节点隧道接口下使能TE FRR。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF

    # 配置LSRA。按图5-48配置各设备的接口IP地址,其中LSRB、LSRC、LSRD、LSRE和LSRF的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100 600
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] ip address 172.6.1.1 255.255.255.0
    [LSRA-Vlanif600] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type trunk
    [LSRA-GigabitEthernet2/0/0] port trunk allow-pass vlan 600
    [LSRA-GigabitEthernet2/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.6.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    配置完成后,在各节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。以LSRA的显示为例:

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 17       Routes : 21                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  OSPF    10   1           D   172.1.1.2       Vlanif100
            3.3.3.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
                        OSPF    10   2           D   172.6.1.2       Vlanif600
            4.4.4.9/32  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
            5.5.5.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
            6.6.6.9/32  OSPF    10   1           D   172.6.1.2       Vlanif600
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.3.1.0/24  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
          172.4.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.5.1.0/24  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
          172.6.1.0/24  Direct  0    0           D   172.6.1.1       Vlanif600
          172.6.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif600
          172.7.1.0/24  OSPF    10   2           D   172.6.1.2       Vlanif600
    

  2. 配置MPLS基本能力,使能MPLS TE、RSVP-TE和CSPF

    # 配置LSRA。LSRB、LSRC、LSRD、LSRE和LSRF的配置与LSRA类似,不再赘述。其中,只需在主隧道和旁路隧道的入节点上使能CSPF。即只需在LSRA、LSRB上使能CSPF,LSRC、LSRD和LSRE、LSRF上无需使能CSPF。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] mpls
    [LSRA-Vlanif600] mpls te
    [LSRA-Vlanif600] mpls rsvp-te
    [LSRA-Vlanif600] quit
    

  3. 配置OSPF TE

    # 配置LSRA。LSRB、LSRC、LSRD、LSRE和LSRF的配置与LSRA类似,不再赘述。

    [LSRA] ospf
    [LSRA-ospf-1] opaque-capability enable
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  4. 使能TE Auto FRR

    # 配置LSRA。

    [LSRA] mpls
    [LSRA-mpls] mpls te auto-frr
    [LSRA-mpls] quit

    # 配置LSRB。

    [LSRB] mpls
    [LSRB-mpls] mpls te auto-frr
    [LSRB-mpls] quit
    [LSRB] interface vlanif 200
    [LSRB-Vlanif200] mpls te auto-frr link
    [LSRB-Vlanif200] quit

  5. 在入节点LSRA上创建主CR-LSP的MPLS TE Tunnel

    # 配置主CR-LSP的显式路径。

    [LSRA] explicit-path pri-path
    [LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [LSRA-explicit-path-pri-path] next hop 172.3.1.2
    [LSRA-explicit-path-pri-path] next hop 4.4.4.9
    [LSRA-explicit-path-pri-path] quit

    # 配置主CR-LSP的MPLS TE隧道接口。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopBack 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 4.4.4.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te record-route label
    [LSRA-Tunnel1] mpls te path explicit-path pri-path
    [LSRA-Tunnel1] mpls te priority 4 3
    [LSRA-Tunnel1] mpls te fast-reroute
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

  6. 检查配置结果

    在节点上执行display mpls te tunnel命令,可以看到隧道的建立情况,LSRA和LSRB上有两条隧道经过,LSRC上有三条隧道经过(分别为一条主隧道和两条Bypass隧道)。

    [LSRA] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      --/1055          I  Tunnel1       
    1.1.1.9          3.3.3.9          3       --/1024          I  Tunnel16384    
    
    [LSRB] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      1055/1063        T  Tunnel1       
    2.2.2.9          3.3.3.9          1       --/1033          I  Tunnel16384    
    
    [LSRC] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      1063/3           T  Tunnel1       
    1.1.1.9          3.3.3.9          3       3/--             E  Tunnel16384    
    2.2.2.9          3.3.3.9          1       3/--             E  Tunnel16384    
    
    [LSRD] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      3/--             E  Tunnel1       
    
    [LSRE] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    2.2.2.9          3.3.3.9          1       1033/3           T  Tunnel16384    
    
    [LSRF] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          3.3.3.9          3       1024/3           T  Tunnel16384    
    

    在入节点LSRA和LSRB上使用命令display mpls te tunnel name Tunnel1 verbose查看LSP信息时,可以看到主隧道信息及与之绑定的旁路隧道。

    [LSRA] display mpls te tunnel name Tunnel1 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                      
        Tunnel Interface Name   :  Tunnel1                                      
        TunnelIndex             :  3           LSP Index         :  2050            
        Session ID              :  100         LSP ID            :  34              
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  4.4.4.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif100                                       
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  -                                                
        ER-Hop Table Index      :  0           AR-Hop Table Index:  0               
        C-Hop Table Index       :  0                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8205                                            
        Created Time            :  2013-09-16 16:11:50+00:00                  
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  4           Hold-Priority     :  3               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x63        Protected Flag    :  0x2             
        Bypass In Use           :  Not Used                                         
        Bypass Tunnel Id        :  41                                               
        BypassTunnel            :  Tunnel Index[Tunnel16384], InnerLabel[1063]   
        Bypass LSP ID           :  3           FrrNextHop        :  172.7.1.2       
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
    
    [LSRB] display mpls te tunnel name Tunnel1 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                      
        Tunnel Interface Name   :  -                                                
        TunnelIndex             :  3           LSP Index         :  2049            
        Session ID              :  100         LSP ID            :  34              
        LSR Role                :  Transit                                          
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  4.4.4.9                                          
        In-Interface            :  Vlanif100                                      
        Out-Interface           :  Vlanif200                                      
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        ER-Hop Table Index      :  3           AR-Hop Table Index:  1               
        C-Hop Table Index       :  -                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8198                                           
        Created Time            :  2013-09-16 16:12:50+00:00                          
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  4           Hold-Priority     :  3               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x63        Protected Flag    :  0x1             
        Bypass In Use           :  Not Used                                         
        Bypass Tunnel Id        :  65                                               
        BypassTunnel            :  Tunnel Index[Tunnel16384], InnerLabel[1063]   
        Bypass LSP ID           :  1           FrrNextHop        :  172.5.1.2       
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -           CT1 Unbound Bandwidth:  -            
        CT2 Unbound Bandwidth   :  -           CT3 Unbound Bandwidth:  -            
        CT4 Unbound Bandwidth   :  -           CT5 Unbound Bandwidth:  -            
        CT6 Unbound Bandwidth   :  -           CT7 Unbound Bandwidth:  -            
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               

    可以看到LSRA上主隧道和一条自动旁路隧道Tunnel16384绑定,LSRB上主隧道和一条自动旁路隧道Tunnel16384绑定。

    分别在LSRA上执行命令display mpls te tunnel name Tunnel16384 verbose,在LSRB上执行display mpls te tunnel name Tunnel16384 verbose,可以看到自动旁路隧道的详细信息。

    [LSRA] display mpls te tunnel name Tunnel16384 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel16384                                   
        Tunnel Interface Name   :  Tunnel16384                                   
        TunnelIndex             :  1           LSP Index         :  2048            
        Session ID              :  1025        LSP ID            :  3               
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif600                                     
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  -                                                
        ER-Hop Table Index      :  -           AR-Hop Table Index:  0               
        C-Hop Table Index       :  1                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8206                                            
        Created Time            :  2013-09-16 16:11:50+00:00                            
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
    [LSRB] display mpls te tunnel name Tunnel16384 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel16384                                   
        Tunnel Interface Name   :  Tunnel16384                                   
        TunnelIndex             :  1           LSP Index         :  2050            
        Session ID              :  1026        LSP ID            :  1               
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  2.2.2.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif400                                          
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  -                                                
        ER-Hop Table Index      :  -           AR-Hop Table Index:  0               
        C-Hop Table Index       :  0                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8199                                           
        Created Time            :  2013-09-16 16:12:50+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               

    可以看到LSRA上自动旁路隧道保护主隧道的出接口VLANIF100,排除了主隧道路径上LSRB,进行节点保护。LSRB上自动旁路隧道保护主隧道的出接口VLANIF200,对LSRB→LSRC之间的链路进行链路保护。

    分别在LSRA和LSRB上执行命令display mpls te tunnel path可以看到主隧道和自动旁路隧道的路径信息,在主隧道的出接口这一跳上显示主隧道受节点保护和链路保护。

    [LSRA] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1                                            
     Lsp ID : 1.1.1.9 :100 :34                                                      
     Hop Information                                                                
      Hop 0   172.1.1.1 Local-Protection available | node                           
      Hop 1   172.1.1.2  Label 1055                                                 
      Hop 2   2.2.2.9  Label 1055                                                   
      Hop 3   172.2.1.1 Local-Protection available                                  
      Hop 4   172.2.1.2  Label 1063                                                 
      Hop 5   3.3.3.9  Label 1063                                                   
      Hop 6   172.3.1.1                                                             
      Hop 7   172.3.1.2  Label 3                                                    
      Hop 8   4.4.4.9  Label 3                                                      
    
     Tunnel Interface Name : Tunnel16384                                         
     Lsp ID : 1.1.1.9 :1025 :3                                                      
     Hop Information                                                                
      Hop 0   172.6.1.1                                                             
      Hop 1   172.6.1.2  Label 1024                                                 
      Hop 2   6.6.6.9  Label 1024                                                   
      Hop 3   172.7.1.1                                                             
      Hop 4   172.7.1.2  Label 3                                                    
      Hop 5   3.3.3.9  Label 3                                                      
    
    [LSRB] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1                                            
     Lsp ID : 1.1.1.9 :100 :34                                                      
     Hop Information                                                                
      Hop 0   1.1.1.9                                                               
      Hop 1   172.1.1.1 Local-Protection available | node                           
      Hop 2   172.1.1.2  Label 1055                                                 
      Hop 3   2.2.2.9                                                               
      Hop 4   172.2.1.1 Local-Protection available                                  
      Hop 5   172.2.1.2  Label 1063                                                 
      Hop 6   3.3.3.9  Label 1063                                                   
      Hop 7   172.3.1.1                                                             
      Hop 8   172.3.1.2  Label 3                                                    
      Hop 9   4.4.4.9  Label 3                                                      
    
     Tunnel Interface Name : Tunnel16384                                         
     Lsp ID : 2.2.2.9 :1026 :1                                                      
     Hop Information                                                                
      Hop 0   172.4.1.1                                                             
      Hop 1   172.4.1.2  Label 1033                                                 
      Hop 2   5.5.5.9  Label 1033                                                   
      Hop 3   172.5.1.1                                                             
      Hop 4   172.5.1.2  Label 3                                                    
      Hop 5   3.3.3.9  Label 3                                                      
    

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100 600
    #
    mpls lsr-id 1.1.1.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls te auto-frr                                                               
     mpls rsvp-te                                                                   
     mpls te cspf 
    #
    explicit-path pri-path                                                          
     next hop 172.1.1.2                                                             
     next hop 172.2.1.2                                                             
     next hop 172.3.1.2                                                             
     next hop 4.4.4.9 
    #    
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #    
    interface Vlanif600
     ip address 172.6.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.9
     mpls te tunnel-id 100
     mpls te record-route label
     mpls te priority 4 3
     mpls te path explicit-path pri-path
     mpls te fast-reroute
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.6.1.0 0.0.0.255 
      mpls-te enable
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200 400
    # 
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls te auto-frr
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls te auto-frr link
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255 
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 300 500 700
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te 
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.3.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 300
    #
    mpls lsr-id 4.4.4.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0                                                       
      network 172.3.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0                                                       
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRF的配置文件

    #
    sysname LSRF
    #
    vlan batch 600 700
    #
    mpls lsr-id 6.6.6.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 6.6.6.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 6.6.6.9 0.0.0.0                                                       
      network 172.6.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8251

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页