所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置LDP GTSM示例

配置LDP GTSM示例

组网需求

图3-26所示,各节点间运行MPLS和MPLS LDP协议。要求对节点进行保护,增强系统的安全性,防止攻击者模拟真实的LDP协议单播报文,对LSRB发送报文,导致系统异常繁忙,CPU占用率高的问题。

图3-26  配置LDP GTSM组网

配置思路

配置LDP GTSM功能,可以实现此需求。采用如下配置思路:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。
  2. 在LSR上使能全局和接口MPLS、MPLS LDP。
  3. 在LSR上配置GTSM功能,设置TTL的范围。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] interface loopback 0
    [LSRA-LoopBack0] ip address 1.1.1.1 32
    [LSRA-LoopBack0] quit
    [LSRA] vlan batch 10
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] ip address 10.1.1.1 24
    [LSRA-Vlanif10] quit
    [LSRA] interface gigabitethernet 1/0/1
    [LSRA-GigabitEthernet1/0/1] port link-type trunk
    [LSRA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [LSRA-GigabitEthernet1/0/1] quit

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。

    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    # 配置LSRB。

    [LSRB] ospf 1
    [LSRB-ospf-1] area 0
    [LSRB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [LSRB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [LSRB-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [LSRB-ospf-1-area-0.0.0.0] quit
    [LSRB-ospf-1] quit

    # 配置LSRC。

    [LSRC] ospf 1
    [LSRC-ospf-1] area 0
    [LSRC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [LSRC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [LSRC-ospf-1-area-0.0.0.0] quit
    [LSRC-ospf-1] quit

    # 配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了彼此的路由。

  3. 配置各节点和接口的MPLS和MPLS LDP能力

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [LSRA] mpls lsr-id 1.1.1.1
    [LSRA] mpls
    [LSRA-mpls] quit
    [LSRA] mpls ldp
    [LSRA-mpls-ldp] quit
    [LSRA] interface vlanif 10 
    [LSRA-Vlanif10] mpls
    [LSRA-Vlanif10] mpls ldp
    [LSRA-Vlanif10] quit
    

    完成上述配置后,在各节点上执行display mpls ldp session命令,可以看到LDP会话的建立情况。以LSRA的显示为例:

    [LSRA] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.2:0          Operational DU   Passive  0000:00:02  9/9
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    

  4. 配置LDP GTSM

    # 在LSRA上配置:LSRB发送给LSRA的LDP报文的有效TTL范围是253到255。

    [LSRA] mpls ldp
    [LSRA-mpls-ldp] gtsm peer 2.2.2.2 valid-ttl-hops 3
    [LSRA-mpls-ldp] quit

    # 在LSRB上配置:LSRA发送给LSRB的LDP报文的有效TTL范围是252到255;LSRC发送给LSRB的LDP报文的有效TTL范围是251到255。

    [LSRB] mpls ldp
    [LSRB-mpls-ldp] gtsm peer 1.1.1.1 valid-ttl-hops 4
    [LSRB-mpls-ldp] gtsm peer 3.3.3.3 valid-ttl-hops 5
    [LSRB-mpls-ldp] quit

    # 在LSRC上配置:LSRB发送给LSRC的LDP报文的有效TTL范围是250到255。

    [LSRC] mpls ldp
    [LSRC-mpls-ldp] gtsm peer 2.2.2.2 valid-ttl-hops 6
    [LSRC-mpls-ldp] quit

    此时如果主机PC模拟LSRA的LDP协议报文对LSRB进行攻击,由于该报文到达LSRB时,TTL值不在252~255范围内,所以被丢弃。在LSRB的GTSM统计信息中丢弃的报文数也会相应的增加。

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.1
    mpls
    #
    mpls ldp
     gtsm peer 2.2.2.2 valid-ttl-hops 3
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    mpls
    #
    mpls ldp
     gtsm peer 1.1.1.1 valid-ttl-hops 4
     gtsm peer 3.3.3.3 valid-ttl-hops 5
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
    
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20
    #
    mpls lsr-id 3.3.3.3
    mpls
    #
    mpls ldp
     gtsm peer 2.2.2.2 valid-ttl-hops 6
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
    
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8743

下载量:344

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页