所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Manual LDP FRR示例

配置Manual LDP FRR示例

组网需求

图3-23所示,网络拓扑结构简单并且稳定,LSRA、LSRB、LSRC为MPLS骨干网设备。LSRA到LSRC之间建立LSP承载网络业务,其中LSRA->LSRC为主用LSP,LSRA->LSRB->LSRC为备份LSP。当主用LSP发生故障时,流量切换到备份LSP,造成MPLS流量丢失。对于实时性要求高的网络业务(例如VoIP,在线游戏,在线视频业务等),用户无法容忍业务的短时间中断,要求在主用LSP发生故障的时候,流量能够快速切换到备份LSP,尽可能避免流量的丢失。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图3-23  配置Manual LDP FRR组网

配置思路

配置Manual LDP FRR,可以实现此需求。采用如下配置思路:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。
  2. 在LSR上配置本地LDP会话,实现创建LDP LSP承载网络业务。
  3. 在LSRA、LSRC上配置静态BFD检测LDP LSP,实现快速检测LSP故障。
  4. 由于网络拓扑结构简单并且稳定,因此在LSRA上配置Manual LDP FRR,实现主备切换时尽可能地避免流量丢失。
说明:

在Manual LDP FRR的组网中,备份LSP必须是Liberal状态的LSP,即在使能FRR的节点上执行display ip routing-table ip-address verbose命令可以发现备份LSP的路由状态是“Inactive Adv”。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 32
    [LSRA-LoopBack1] quit
    [LSRA] vlan batch 10 20
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] ip address 10.1.1.1 30
    [LSRA-Vlanif10] quit
    [LSRA] interface vlanif 20
    [LSRA-Vlanif20] ip address 10.3.1.1 30
    [LSRA-Vlanif20] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type trunk
    [LSRA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [LSRA-GigabitEthernet2/0/0] quit

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.3
    [LSRA-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.3
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了彼此的路由。

  3. 配置各节点全局和接口的MPLS和MPLS LDP能力,使网络能够转发MPLS流量

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] quit
    [LSRA] mpls ldp
    [LSRA-mpls-ldp] quit
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] mpls
    [LSRA-Vlanif10] mpls ldp
    [LSRA-Vlanif10] quit
    [LSRA] interface vlanif 20
    [LSRA-Vlanif20] mpls
    [LSRA-Vlanif20] mpls ldp
    [LSRA-Vlanif20] quit

    上述配置完成后,相邻节点之间应该建立起LDP会话。在各节点上执行display mpls ldp session命令可以看到显示结果中Status项为“Operational”。以LSRA的显示为例:

    [LSRA] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.9:0          Operational DU   Passive  0000:00:01  8/8
     3.3.3.9:0          Operational DU   Passive  0000:00:01  6/6
     ------------------------------------------------------------------------------
     TOTAL: 2 session(s) Found.
    

  4. 在LSRA、LSRC上配置静态BFD检测LDP LSP

    # 配置LSRA。

    [LSRA] bfd
    [LSRA-bfd] quit
    [LSRA] bfd lsratoc bind ldp-lsp peer-ip 3.3.3.9 nexthop 10.3.1.2 interface vlanif 20
    [LSRA-bfd-lsp-session-lsratoc] discriminator local 1
    [LSRA-bfd-lsp-session-lsratoc] discriminator remote 2
    [LSRA-bfd-lsp-session-lsratoc] min-tx-interval 100
    [LSRA-bfd-lsp-session-lsratoc] min-rx-interval 100
    [LSRA-bfd-lsp-session-lsratoc] process-pst
    [LSRA-bfd-lsp-session-lsratoc] commit
    [LSRA-bfd-lsp-session-lsratoc] quit

    # 配置LSRC。

    [LSRC] bfd
    [LSRC-bfd] quit
    [LSRC] bfd lsrctoa bind  peer-ip 1.1.1.9
    [LSRC-bfd-session-lsrctoa] discriminator local 2
    [LSRC-bfd-session-lsrctoa] discriminator remote 1
    [LSRC-bfd-session-lsrctoa] min-tx-interval 100
    [LSRC-bfd-session-lsrctoa] min-rx-interval 100
    [LSRC-bfd-session-lsrctoa] commit
    [LSRC-bfd-session-lsrctoa] quit

    配置完成后,在LSRA上执行命令display bfd session all,可以看到“State”字段的值为“Up”。

  5. 在LSRA的接口Vlanif20下使能Manual LDP FRR,指定用于生成备用LSP的下一跳地址

    # 配置LSRA。

    [LSRA] interface vlanif 20
    [LSRA-Vlanif20] mpls ldp frr nexthop 10.1.1.2
    [LSRA-Vlanif20] quit

  6. 检查配置结果

    上述配置完成后,在LSRA节点上执行display mpls lsp命令,可以看到到达LSRC的LSP上存在Manual LDP FRR。

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
     -------------------------------------------------------------------------------
                      LSP Information: LDP LSP
     -------------------------------------------------------------------------------
     FEC                In/Out Label  In/Out IF                      Vrf Name
     1.1.1.9/32         3/NULL        -/-     
     2.2.2.9/32         NULL/3        -/Vlanif10
     2.2.2.9/32         1024/3        -/Vlanif10
     3.3.3.9/32         NULL/3        -/Vlanif20
        **LDP FRR**         /1025      /Vlanif10
     3.3.3.9/32         1025/3        -/Vlanif20
        **LDP FRR**         /1025      /Vlanif10
    

    将同一台测试仪的两个接口(Port1和Port2)分别接入LSRA和LSRC,从Port1向Port2打MPLS流。当对LSRA的VLANIF20接口进行shutdown操作来模拟主用LSP故障时,发现流量快速切换到备份LSP。

配置文件

  • LSRA的配置文件

    #
    sysname LSRA 
    #
    vlan batch 10 20
    #
    bfd
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.252
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.3.1.1 255.255.255.252
     mpls
     mpls ldp
     mpls ldp frr nexthop 10.1.1.2
    #
    interface GigabitEthernet1/0/0
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.3
      network 10.3.1.0 0.0.0.3
    #
    bfd lsratoc bind ldp-lsp peer-ip 3.3.3.9 nexthop 10.3.1.2 interface Vlanif20
     discriminator local 1 
     discriminator remote 2
     min-tx-interval 100
     min-rx-interval 100
     process-pst
     commit
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 30
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.252
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.2.1.1 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk 
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0  
      network 10.1.1.0 0.0.0.3
      network 10.2.1.0 0.0.0.3
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20 30
    #
    bfd
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif20
     ip address 10.3.1.2 255.255.255.252
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.2.1.2 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet2/0/0
     port link-type trunk 
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    bfd lsrctoa bind peer-ip 1.1.1.9
     discriminator local 2
     discriminator remote 1
     min-tx-interval 100
     min-rx-interval 100
     commit
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.3
      network 10.3.1.0 0.0.0.3
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8268

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页