所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置TE FRR与备份CR-LSP同步示例

配置TE FRR与备份CR-LSP同步示例

组网需求

图5-50所示,要求创建一条沿显式路径:LSRA→LSRB→LSRC→LSRD的主隧道。在中间节点LSRB上配置一条TE FRR的旁路保护隧道,路径为LSRB→LSRE→LSRC,并在入节点LSRA上配置普通备份CR-LSP,路径为LSRA→LSRF→LSRC→LSRD。

当LSRB和LSRC之间的链路出现故障后,设备启用TE FRR旁路保护隧道(即主CR-LSP处于Frr-in-use状态)并尝试恢复主CR-LSP的同时,也会尝试创建备份CR-LSP。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图5-50  配置TE FRR与备份CR-LSP同步组网图

配置思路

采用如下的思路配置TE FRR与备份CR-LSP同步:

  1. 配置各接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS、MPLS TE、RSVP-TE、CSPF功能,使能OSPF TE。

  3. 在主隧道入节点创建隧道接口,配置隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE。

  4. 在入节点的主隧道接口下使能TE FRR。

  5. 在被保护链路的旁路隧道入节点即LSRB上配置TE FRR旁路保护隧道,路径为LSRB→LSRE→LSRC,用来保护LSRB和LSRC之间的链路。

  6. 在入节点上配置普通备份CR-LSP,路径为LSRA→LSRF→LSRC→LSRD。

  7. 在入节点的主隧道接口视图下配置旁路保护隧道与备份CR-LSP同步功能。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF

    # 配置LSRA。按图5-50配置各设备的接口IP地址,其中LSRB、LSRC、LSRD、LSRE和LSRF的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100 600
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] ip address 172.6.1.1 255.255.255.0
    [LSRA-Vlanif600] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type trunk
    [LSRA-GigabitEthernet2/0/0] port trunk allow-pass vlan 600
    [LSRA-GigabitEthernet2/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.6.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    配置完成后,在各节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。以LSRA的显示为例:

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 17       Routes : 21                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  OSPF    10   1           D   172.1.1.2       Vlanif100
            3.3.3.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
                        OSPF    10   2           D   172.6.1.2       Vlanif600
            4.4.4.9/32  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
            5.5.5.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
            6.6.6.9/32  OSPF    10   1           D   172.6.1.2       Vlanif600
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.3.1.0/24  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
          172.4.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.5.1.0/24  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
          172.6.1.0/24  Direct  0    0           D   172.6.1.1       Vlanif600
          172.6.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif600
          172.7.1.0/24  OSPF    10   2           D   172.6.1.2       Vlanif600
    

  2. 配置MPLS基本能力,使能MPLS TE、RSVP-TE和CSPF

    # 配置LSRA。LSRB、LSRC、LSRD、LSRE和LSRF的配置与LSRA类似,不再赘述。其中,只需在主隧道和旁路隧道的入节点上使能CSPF。即只需在LSRA、LSRB上使能CSPF,LSRC、LSRD和LSRE、LSRF上无需使能CSPF。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] mpls
    [LSRA-Vlanif600] mpls te
    [LSRA-Vlanif600] mpls rsvp-te
    [LSRA-Vlanif600] quit
    

  3. 配置OSPF TE

    # 配置LSRA。LSRB、LSRC、LSRD、LSRE和LSRF的配置与LSRA类似,不再赘述。

    [LSRA] ospf
    [LSRA-ospf-1] opaque-capability enable
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  4. 在入节点LSRA上创建主CR-LSP的MPLS TE Tunnel

    # 配置主CR-LSP的显式路径。

    [LSRA] explicit-path pri-path
    [LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [LSRA-explicit-path-pri-path] next hop 172.3.1.2
    [LSRA-explicit-path-pri-path] next hop 4.4.4.9
    [LSRA-explicit-path-pri-path] quit

    # 配置主CR-LSP的MPLS TE隧道接口。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 4.4.4.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te path explicit-path pri-path

    # 使能TE FRR。

    [LSRA-Tunnel1] mpls te fast-reroute
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    配置完成后,在LSRA上执行display interface tunnel命令,可以看到Tunnel1的状态为Up。

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-01-21 10:58:49                                
    Description:
    ...

  5. 在作为PLR的LSRB上配置Bypass CR-LSP

    # 配置Bypass CR-LSP的显式路径。

    [LSRB] explicit-path by-path
    [LSRB-explicit-path-by-path] next hop 172.4.1.2
    [LSRB-explicit-path-by-path] next hop 172.5.1.2
    [LSRB-explicit-path-by-path] next hop 3.3.3.9
    [LSRB-explicit-path-by-path] quit

    # 配置Bypass CR-LSP的隧道接口。

    [LSRB] interface tunnel 2
    [LSRB-Tunnel2] ip address unnumbered interface loopback 1
    [LSRB-Tunnel2] tunnel-protocol mpls te
    [LSRB-Tunnel2] destination 3.3.3.9
    [LSRB-Tunnel2] mpls te tunnel-id 300
    [LSRB-Tunnel2] mpls te path explicit-path by-path
    [LSRB-Tunnel2] mpls te bypass-tunnel

    # 将Bypass CR-LSP绑定到被保护的接口。

    [LSRB-Tunnel2] mpls te protected-interface vlanif 200
    [LSRB-Tunnel2] mpls te commit
    [LSRB-Tunnel2] quit

    在节点上执行display mpls lsp命令,可以看到LSP表项,并且LSRB和LSRC上有两条CR-LSP经过。以LSRB为例:

    [LSRB] display mpls lsp
    -------------------------------------------------------------------------------
                     LSP Information: RSVP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    4.4.4.9/32         1059/1068     Vlanif100/Vlanif200
    3.3.3.9/32         NULL/1036     -/Vlanif400
    

    在节点上执行display mpls te tunnel命令,可以看到隧道的建立情况,LSRB和LSRC上有两条隧道经过。以LSRB为例:

    [LSRB] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    1.1.1.9          4.4.4.9          40      1059/1068        T  Tunnel1
    2.2.2.9          3.3.3.9          4       --/1036          I  Tunnel2
    

    在LSRB上执行display mpls te tunnel name Tunnel1 verbose命令,可以看到旁路隧道绑定到出接口VLANIF200,目前未被使用。

    [LSRB] display mpls te tunnel name Tunnel1 verbose
        No                      :  1
        Tunnel-Name             :  Tunnel1
        Tunnel Interface Name   :  - 
        TunnelIndex             :  3           LSP Index         :  2048
        Session ID              :  100         LSP ID            :  40
        LSR Role                :  Transit
        Ingress LSR ID          :  1.1.1.9
        Egress LSR ID           :  4.4.4.9
        In-Interface            :  Vlanif100
        Out-Interface           :  Vlanif200
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0
        IncludeAllAff           :  0x0
        ER-Hop Table Index      :  3           AR-Hop Table Index:  1
        C-Hop Table Index       :  -
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -
        PSB Handle              :  8200 
        Created Time            :  2013-09-16 12:52:03+00:00
        RSVP LSP Type           :  -             
        --------------------------------
                  DS-TE Information
        --------------------------------
        Bandwidth Reserved Flag :  Unreserved
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0
        Setup-Priority          :  7           Hold-Priority     :  7
        --------------------------------
                    FRR Information
        --------------------------------
        Primary LSP Info
        TE Attribute Flag       :  0x63        Protected Flag    :  0x1
        Bypass In Use           :  Not Used
        Bypass Tunnel Id        :  15
        BypassTunnel            :  Tunnel Index[Tunnel2], InnerLabel[1068]
        Bypass LSP ID           :  4           FrrNextHop        :  172.5.1.2
        ReferAutoBypassHandle   :  -
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -
        Bypass Attribute(Not configured)
        Setup Priority          :  -           Hold Priority     :  -
        HopLimit                :  -           Bandwidth         :  -
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -
        IncludeAllGroup         :  -
        Bypass Unbound Bandwidth Info(Kbit/sec)
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -
        --------------------------------
                   BFD Information
        --------------------------------
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -
        NextLspId               :  -           PrevLspId         :  -

  6. 在入节点LSRA上创建普通备份CR-LSP的MPLS TE Tunnel

    # 配置备份CR-LSP的显式路径。

    [LSRA] explicit-path backup-path
    [LSRA-explicit-path-backup-path] next hop 172.6.1.2
    [LSRA-explicit-path-backup-path] next hop 172.7.1.2
    [LSRA-explicit-path-backup-path] next hop 172.3.1.2
    [LSRA-explicit-path-backup-path] next hop 4.4.4.9
    [LSRA-explicit-path-backup-path] quit

    # 配置LSRA的备份CR-LSP。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] mpls te backup ordinary
    [LSRA-Tunnel1] mpls te path explicit-path backup-path secondary
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

  7. 在主CR-LSP的入节点配置TE FRR与备份CR-LSP同步

    # 配置LSRA。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] mpls te backup frr-in-use
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    在入节点LSRA上执行display mpls te tunnel-interface Tunnel 1命令可以查看主CR-LSP的信息。

    [LSRA] display mpls te tunnel-interface Tunnel 1
        ----------------------------------------------------------------            
                                   Tunnel1                                      
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Primary LSP                                          
        Session ID          :  100                                                  
        Ingress LSR ID      :  1.1.1.9          Egress LSR ID:  4.4.4.9             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 40                   
                                                                                    

  8. 检查配置结果

    # 使LSRB上被保护的出接口失效。

    [LSRB] interface gigabitethernet 2/0/0
    [LSRB-GigabitEthernet2/0/0] shutdown
    [LSRB-GigabitEthernet2/0/0] quit

    在入节点LSRA上执行display mpls te tunnel-interface命令,可以看到隧道状态为“Up”,说明主隧道处于Frr-in-use状态的同时,正在创建普通备份的CR-LSP和恢复主CR-LSP。

    [LSRA] display mpls te tunnel-interface
        ----------------------------------------------------------------            
                                   Tunnel1                                      
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Ordinary LSP                                         
        Session ID          :  100                                                  
        Ingress LSR ID      :  1.1.1.9          Egress LSR ID:  4.4.4.9             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 40                   
          Modify LSP State     : SETTING UP                             
        Ordinary LSP State     : UP                                                 
          Main LSP State       : READY               LSP ID  : 32774                

    即当主CR-LSP故障后,系统启用TE FRR旁路保护隧道(即主CR-LSP处于Frr-in-use状态)并尝试恢复主CR-LSP的同时,也会尝试创建备份CR-LSP。

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100 600
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path backup-path                                                       
     next hop 172.6.1.2                                                             
     next hop 172.7.1.2                                                             
     next hop 172.3.1.2                                                             
     next hop 4.4.4.9                                                               
    #                                                                               
    explicit-path pri-path                                                          
     next hop 172.1.1.2                                                             
     next hop 172.2.1.2                                                             
     next hop 172.3.1.2                                                             
     next hop 4.4.4.9 
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #    
    interface Vlanif600
     ip address 172.6.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 4.4.4.9                                                            
     mpls te tunnel-id 100                                                          
     mpls te record-route label                                                     
     mpls te path explicit-path pri-path                                            
     mpls te path explicit-path backup-path secondary                               
     mpls te fast-reroute                                                           
     mpls te backup ordinary                                                        
     mpls te backup frr-in-use                                                      
     mpls te commit 
    #
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.6.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return 
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200 400
    #
    mpls lsr-id 2.2.2.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te                                                                   
     mpls te cspf                                                                   
    #
    explicit-path by-path                                                           
     next hop 172.4.1.2                                                             
     next hop 172.5.1.2                                                             
     next hop 3.3.3.9                                                               
    # 
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #                                                                               
    interface Tunnel2                                                           
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 3.3.3.9                                                            
     mpls te tunnel-id 300                                                          
     mpls te record-route                                                           
     mpls te path explicit-path by-path                                             
     mpls te bypass-tunnel                                                          
     mpls te protected-interface Vlanif200                               
     mpls te commit
    #
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return 
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 300 500 700
    #
    mpls lsr-id 3.3.3.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te 
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.3.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255                                                   
      mpls-te enable 
    #
    return 
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 300
    #
    mpls lsr-id 4.4.4.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0                                                       
      network 172.3.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0                                                       
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRF的配置文件

    #
    sysname LSRF
    #
    vlan batch 600 700
    #
    mpls lsr-id 6.6.6.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 6.6.6.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 6.6.6.9 0.0.0.0                                                       
      network 172.6.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8250

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页