所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置静态LSP示例

配置静态LSP示例

组网需求

图2-3所示,网络拓扑结构简单并且稳定,LSR_1、LSR_2、LSR_3为MPLS骨干网设备。要求在骨干网上创建稳定的公网隧道来承载L2VPN或L3VPN业务。

图2-3  建立静态LSP的组网

配置思路

配置静态LSP,可以实现此需求。按要求需配置两条静态LSP:LSR_1到LSR_3的路径为LSP1,LSR_1为Ingress,LSR_2为Transit,LSR_3为Egress;LSR_3到LSR_1的路径为LSP2,LSR_3为Ingress,LSR_2为Transit,LSR_1为Egress。采用如下的配置思路:

  1. 在LSR上配置OSPF,实现骨干网的IP连通性。
  2. 在LSR上配置MPLS功能,这是实现在骨干网上创建公网隧道的前提。
  3. 由于网络拓扑结构简单并且稳定,且需创建稳定的公网隧道来承载L2VPN或L3VPN业务,因此配置静态LSP。为了实现这一步,需进行以下操作。
    1. 在Ingress配置此LSP的目的地址、下一跳和出标签的值。
    2. 在Transit配置此LSP的入接口、与上一节点出标签相等的入标签的值、对应的下一跳和出标签的值。
    3. 在Egress配置此LSP的入接口、与上一节点出标签相等的入标签的值。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSR_1。LSR_2和LSR_3的配置与LSR_1类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSR_1
    [LSR_1] interface loopback 1
    [LSR_1-LoopBack1] ip address 1.1.1.9 32
    [LSR_1-LoopBack1] quit
    [LSR_1] vlan batch 100
    [LSR_1] interface vlanif 100
    [LSR_1-Vlanif100] ip address 172.1.1.1 24
    [LSR_1-Vlanif100] quit
    [LSR_1] interface gigabitethernet 1/0/1
    [LSR_1-GigabitEthernet1/0/1] port link-type trunk
    [LSR_1-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [LSR_1-GigabitEthernet1/0/1] quit
    

  2. 配置OSPF协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSR_1。

    [LSR_1] ospf 1
    [LSR_1-ospf-1] area 0
    [LSR_1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSR_1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSR_1-ospf-1-area-0.0.0.0] quit
    [LSR_1-ospf-1] quit

    # 配置LSR_2。

    [LSR_2] ospf 1
    [LSR_2-ospf-1] area 0
    [LSR_2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [LSR_2-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSR_2-ospf-1-area-0.0.0.0] network 172.2.1.0 0.0.0.255
    [LSR_2-ospf-1-area-0.0.0.0] quit
    [LSR_2-ospf-1] quit

    # 配置LSR_3。

    [LSR_3] ospf 1
    [LSR_3-ospf-1] area 0
    [LSR_3-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [LSR_3-ospf-1-area-0.0.0.0] network 172.2.1.0 0.0.0.255
    [LSR_3-ospf-1-area-0.0.0.0] quit
    [LSR_3-ospf-1] quit

    # 配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了彼此的路由。

  3. 在各节点使能MPLS基本功能

    # 配置LSR_1。

    [LSR_1] mpls lsr-id 1.1.1.9 
    [LSR_1] mpls 
    [LSR_1-mpls] quit 

    # 配置LSR_2。

    [LSR_2] mpls lsr-id 2.2.2.9 
    [LSR_2] mpls 
    [LSR_2-mpls] quit 

    # 配置LSR_3。

    [LSR_3] mpls lsr-id 3.3.3.9 
    [LSR_3] mpls 
    [LSR_3-mpls] quit 

  4. 配置各接口的MPLS能力

    # 配置LSR_1。

    [LSR_1] interface vlanif 100
    [LSR_1-Vlanif100] mpls
    [LSR_1-Vlanif100] quit
    

    # 配置LSR_2。

    [LSR_2] interface vlanif 100
    [LSR_2-Vlanif100] mpls
    [LSR_2-Vlanif100] quit
    [LSR_2] interface vlanif 200
    [LSR_2-Vlanif200] mpls
    [LSR_2-Vlanif200] quit

    # 配置LSR_3。

    [LSR_3] interface vlanif 200
    [LSR_3-Vlanif200] mpls
    [LSR_3-Vlanif200] quit
    

  5. 创建从LSR_1到LSR_3的静态LSP

    # 配置Ingress LSR_1。

    [LSR_1] static-lsp ingress LSP1 destination 3.3.3.9 32 nexthop 172.1.1.2 out-label 20

    # 配置Transit LSR_2。

    [LSR_2] static-lsp transit LSP1 incoming-interface vlanif 100 in-label 20 nexthop 172.2.1.2 out-label 40

    # 配置Egress LSR_3。

    [LSR_3] static-lsp egress LSP1 incoming-interface vlanif 200 in-label 40

    配置完成后,可在各节点上用display mpls static-lsp命令查看静态LSP的状态。LSR_1显示为例:

    [LSR_1] display mpls static-lsp
    TOTAL          : 1       STATIC LSP(S)
    UP             : 1       STATIC LSP(S)
    DOWN           : 0       STATIC LSP(S)
    Name            FEC                 I/O Label  I/O If                   Status
    LSP1            3.3.3.9/32          NULL/20    -/Vlanif100              Up  

    LSP是单向的,需要再配置LSR_3到LSR_1的静态LSP。

  6. 创建从LSR_3到LSR_1静态LSP

    # 配置Ingress LSR_3。

    [LSR_3] static-lsp ingress LSP2 destination 1.1.1.9 32 nexthop 172.2.1.1 out-label 30

    # 配置Transit LSR_2。

    [LSR_2] static-lsp transit LSP2 incoming-interface vlanif 200 in-label 30 nexthop 172.1.1.1 out-label 60

    # 配置Egress LSR_1。

    [LSR_1] static-lsp egress LSP2 incoming-interface vlanif 100 in-label 60

  7. 检查配置结果

    配置完成后,在各节点上用display mpls static-lspdisplay mpls static-lsp verbose命令查看静态LSP的状态及其详细信息。以LSR_3的显示为例:

    [LSR_3] display mpls static-lsp
    TOTAL          : 2       STATIC LSP(S)
    UP             : 2       STATIC LSP(S)
    DOWN           : 0       STATIC LSP(S)
    Name            FEC                 I/O Label  I/O If                      Status
    LSP1            -/-                 40/NULL    Vlanif200/-                 Up
    LSP2            1.1.1.9/32          NULL/30    -/Vlanif200                 Up 
    
    [LSR_3] display mpls static-lsp verbose
    No             : 1
    LSP-Name       : LSP1
    LSR-Type       : Egress
    FEC            : -/-
    In-Label       : 40
    Out-Label      : NULL
    In-Interface   : Vlanif200
    Out-Interface  : -
    NextHop        : -
    Static-Lsp Type: Normal
    Lsp Status     : Up
    
    No             : 2
    LSP-Name       : LSP2
    LSR-Type       : Ingress
    FEC            : 1.1.1.9/32
    In-Label       : NULL
    Out-Label      : 30
    In-Interface   : -
    Out-Interface  : Vlanif200
    NextHop        : 172.2.1.1
    Static-Lsp Type: Normal
    Lsp Status     : Up
    

    在LSR_3执行命令ping lsp ip 1.1.1.9 32,可以ping通。

    在LSR_1执行命令ping lsp ip 3.3.3.9 32,也可以ping通。

配置文件

  • LSR_1的配置文件

    #
    sysname LSR_1
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 100 
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    static-lsp ingress LSP1 destination 3.3.3.9 32 nexthop 172.1.1.2 out-label 20 
    static-lsp egress LSP2 incoming-interface Vlanif100 in-label 60
    #
    return
  • LSR_2的配置文件

    #
    sysname LSR_2
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 100 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 200 
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
    #
    static-lsp transit LSP1 incoming-interface Vlanif100 in-label 20 nexthop 172.2.1.2 out-label 40 
    static-lsp transit LSP2 incoming-interface Vlanif200 in-label 30 nexthop 172.1.1.1 out-label 60
    #
    return
  • LSR_3的配置文件

    #
    sysname LSR_3
    #
    vlan batch 200
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 200 
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
    #
    static-lsp egress LSP1 incoming-interface Vlanif200 in-label 40
    static-lsp ingress LSP2 destination 1.1.1.9 32 nexthop 172.2.1.1 out-label 30
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8121

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页