所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置动态BFD检测MPLS TE隧道保护组示例

配置动态BFD检测MPLS TE隧道保护组示例

组网需求

图5-52中,LSRA与LSRC之间建立了两条MPLS TE隧道。现要求为主隧道配置MPLS TE隧道保护组,采用动态BFD机制来检测CR-LSP故障。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图5-52  配置动态BFD检测MPLS TE隧道保护组组网图

配置思路

采用如下思路配置动态BFD检测MPLS TE隧道保护组:
  1. 配置MPLS TE隧道保护组。
  2. 在主隧道入节点的Tunnel接口下使能自动创建BFD会话功能,并在出节点MPLS视图使能被动创建BFD会话功能。

操作步骤

  1. 配置MPLS TE隧道保护组

    配置MPLS TE隧道保护组示例配置MPLS TE隧道保护组。

  2. 配置动态BFD检测MPLS TE隧道保护组

    # 配置LSRA。

    [LSRA] bfd
    [LSRA-bfd] quit
    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] mpls te bfd enable
    [LSRA-Tunnel1] mpls te bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 3
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit
    

    # 配置LSRC。

    [LSRC] bfd
    [LSRC-bfd] mpls-passive
    [LSRC-bfd] quit
    

  3. 检查配置结果

    完成上述配置之后,可以在LSRA上执行命令display mpls te protection tunnel 100 verbose,可查看隧道保护组的详细信息。

    [LSRA] display mpls te protection tunnel 100 verbose
    ----------------------------------------------------------------                
    Verbose information about the No.1 protection-group                             
    ----------------------------------------------------------------                
    Work-tunnel id                           : 100                                  
    Protect-tunnel id                        : 101                                  
    Work-tunnel name                         : Tunnel1                              
    Protect-tunnel name                      : Tunnel2                              
    Work-tunnel reverse-lsp                  : -                                    
    Protect-tunnel reverse-lsp               : -                                    
    Bridge type                              : 1:1                                  
    Switch type                              : unidirectional                       
    Switch result                            : work-tunnel                          
    Tunnel using Best-Effort                 : none                                 
    Tunnel using Ordinary                    : none                                 
    Work-tunnel frr in use                   : none                                 
    Work-tunnel defect state                 : non-defect                           
    Protect-tunnel defect state              : non-defect                           
    Work-tunnel forward-lsp defect state     : non-defect                           
    Protect-tunnel forward-lsp defect state  : non-defect                           
    Work-tunnel reverse-lsp defect state     : non-defect                           
    Protect-tunnel reverse-lsp defect state  : non-defect                           
    HoldOff config time                      : 0ms                                  
    HoldOff remain time                      : -                                    
    WTR config time                          : 120s                                 
    WTR remain time                          : -                                    
    Mode                                     : revertive                            
    Using same path                          : -                                    
    Local state                              : no request                           
    Far end request                          : no request                           

    在LSRA上执行命令tracert lsp te tunnel 1,查看流量经过主隧道的路径信息。

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to br
    eak.                                                                            
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.1.1.2/[4101 ]                  
      1     172.1.1.2          7 ms    Transit   172.2.1.2/[3 ]                     
      2     3.3.3.9            3 ms    Egress                                       

    在LSRA上执行命令display mpls te protection tunnel all,查看隧道保护组信息。

    [LSRA] display mpls te protection tunnel all
    ------------------------------------------------------------------------        
    No. Work-tunnel status  /id  Protect-tunnel status /id    Switch-Result         
    ------------------------------------------------------------------------        
    1          non-defect   /100        non-defect     /101     work-tunnel         
    

    在LSRA上执行命令display bfd session all,可以看到BFD会话的状态为UP。

    [LSRA] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type         InterfaceName           
    --------------------------------------------------------------------------------
    8252  8245       3.3.3.9         Up        D_TE_LSP     Tunnel1                 
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0 

    # 在LSRA的GE1/0/0接口下执行命令shutdown,模拟主隧道故障。

    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] shutdown
    [LSRA-GigabitEthernet1/0/0] quit
    

    此时在LSRA上再次执行命令tracert lsp te tunnel 1,可以看到流量切换到保护隧道。

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to br
    eak.                                                                            
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.4.1.2/[1028 ]                  
      1     172.4.1.2          4 ms    Transit   172.5.1.2/[3 ]                     
      2     3.3.3.9            3 ms    Egress

    在LSRA上执行命令display mpls te protection tunnel all,查看隧道保护组信息。

    [LSRA] display mpls te protection tunnel all
    ------------------------------------------------------------------------        
    No. Work-tunnel status  /id  Protect-tunnel status /id    Switch-Result         
    ------------------------------------------------------------------------        
    1           in defect   /100        non-defect     /101  protect-tunnel         

配置文件

  • LSRA的配置文件

    #
     sysname LSRA
    #
    vlan batch 100 400
    #
    bfd
    #
    mpls lsr-id 1.1.1.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te                                                                   
     mpls te cspf 
    #
    explicit-path backup-path                                                       
     next hop 172.4.1.2                                                             
     next hop 172.5.1.2                                                             
     next hop 3.3.3.9
    #
    explicit-path pri-path                                                          
     next hop 172.1.1.2                                                             
     next hop 172.2.1.2                                                             
     next hop 3.3.3.9 
    #    
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #    
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 3.3.3.9                                                            
     mpls te tunnel-id 100                                                          
     mpls te protection tunnel 101 mode revertive wtr 4                             
     mpls te bfd enable                                                             
     mpls te bfd min-tx-interval 100 min-rx-interval 100
     mpls te path explicit-path pri-path                                            
     mpls te commit
    #
    interface Tunnel2                                                               
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 3.3.3.9                                                            
     mpls te tunnel-id 101                                                          
     mpls te path explicit-path backup-path                                         
     mpls te commit 
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRB的配置文件

    #
     sysname LSRB
    #
    vlan batch 100 200
    # 
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
     sysname LSRC
    #
    vlan batch 200 500
    #
    bfd                                                                             
     mpls-passive                                                                   
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
  • LSRE的配置文件

    #
     sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls te srlg 2
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0                                                       
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8040

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页