所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RSVP认证示例

配置RSVP认证示例

组网需求

图5-42,LSRA和LSRB之间的VLANIF100的成员接口为GE1/0/0和GE2/0/0。使用RSVP建立了一条从LSRA到LSRC的MPLS TE隧道。

要求配置Handshake功能使LSRA和LSRB之间互相进行RSVP密钥认证,防止伪造的RSVP资源预留请求非法占用网络资源,并配置message window功能解决RSVP报文失序问题。

图5-42  配置RSVP认证组网图

配置思路

采用如下的思路配置RSVP认证:

  1. 配置各节点接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS、MPLS TE、MPLS RSVP-TE功能。

  3. 在入节点创建隧道接口,指定隧道的IP地址、隧道协议、目的地址、隧道ID、动态信令协议RSVP-TE,使能CSPF。

  4. 在LSRA和LSRB上配置RSVP消息认证功能。

  5. 在LSRA和LSRB上配置Handshake功能,防止伪造的RSVP资源预留请求非法占用网络资源。

  6. 在LSRA和LSRB上配置message window功能解决RSVP报文失序问题。

说明:

建议将滑动窗口大小配置为大于32。如果滑动窗口设置过小,收到的RSVP消息有些可能不在窗口范围内而被丢弃,这样会导致RSVP邻居关系终止。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF

    # 配置LSRA。按图5-42配置各设备的接口IP地址,其中LSRB和LSRC的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type trunk
    [LSRA-GigabitEthernet2/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet2/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    配置完成后,在各节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。

  2. 配置MPLS基本能力,使能MPLS TE、MPLS RSVP-TE和CSPF

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。其中,只需在主隧道的入节点上使能CSPF。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    

  3. 配置OSPF TE

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [LSRA] ospf
    [LSRA-ospf-1] opaque-capability enable
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  4. 在入节点创建MPLS TE Tunnel

    # 在LSRA上创建Tunnel1

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 3.3.3.9
    [LSRA-Tunnel1] mpls te tunnel-id 101
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    配置完成后,在LSRA上执行display interface tunnel命令可以看到隧道接口状态为Up。

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-02-22 14:28:37                                
    Description:...

  5. 在LSRA、LSRB的MPLS TE链路的接口上配置RSVP验证

    # 配置LSRA。

    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls rsvp-te authentication cipher Huawei@1234
    [LSRA-Vlanif100] mpls rsvp-te authentication handshake
    [LSRA-Vlanif100] mpls rsvp-te authentication window-size 32
    [LSRA-Vlanif100] quit

    # 配置LSRB。

    [LSRB] interface vlanif 100
    [LSRB-Vlanif100] mpls rsvp-te authentication cipher Huawei@1234
    [LSRB-Vlanif100] mpls rsvp-te authentication handshake
    [LSRB-Vlanif100] mpls rsvp-te authentication window-size 32
    [LSRB-Vlanif100] quit

  6. 验证配置结果

    在LSRA上执行reset mpls rsvp-te,再执行display interface tunnel命令可以看到隧道接口状态为Up。

    在LSRA或LSRB上执行display mpls rsvp-te interface命令,可查看RSVP认证的相关配置信息。

    [LSRA] display mpls rsvp-te interface vlanif 100
    Interface: Vlanif100                                                           
     Interface Address: 172.1.1.1                                                   
     Interface state: UP                   Interface Index: 0x36                    
     Total-BW: 0                           Used-BW: 0                               
     Hello configured: NO                  Num of Neighbors: 1                      
     SRefresh feature: DISABLE             SRefresh Interval: 30 sec                
     Mpls Mtu: 1500                        Retransmit Interval: 5000 msec           
     Increment Value: 1                    Authentication: ENABLE                   
     Challenge: ENABLE                     WindowSize: 32                           
     Next Seq # to be sent:2767789282 0    Key ID: 0xa4ff1cdc0000                   
     Bfd Enabled: DISABLE                  Bfd Min-Tx: 1000                         
     Bfd Min-Rx: 1000                      Bfd Detect-Multi: 3                      

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te                                                                   
     mpls te cspf 
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te authentication cipher %^%#P>Z{S["[&0D+~^McJ#GX~ij}D%N|y;w4*D;M!WJE%^%#
     mpls rsvp-te authentication handshake
     mpls rsvp-te authentication window-size 32
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1                                                           
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 3.3.3.9                                                            
     mpls te tunnel-id 101                                                          
     mpls te commit                                                                 
    #                                                                               
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      mpls-te enable 
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te                                                                   
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te authentication cipher %^%#DbqR!4[#1)#D0,Gv*|(<^`B>1},"k2[QT}T)*C5+%^%#
     mpls rsvp-te authentication handshake
     mpls rsvp-te authentication window-size 32
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #                                                                               
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      mpls-te enable 
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te 
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8842

下载量:344

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页