所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置动态MPLS TE隧道示例

配置动态MPLS TE隧道示例

组网需求

图5-36所示,某企业自建MPLS骨干网,LSRA、LSRB、LSRC均属于MPLS骨干网设备。MPLS骨干网的路由协议使用IS-IS,都属于Level-2。现要求在MPLS骨干网创建公网隧道承载L2VPN或L3VPN业务,同时要求该隧道适应网络拓扑变化保证数据传输的稳定性。

为了实现该需求,需要使用RSVP-TE信令建立一条动态MPLS TE隧道。

图5-36  配置动态MPLS TE隧道组网图

配置思路

采用如下的思路配置动态MPLS TE隧道:

  1. 在MPLS骨干网可以使用MPLS LDP和MPLS TE隧道承载L2VPN或L3VPN业务。由于企业网络拓扑经常发生变动,为了保证数据传输的稳定性,这里采用MPLS TE隧道。

  2. 配置IS-IS路由协议,实现MPLS骨干网设备路由可达。

  3. 使能各节点MPLS TE和RSVP-TE功能,以便建立MPLS TE隧道。

  4. 使能IS-IS TE,改变cost类型,使得TE信息可以通过IS-IS发布到其他节点。

  5. 在入节点创建隧道接口,配置隧道属性,使能MPLS TE CSPF,创建动态MPLS TE隧道。

操作步骤

  1. 配置各接口的IP地址

    # 配置LSRA。按图5-36配置各设备的接口IP地址并配置OSPF,其中LSRB和LSRC的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    

  2. 配置IS-IS协议发布路由

    # 配置LSRA。

    [LSRA] isis 1
    [LSRA-isis-1] network-entity 00.0005.0000.0000.0001.00
    [LSRA-isis-1] is-level level-2
    [LSRA-isis-1] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] isis enable 1
    [LSRA-Vlanif100] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] isis enable 1
    [LSRA-LoopBack1] quit

    # 配置LSRB。

    [LSRB] isis 1
    [LSRB-isis-1] network-entity 00.0005.0000.0000.0002.00
    [LSRB-isis-1] is-level level-2
    [LSRB-isis-1] quit
    [LSRB] interface vlanif 100
    [LSRB-Vlanif100] isis enable 1
    [LSRB-Vlanif100] quit
    [LSRB] interface vlanif 200
    [LSRB-Vlanif200] isis enable 1
    [LSRB-Vlanif200] quit
    [LSRB] interface loopback 1
    [LSRB-LoopBack1] isis enable 1
    [LSRB-LoopBack1] quit

    # 配置LSRC。

    [LSRC] isis 1
    [LSRC-isis-1] network-entity 00.0005.0000.0000.0003.00
    [LSRC-isis-1] is-level level-2
    [LSRC-isis-1] quit
    [LSRC] interface vlanif 200
    [LSRC-Vlanif200] isis enable 1
    [LSRC-Vlanif200] quit
    [LSRC] interface loopback 1
    [LSRC-LoopBack1] isis enable 1
    [LSRC-LoopBack1] quit

    配置完成后,在各节点上执行display ip routing-table命令,可以看到相互之间都学到了到对方的路由。以LSRA的显示为例:

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 8        Routes : 8                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  ISIS-L2 15   10          D   172.1.1.2       Vlanif100
            3.3.3.9/32  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
    

  3. 配置MPLS基本能力,使能MPLS TE、RSVP-TE

    在各节点全局使能MPLS、MPLS TE和RSVP-TE,在隧道沿途的接口上使能MPLS、MPLS TE和RSVP-TE。

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit

  4. 配置IS-IS TE

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [LSRA] isis 1
    [LSRA-isis-1] cost-style wide
    [LSRA-isis-1] traffic-eng level-2
    [LSRA-isis-1] quit

  5. 配置MPLS TE隧道接口,使能MPLS TE CSPF

    在隧道入节点上创建Tunnel接口,并配置Tunnel接口的IP地址、隧道协议、目的地址、Tunnel ID、动态信令协议,并执行mpls te commit命令使配置生效。

    # 配置LSRA。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 3.3.3.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te signal-protocol rsvp-te
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit
    [LSRA] mpls
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit

  6. 检查配置结果

    配置完成后,在LSRA上执行display interface tunnel命令可以看到隧道接口状态为Up。

    [LSRA] display interface tunnel
    Tunnel1 current state : UP
    Line protocol current state : UP
    Last line protocol up time : 2013-01-14 09:18:46
    Description:
    ...

    在LSRA上执行display mpls te tunnel-interface命令可以看到隧道接口信息。

    [LSRA] display mpls te tunnel-interface
        ----------------------------------------------------------------            
                                   Tunnel1                                      
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Primary LSP                                          
        Session ID          :  100                                                  
        Ingress LSR ID      :  1.1.1.9          Egress LSR ID:  3.3.3.9             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 3                    

    在LSRA上执行display mpls te tunnel verbose命令可以看到隧道详细信息。

    [LSRA] display mpls te tunnel verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                      
        Tunnel Interface Name   :  Tunnel1                                      
        TunnelIndex             :  1           LSP Index         :  2048            
        Session ID              :  100         LSP ID            :  3               
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif100                                          
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  -                                                
        ER-Hop Table Index      :  -           AR-Hop Table Index:  -               
        C-Hop Table Index       :  -                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  16388                                            
        Created Time            :  2013-09-16 11:51:21+00:00                      
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    

    在LSRA上执行display mpls te cspf tedb all命令查看TEDB中的链路信息。

    [LSRA] display mpls te cspf tedb all
    Maximum Nodes Supported: 1024    Current Total Node Number: 3                    
    Maximum Links Supported: 2048   Current Total Link Number: 4                    
    Maximum SRLGs supported: 5120   Current Total SRLG Number: 0                    
    ID     Router-ID        IGP      Process-ID     Area            Link-Count      
    1      1.1.1.9          ISIS     1              Level-2         1               
    2      2.2.2.9          ISIS     1              Level-2         2               
    3      3.3.3.9          ISIS     1              Level-2         1               

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0001.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 100
     mpls te commit
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0002.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0003.00
     traffic-eng level-2
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8034

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页