所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置静态MPLS TE隧道示例

配置静态MPLS TE隧道示例

组网需求

图5-35所示,要求分别建立一条LSRA到LSRC和一条从LSRC到LSRA的静态TE隧道。

图5-35  配置静态MPLS TE隧道组网图

配置思路

采用如下的思路配置静态MPLS TE隧道:

  1. 配置各节点接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。

  2. 配置LSR ID并全局使能各节点以及接口的MPLS、MPLS TE功能。

  3. 在入节点创建隧道接口,指定使用静态CR-LSP建立MPLS TE隧道。

  4. 配置与隧道相关联的静态CR-LSP,在入节点上配置下一跳地址和出标签,在中间节点配置入接口、入标签、下一跳地址和出标签,在出节点上配置入标签和入接口。

说明:
  • 每个节点出标签的值就是其下一个节点入标签的值。

  • 执行命令static-cr-lsp ingress { tunnel-interface tunnel interface-number | tunnel-name } destination destination-address { nexthop next-hop-address | outgoing-interface interface-type interface-number } * out-label out-label配置CR-LSP入节点时需注意,参数tunnel-name必须与命令interface tunnel interface-number创建的隧道接口名称一致,且区分大小写,不支持空格。假设使用命令interface tunnel 1创建了一个的Tunnel接口,则隧道接口名称为Tunnel1,其静态CR-LSP入节点中的参数应该写作“Tunnel1”,否则隧道将不能正确建立。中间节点和出节点无此限制。

操作步骤

  1. 配置各接口的IP地址及路由协议

    # 配置LSRA。按图5-35配置各设备的接口IP地址并配置OSPF,其中LSRB和LSRC的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    完成此步骤后,LSRA、LSRB、LSRC之间应能建立OSPF邻居关系,执行display ospf peer命令可以看到邻居状态为Full。执行display ip routing-table命令可以看到LSR之间学习到对方的Loopback1路由。

  2. 配置MPLS基本能力,使能MPLS TE

    # 配置LSRA。LSRB和LSRC的配置与LSRA类似,不再赘述。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] quit

  3. 配置MPLS TE隧道接口

    # 在LSRA上配置MPLS TE隧道接口。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 3.3.3.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te signal-protocol cr-static
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    # 在LSRC上配置MPLS TE隧道。

    [LSRC] interface tunnel 1
    [LSRC-Tunnel1] ip address unnumbered interface loopback 1
    [LSRC-Tunnel1] tunnel-protocol mpls te
    [LSRC-Tunnel1] destination 1.1.1.9
    [LSRC-Tunnel1] mpls te tunnel-id 200
    [LSRC-Tunnel1] mpls te signal-protocol cr-static
    [LSRC-Tunnel1] mpls te commit
    [LSRC-Tunnel1] quit

  4. 创建LSRA至LSRC的静态CR-LSP

    # 配置LSRA为静态CR-LSP的入节点。

    [LSRA] static-cr-lsp ingress tunnel-interface Tunnel1 destination 3.3.3.9 nexthop 172.1.1.2 out-label 20

    # 配置LSRB为静态CR-LSP的中间节点。

    [LSRB] static-cr-lsp transit LSRA2LSRC incoming-interface vlanif 100 in-label 20 nexthop 172.2.1.2 out-label 30

    # 配置LSRC为静态CR-LSP的出节点。

    [LSRC] static-cr-lsp egress LSRA2LSRC incoming-interface vlanif 200 in-label 30

  5. 创建LSRC至LSRA的静态CR-LSP

    # 配置LSRC为静态CR-LSP的入节点。

    [LSRC] static-cr-lsp ingress tunnel-interface Tunnel1 destination 1.1.1.9 nexthop 172.2.1.1 out-label 120

    # 配置LSRB为静态CR-LSP的中间节点。

    [LSRB] static-cr-lsp transit LSRC2LSRA incoming-interface vlanif 200 in-label 120 nexthop 172.1.1.1 out-label 130

    # 配置LSRA为静态CR-LSP的出节点。

    [LSRA] static-cr-lsp egress LSRC2LSRA incoming-interface vlanif 100 in-label 130

  6. 检查配置结果

    配置完成后,在LSRA上执行display interface tunnel命令,可以看到Tunnel接口的状态为Up。

    以LSRA为例:

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                 
    Line protocol current state : UP                                              
    ...

    在各节点上执行display mpls te tunnel命令,可以看到MPLS TE隧道的建立情况。

    以LSRA为例:

    [LSRA] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name
    ------------------------------------------------------------------------------
    1.1.1.9          3.3.3.9          1       --/20            I  Tunnel1
    -                -                -       130/--           E  LSRC2LSRA
    

    在各节点上执行display mpls lspdisplay mpls static-cr-lsp命令,可以看到静态CR-LSP的建立情况。

    以LSRA为例:

    [LSRA] display mpls static-cr-lsp
    TOTAL          : 2     STATIC CRLSP(S)
    UP             : 2     STATIC CRLSP(S)
    DOWN           : 0     STATIC CRLSP(S)
    Name                FEC                I/O Label    I/O If                Status
    Tunnel1             3.3.3.9/32         NULL/20      -/Vlanif100           Up
    LSRC2LSRA           -/-                130/NULL     Vlanif100/-           Up

    建立静态MPLS TE隧道时,Transit节点和Egress节点直接根据配置的入标签和出标签进行转发,因此LSRB和LSRC的相关显示信息中,FEC等内容为空。

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te signal-protocol cr-static
     mpls te tunnel-id 100
     mpls te commit
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    static-cr-lsp ingress tunnel-interface Tunnel1 destination 3.3.3.9 nexthop 172.1.1.2 out-label 20 bandwidth ct0 0
    static-cr-lsp egress LSRC2LSRA incoming-interface Vlanif100 in-label 130
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
    #
    static-cr-lsp transit LSRA2LSRC incoming-interface Vlanif100 in-label 20 nexthop 172.2.1.2 out-label 30 bandwidth ct0 0
    static-cr-lsp transit LSRC2LSRA incoming-interface Vlanif200 in-label 120 nexthop 172.1.1.1 out-label 130 bandwidth ct0 0
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.9
     mpls te signal-protocol cr-static
     mpls te tunnel-id 200
     mpls te commit
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
    #
    static-cr-lsp egress LSRA2LSRC incoming-interface Vlanif200 in-label 30
    static-cr-lsp ingress tunnel-interface Tunnel1 destination 1.1.1.9 nexthop 172.2.1.1 out-label 120 bandwidth ct0 0
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8015

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页