所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Auto LDP FRR示例

配置Auto LDP FRR示例

组网需求

图3-24所示,网络结构拓扑复杂并且不稳定,LSRA、LSRB、LSRC、LSRD为MPLS骨干网设备。LSRA到LSRC之间建立LSP承载网络业务,其中LSRA->LSRC为主用LSP,LSRA->LSRB->LSRC为备份LSP。当主用LSP发生故障时,流量切换到备份LSP,造成MPLS流量丢失。对于实时性要求高的网络业务(例如VoIP,在线游戏,在线视频业务等),用户无法容忍业务的短时间中断,要求在主用LSP发生故障的时候,流量能够快速切换到备份LSP,尽可能避免流量的丢失。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图3-24  配置Auto LDP FRR组网

配置思路

配置Auto LDP FRR,可以实现此需求。采用如下配置思路:

  1. 在LSR上配置IS-IS,实现骨干网的IP连通性。
  2. 在LSR上配置本地LDP会话,实现创建LDP LSP承载网络业务。
  3. 在LSRA、LSRC上配置动态BFD检测LDP LDP,实现快速检测LSP故障。
  4. 由于网络结构拓扑复杂并且不稳定,因此配置Auto LDP FRR,实现主备切换时尽可能地避免流量丢失。

操作步骤

  1. 交换机上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置LSRA。LSRB、LSRC和LSRD的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] interface loopback 0
    [LSRA-LoopBack0] ip address 1.1.1.9 32
    [LSRA-LoopBack0] quit
    [LSRA] vlan batch 10 20
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] ip address 10.1.1.1 24
    [LSRA-Vlanif10] quit
    [LSRA] interface vlanif 20
    [LSRA-Vlanif20] ip address 10.1.2.1 24
    [LSRA-Vlanif20] quit
    [LSRA] interface gigabitethernet 1/0/1
    [LSRA-GigabitEthernet1/0/1] port link-type trunk
    [LSRA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [LSRA-GigabitEthernet1/0/1] quit
    [LSRA] interface gigabitethernet 2/0/2
    [LSRA-GigabitEthernet2/0/2] port link-type trunk
    [LSRA-GigabitEthernet2/0/2] port trunk allow-pass vlan 20
    [LSRA-GigabitEthernet2/0/2] quit

  2. 配置IS-IS协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置LSRA。

    [LSRA] isis 1
    [LSRA-isis-1] network-entity 10.0000.0000.0001.00
    [LSRA-isis-1] quit
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] isis enable 1
    [LSRA-Vlanif10] quit
    [LSRA] interface vlanif 20
    [LSRA-Vlanif20] isis enable 1
    [LSRA-Vlanif20] quit
    [LSRA] interface loopback 0
    [LSRA-LoopBack0] isis enable 1
    [LSRA-LoopBack0] quit

    # 配置LSRB。

    [LSRB] isis 1
    [LSRB-isis-1] network-entity 10.0000.0000.0002.00
    [LSRB-isis-1] quit
    [LSRB] interface vlanif 10
    [LSRB-Vlanif10] isis enable 1
    [LSRB-Vlanif10] quit
    [LSRB] interface vlanif 40
    [LSRB-Vlanif40] isis enable 1
    [LSRB-Vlanif40] quit
    [LSRB] interface loopback 0
    [LSRB-LoopBack0] isis enable 1
    [LSRB-LoopBack0] quit

    # 配置LSRC。

    [LSRC] isis 1
    [LSRC-isis-1] network-entity 10.0000.0000.0003.00
    [LSRC-isis-1] quit
    [LSRC] interface vlanif 30
    [LSRC-Vlanif30] isis enable 1
    [LSRC-Vlanif30] quit
    [LSRC] interface vlanif 20
    [LSRC-Vlanif20] isis enable 1
    [LSRC-Vlanif20] quit
    [LSRC] interface vlanif 40
    [LSRC-Vlanif40] isis enable 1
    [LSRC-Vlanif40] quit
    [LSRC] interface loopback 0
    [LSRC-LoopBack0] isis enable 1
    [LSRC-LoopBack0] quit

    # 配置LSRD。

    [LSRD] isis 1
    [LSRD-isis-1] network-entity 10.0000.0000.0004.00
    [LSRD-isis-1] quit
    [LSRD] interface vlanif 30
    [LSRD-Vlanif30] isis enable 1
    [LSRD-Vlanif30] quit
    [LSRD] interface loopback 0
    [LSRD-LoopBack0] isis enable 1
    [LSRD-LoopBack0] quit

  3. 配置各节点全局和接口的MPLS和MPLS LDP能力,使网络能够转发MPLS流量,并查看LSP建立情况

    # 配置LSRA。LSRB、LSRC和LSRD的配置与LSRA类似,不再赘述。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] quit
    [LSRA] mpls ldp
    [LSRA-mpls-ldp] quit
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] mpls
    [LSRA-Vlanif10] mpls ldp
    [LSRA-Vlanif10] quit
    [LSRA] interface vlanif 20
    [LSRA-Vlanif20] mpls
    [LSRA-Vlanif20] mpls ldp
    [LSRA-Vlanif20] quit

    # 配置完成后,在LSRA上执行display mpls lsp命令,查看已经建立的LSP。

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         3/NULL        -/- 
    2.2.2.9/32         NULL/3        -/Vlanif10
    2.2.2.9/32         1024/3        -/Vlanif10
    3.3.3.9/32         NULL/3        -/Vlanif20
    3.3.3.9/32         1025/3        -/Vlanif20
    4.4.4.9/32         NULL/1026     -/Vlanif20
    4.4.4.9/32         1026/1026     -/Vlanif20
    

    从显示信息可以看到,缺省情况下,32位的主机路由触发LDP建立了LSP。

  4. 配置动态BFD会话检测LSRA和LSRC之间的LDP LSP

    # 在LSRA配置FEC列表,这样就可以保障只触发BFD检测LSRA和LSRC之间的LDP LSP。

    [LSRA] fec-list tortc
    [LSRA-fec-list-tortc] fec-node 3.3.3.9
    [LSRA-fec-list-tortc] quit

    # 在LSRA使能BFD,指定动态触发BFD会话的FEC列表,并调整BFD检测参数。

    [LSRA] bfd
    [LSRA-bfd] quit
    [LSRA] mpls
    [LSRA-mpls] mpls bfd-trigger fec-list tortc
    [LSRA-mpls] mpls bfd enable
    [LSRA-mpls] mpls bfd min-tx-interval 100 min-rx-interval 100 
    [LSRA-mpls] quit
    

    # 在LSRC上配置被动使能BFD for LSP能力。

    [LSRC] bfd
    [LSRC-bfd] mpls-passive
    [LSRC-bfd] quit

    完成上述配置后,查看LSRA上创建的BFD会话状态,可以看到“State”字段的值为“Up”。

  5. 在LSRA上使能IS-IS Auto FRR,并查看路由信息,以及备份LSP的建立情况

    # 在LSRA上使能IS-IS Auto FRR。

    [LSRA] isis
    [LSRA-isis-1] frr
    [LSRA-isis-1-frr] loop-free-alternate
    [LSRA-isis-1-frr] quit
    [LSRA-isis-1] quit

    # 查看LSRA到LSRC和LSRD之间直连链路的路由信息。

    [LSRA] display ip routing-table 10.1.4.0 verbose
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table : Public
    Summary Count : 1
    
    Destination: 10.1.4.0/24
         Protocol: ISIS-L1         Process ID: 1
       Preference: 15                    Cost: 20
          NextHop: 10.1.2.2         Neighbour: 0.0.0.0
            State: Active Adv             Age: 00h05m38s
              Tag: 0                 Priority: medium
            Label: NULL               QoSInfo: 0x0
       IndirectID: 0x0
     RelayNextHop: 0.0.0.0          Interface: Vlanif20
         TunnelID: 0x0                  Flags: D
        BkNextHop: 10.1.1.2       BkInterface: Vlanif10
          BkLabel: NULL           SecTunnelID: 0x0
     BkPETunnelID: 0x0        BkPESecTunnelID: 0x0
     BkIndirectID: 0x0
    

    从显示信息可以看到,由于使能了IS-IS Auto FRR,IS-IS生成了一条备份路由。

    # 在LSRA上执行display mpls lsp命令,查看LSP的建立情况。

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         3/NULL        -/- 
    2.2.2.9/32         NULL/3        -/Vlanif10
       **LDP FRR**         /1025      /Vlanif20
    2.2.2.9/32         1024/3        -/Vlanif10
       **LDP FRR**         /1025      /Vlanif20
    3.3.3.9/32         NULL/3        -/Vlanif20
       **LDP FRR**         /1025      /Vlanif10
    3.3.3.9/32         1025/3        -/Vlanif20
       **LDP FRR**         /1025      /Vlanif10
    4.4.4.9/32         NULL/1026     -/Vlanif20
       **LDP FRR**         /1026      /Vlanif10
    4.4.4.9/32         1026/1026     -/Vlanif20
       **LDP FRR**         /1026      /Vlanif10
    

    从显示信息可以看到,缺省情况下,32位的备份路由触发LDP建立了备份LSP。

  6. 在LSRC上执行lsp-trigger命令,改变LSP触发策略,所有路由触发LDP建立LSP,并查看LSP建立情况

    # 在LSRC上执行lsp-trigger命令,改变LSP触发策略,所有路由触发LDP建立LSP。

    [LSRC] mpls
    [LSRC-mpls] lsp-trigger all
    [LSRC-mpls] quit

    # 在LSRA上执行display mpls lsp命令,查看已经建立的LSP。

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         3/NULL        -/- 
    2.2.2.9/32         NULL/3        -/Vlanif10
       **LDP FRR**         /1025      /Vlanif20
    2.2.2.9/32         1024/3        -/Vlanif10
       **LDP FRR**         /1025      /Vlanif20
    3.3.3.9/32         NULL/3        -/Vlanif20
       **LDP FRR**         /1025      /Vlanif10
    3.3.3.9/32         1025/3        -/Vlanif20
       **LDP FRR**         /1025      /Vlanif10
    4.4.4.9/32         NULL/1026     -/Vlanif20
       **LDP FRR**         /1026      /Vlanif10
    4.4.4.9/32         1026/1026     -/Vlanif20
       **LDP FRR**         /1026      /Vlanif10
    10.1.3.0/24        1027/3        -/Vlanif20
    10.1.4.0/24        1028/3        -/Vlanif20
    

    从显示信息可以看到,24位的路由触发建立了LSP。

  7. 配置备份LSP的触发策略,所有备份路由触发LDP建立备份LSP

    # 在LSRA上执行auto-frr lsp-trigger命令,为所有备份路由生成备份LSP。

    [LSRA] mpls ldp
    [LSRA-mpls-ldp] auto-frr lsp-trigger all
    [LSRA-mpls-ldp] quit

  8. 检查配置结果

    上述配置完成后,在LSRA节点上执行display mpls lsp命令,查看备份LSP的建立情况。

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         3/NULL        -/- 
    2.2.2.9/32         NULL/3        -/Vlanif10
       **LDP FRR**         /1025      /Vlanif20
    2.2.2.9/32         1024/3        -/Vlanif10
       **LDP FRR**         /1025      /Vlanif20
    3.3.3.9/32         NULL/3        -/Vlanif20
       **LDP FRR**         /1025      /Vlanif10
    3.3.3.9/32         1025/3        -/Vlanif20
       **LDP FRR**         /1025      /Vlanif10
    4.4.4.9/32         NULL/1026     -/Vlanif20
       **LDP FRR**         /1026      /Vlanif10
    4.4.4.9/32         1026/1026     -/Vlanif20
       **LDP FRR**         /1026      /Vlanif10
    10.1.3.0/24        1027/3        -/Vlanif20
    10.1.4.0/24        1028/3        -/Vlanif20
       **LDP FRR**         /1027      /Vlanif10
    

    从显示信息可以看到,24位的路由触发建立了LSP。

    将同一台测试仪的两个接口(Port1和Port2)分别接入LSRA和LSRD,从Port1向Port2打MPLS流。当对LSRA的VLANIF20接口进行shutdown操作来模拟主用LSP故障时,发现流量快速切换到备份LSP。

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 10 20
    #
    bfd
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls bfd enable
     mpls bfd-trigger fec-list tortc
     mpls bfd min-tx-interval 100 min-rx-interval 100
    #
    fec-list tortc 
     fec-node 3.3.3.9
    #
    mpls ldp
     auto-frr lsp-trigger all
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     frr
      loop-free-alternate level-1
      loop-free-alternate level-2
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 1.1.1.9 255.255.255.255
     isis enable 1
    #
    return
    
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 10 40
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.1.3.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 40 
    #
    interface LoopBack0
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #
    return
    
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 20 30 40
    #
    bfd  
     mpls-passive 
    #
    mpls lsr-id 3.3.3.9
    mpls
     lsp-trigger all
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.1.4.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.1.3.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 40 
    #
    interface GigabitEthernet2/0/3
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack0
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    return
    
  • LSRD的配置文件

    #
    sysname LSRD
    #
    vlan batch 30
    #
    mpls lsr-id 4.4.4.9
    mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif30
     ip address 10.1.4.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack0
     ip address 4.4.4.9 255.255.255.255
     isis enable 1
    #
    return
    
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8130

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页