所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置域内Seamless MPLS承载VLL业务示例

配置域内Seamless MPLS承载VLL业务示例

组网需求

图7-15所示的网络中,接入层(Access)、汇聚层(Aggregation)和核心层(Core)网络处于同一个AS内,为了实现基站(NodeB)与MME/SGW互通并提供VLL服务,用户希望将MPLS技术扩展至接入层网络,在接入层、汇聚层和核心层网络中部署一条完整的LSP,提供一种端到端的服务,从而简化端到端的业务配置和网络管理,则可以在该组网内部署域内Seamless MPLS。

图7-15  配置域内Seamless MPLS组网

配置思路

采用如下的思路配置域内Seamless MPLS承载VLL业务:

  1. 在各个网络层内配置IGP协议,实现各自网络层内互通。

  2. 在各个设备上配置MPLS基本能力和MPLS LDP,建立MPLS LSP。

  3. 在各个网络层内建立IBGP邻居,并使能标签路由交换能力。

  4. 将AGG、Core_ABR设备配置成路由反射器,通过路由反射使CSG和MASG获得对方的Loopback路由。

  5. 在各个设备上配置路由策略建立BGP LSP:在BGP LSP的起始节点上,需要为向下游发布的路由分配MPLS标签;在BGP LSP的中间节点上,如果从上游收到带标签的IPv4路由,则需要为其重新分配MPLS标签,然后向下游发布。

  6. 在CSG和MASG上使能MPLS L2VPN,并创建Martini连接。

操作步骤

  1. 在设备上创建VLAN、VLANIF接口,配置VLANIF接口的IP地址,并将相应的物理接口加入到VLAN

    # 配置CSG。CE1、CE2、AGG、Core_ABR和MASG的配置与CSG类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname CSG
    [CSG] interface loopback 1
    [CSG-LoopBack1] ip address 1.1.1.9 32
    [CSG-LoopBack1] quit
    [CSG] vlan batch 10 100
    [CSG] interface vlanif 100
    [CSG-Vlanif100] ip address 172.1.1.1 24
    [CSG-Vlanif100] quit
    [CSG] interface gigabitethernet 1/0/1
    [CSG-GigabitEthernet1/0/1] port link-type trunk
    [CSG-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [CSG-GigabitEthernet1/0/1] quit
    [CSG] interface gigabitethernet 2/0/2
    [CSG-GigabitEthernet2/0/2] port link-type trunk
    [CSG-GigabitEthernet2/0/2] port trunk allow-pass vlan 10
    [CSG-GigabitEthernet2/0/2] quit
    

  2. 配置OSPF或IS-IS协议发布各节点接口所连网段和LSR ID的主机路由

    # 配置CSG。

    [CSG] ospf 1
    [CSG-ospf-1] area 0
    [CSG-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [CSG-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [CSG-ospf-1-area-0.0.0.0] quit
    [CSG-ospf-1] quit

    # 配置AGG。

    [AGG] ospf 1
    [AGG-ospf-1] area 0
    [AGG-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [AGG-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [AGG-ospf-1-area-0.0.0.0] quit
    [AGG-ospf-1] quit
    [AGG] isis 1
    [AGG-isis-1] network-entity 10.0000.0000.0000.0010.00
    [AGG-isis-1] quit
    [AGG] interface vlanif 200
    [AGG-Vlanif200] isis enable 1
    [AGG-Vlanif200] quit
    [AGG] interface loopback 1
    [AGG-LoopBack1] isis enable 1
    [AGG-LoopBack1] quit

    # 配置Core_ABR。

    [Core_ABR] ospf 2
    [Core_ABR-ospf-2] area 0
    [Core_ABR-ospf-2-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [Core_ABR-ospf-2-area-0.0.0.0] network 172.3.1.0 0.0.0.255
    [Core_ABR-ospf-2-area-0.0.0.0] quit
    [Core_ABR-ospf-2] quit
    [Core_ABR] isis 1
    [Core_ABR-isis-1] network-entity 10.0000.0000.0000.0020.00
    [Core_ABR-isis-1] quit
    [Core_ABR] interface vlanif 200
    [Core_ABR-Vlanif200] isis enable 1
    [Core_ABR-Vlanif200] quit
    [Core_ABR] interface loopback 1
    [Core_ABR-LoopBack1] isis enable 1
    [Core_ABR-LoopBack1] quit

    # 配置MASG。

    [MASG] ospf 2
    [MASG-ospf-2] area 0
    [MASG-ospf-2-area-0.0.0.0] network 4.4.4.9 0.0.0.0
    [MASG-ospf-2-area-0.0.0.0] network 172.3.1.0 0.0.0.255
    [MASG-ospf-2-area-0.0.0.0] quit
    [MASG-ospf-2] quit

  3. 在各设备上配置全局的MPLS和MPLS LDP能力

    # 配置CSG。AGG、Core_ABR和MASG的配置与CSG类似,不再赘述。

    [CSG] mpls lsr-id 1.1.1.9
    [CSG] mpls
    [CSG-mpls] quit
    [CSG] mpls ldp
    [CSG-mpls-ldp] quit
    [CSG] interface vlanif 100
    [CSG-Vlanif100] mpls
    [CSG-Vlanif100] mpls ldp
    [CSG-Vlanif100] quit

  4. 在各个网络层内分别建立IBGP邻居,并使能标签路由交换能力

    # 配置CSG。

    [CSG] bgp 100
    [CSG-bgp] peer 2.2.2.9 as-number 100
    [CSG-bgp] peer 2.2.2.9 connect-interface LoopBack 1
    [CSG-bgp] peer 2.2.2.9 label-route-capability
    [CSG-bgp] network 1.1.1.9 32
    [CSG-bgp] quit

    # 配置AGG。

    [AGG] bgp 100
    [AGG-bgp] peer 1.1.1.9 as-number 100
    [AGG-bgp] peer 1.1.1.9 connect-interface LoopBack 1
    [AGG-bgp] peer 1.1.1.9 label-route-capability
    [AGG-bgp] peer 3.3.3.9 as-number 100
    [AGG-bgp] peer 3.3.3.9 connect-interface LoopBack 1
    [AGG-bgp] peer 3.3.3.9 label-route-capability
    [AGG-bgp] quit

    # 配置Core_ABR。

    [Core_ABR] bgp 100
    [Core_ABR-bgp] peer 2.2.2.9 as-number 100
    [Core_ABR-bgp] peer 2.2.2.9 connect-interface LoopBack 1
    [Core_ABR-bgp] peer 2.2.2.9 label-route-capability
    [Core_ABR-bgp] peer 4.4.4.9 as-number 100
    [Core_ABR-bgp] peer 4.4.4.9 connect-interface LoopBack 1
    [Core_ABR-bgp] peer 4.4.4.9 label-route-capability
    [Core_ABR-bgp] quit

    # 配置MASG。

    [MASG] bgp 100
    [MASG-bgp] peer 3.3.3.9 as-number 100
    [MASG-bgp] peer 3.3.3.9 connect-interface LoopBack 1
    [MASG-bgp] peer 3.3.3.9 label-route-capability
    [MASG-bgp] network 4.4.4.9 32
    [MASG-bgp] quit

  5. 将AGG、Core_ABR设备配置成路由反射器,通过路由反射使CSG和MASG获得对方的Loopback路由

    # 配置AGG。

    [AGG] bgp 100
    [AGG-bgp] peer 1.1.1.9 reflect-client
    [AGG-bgp] peer 1.1.1.9 next-hop-local
    [AGG-bgp] peer 3.3.3.9 reflect-client
    [AGG-bgp] peer 3.3.3.9 next-hop-local
    [AGG-bgp] quit

    # 配置Core_ABR。

    [Core_ABR] bgp 100
    [Core_ABR-bgp] peer 2.2.2.9 reflect-client
    [Core_ABR-bgp] peer 2.2.2.9 next-hop-local
    [Core_ABR-bgp] peer 4.4.4.9 reflect-client
    [Core_ABR-bgp] peer 4.4.4.9 next-hop-local
    [Core_ABR-bgp] quit

  6. 在各个设备上配置路由策略,建立BGP LSP

    # 在CSG上创建路由策略,并向对等体应用路由策略。MASG的配置与CSG类似,此处不再详述。

    [CSG] route-policy policy1 permit node 1
    [CSG-route-policy] apply mpls-label
    [CSG-route-policy] quit
    [CSG] bgp 100
    [CSG-bgp] peer 2.2.2.9 route-policy policy1 export
    [CSG-bgp] quit

    # 在AGG上创建路由策略,并向对等体应用路由策略。Core_ABR的配置与AGG类似,此处不再详述。

    [AGG] route-policy policy1 permit node 1
    [AGG-route-policy] if-match mpls-label
    [AGG-route-policy] apply mpls-label
    [AGG-route-policy] quit
    [AGG] bgp 100
    [AGG-bgp] peer 1.1.1.9 route-policy policy1 export
    [AGG-bgp] peer 3.3.3.9 route-policy policy1 export
    [AGG-bgp] quit

    上述配置完成后,在CSG或MASG上执行display ip routing-table命令,可以看到到达对方的Loopback地址的路由。

    以CSG的显示为例:

    [CSG] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1
            2.2.2.9/32  OSPF    10   1           D   172.1.1.2       Vlanif100
            4.4.4.9/32  IBGP    255  0          RD   2.2.2.9         Vlanif100
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
    

    在CSG或MASG上执行display mpls lsp命令,可以看到LSP的信息。

    以CSG的显示为例:

    [CSG] display mpls lsp
    -------------------------------------------------------------------------------
                     LSP Information: BGP  LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         4099/NULL     -/-
    4.4.4.9/32         NULL/4106     -/-
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.9/32         3/NULL        -/-
    2.2.2.9/32         NULL/3        -/Vlanif100 
    2.2.2.9/32         4097/3        -/Vlanif100 

  7. 在CSG和MASG上使能MPLS L2VPN,并创建Martini连接

    # 在CSG上使能MPLS L2VPN,并建立LDP远端会话。MASG的配置与CSG类似,此处不再详述。

    [CSG] mpls l2vpn
    [CSG-l2vpn] quit
    [CSG] mpls ldp remote-peer 4.4.4.9
    [CSG-mpls-ldp-remote-4.4.4.9] remote-ip 4.4.4.9
    [CSG-mpls-ldp-remote-4.4.4.9] quit

    # 在CSG上建立到MASG的Martini方式连接。MASG的配置与CSG类似,此处不再详述。

    [CSG] interface vlanif 10
    [CSG-Vlanif10] mpls l2vc 4.4.4.9 100
    [CSG-Vlanif10] quit

  8. 检查配置结果

    在CSG或MASG上查看L2VPN连接信息,可以看到建立了一条L2 VC,状态为UP。

    以CSG的显示为例:
    [CSG] display mpls l2vc interface vlanif 10
     *client interface       : Vlanif10 is up
      Administrator PW       : no
      session state          : up
      AC status              : up
      Ignore AC state        : disable
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : VLAN
      destination            : 4.4.4.9
      local group ID         : 0            remote group ID      : 0
      local VC label         : 23552        remote VC label      : 23552
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0
      remote AC OAM state    : up
      remote PSN OAM state   : up
      remote forwarding state: forwarding
      remote status code     : 0x0
      ignore standby state   : no
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 1500         remote VC MTU        : 1500
      local VCCV             : alert ttl lsp-ping bfd
      remote VCCV            : alert ttl lsp-ping bfd
      local control word     : disable      remote control word  : disable
      tunnel policy name     : --
      PW template name       : --
      primary or secondary   : primary
      load balance type      : flow                                                 
      Access-port            : false                                                
      Switchover Flag        : false                                                
      VC tunnel/token info   : 1 tunnels/tokens
        NO.0  TNL type       : lsp   , TNL ID : 0x10031
        Backup TNL type      : lsp   , TNL ID : 0x0
      create time            : 1 days, 22 hours, 15 minutes, 9 seconds
      up time                : 0 days, 22 hours, 54 minutes, 57 seconds
      last change time       : 0 days, 22 hours, 54 minutes, 57 seconds
      VC last up time        : 2013/09/05 19:26:37
      VC total up time       : 1 days, 20 hours, 42 minutes, 30 seconds
      CKey                   : 8
      NKey                   : 3
      PW redundancy mode     : --
      AdminPw interface      : --
      AdminPw link state     : --
      Diffserv Mode          : uniform                                              
      Service Class          : --                                                   
      Color                  : --                                                   
      DomainId               : --                                                   
      Domain Name            : --                                                   
    

    CE1和CE2能够相互Ping通。

    以CE1的显示为例:

    [CE1] ping 192.168.1.2
      PING 192.168.1.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.1.2: bytes=56 Sequence=1 ttl=255 time=31 ms
        Reply from 192.168.1.2: bytes=56 Sequence=2 ttl=255 time=10 ms
        Reply from 192.168.1.2: bytes=56 Sequence=3 ttl=255 time=5 ms
        Reply from 192.168.1.2: bytes=56 Sequence=4 ttl=255 time=2 ms
        Reply from 192.168.1.2: bytes=56 Sequence=5 ttl=255 time=28 ms
      --- 192.168.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 2/15/31 ms 

配置文件

  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 10 
    #
    return
  • CE2的配置文件

    #
    sysname CE2
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 20 
    #
    return
  • CSG的配置文件

    #
    sysname CSG
    #
    vlan batch 10 100
    #
    mpls lsr-id 1.1.1.9
    mpls
    #            
    mpls l2vpn   
    #
    mpls ldp
    #
    #
    mpls ldp remote-peer 4.4.4.9
     remote-ip 4.4.4.9
    #
    interface Vlanif10
     mpls l2vc 4.4.4.9 100
    # 
    interface Vlanif 100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 100 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 10 
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      network 1.1.1.9 255.255.255.255
      peer 2.2.2.9 enable
      peer 2.2.2.9 route-policy policy1 export
      peer 2.2.2.9 label-route-capability
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    return
  • AGG的配置文件

    #
    sysname AGG
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0000.0010.00
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 100 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk  
     port trunk allow-pass vlan 200 
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
      peer 1.1.1.9 route-policy policy1 export
      peer 1.1.1.9 reflect-client
      peer 1.1.1.9 next-hop-local
      peer 1.1.1.9 label-route-capability
      peer 3.3.3.9 enable
      peer 3.3.3.9 route-policy policy1 export
      peer 3.3.3.9 reflect-client
      peer 3.3.3.9 next-hop-local
      peer 3.3.3.9 label-route-capability
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    route-policy policy1 permit node 1
     if-match mpls-label
     apply mpls-label
    #
    return
  • Core_ABR的配置文件

    #
    sysname Core_ABR
    #
    vlan batch 200 300
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0000.0020.00
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 300 
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
     peer 4.4.4.9 as-number 100
     peer 4.4.4.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.9 enable
      peer 2.2.2.9 route-policy policy1 export
      peer 2.2.2.9 reflect-client
      peer 2.2.2.9 next-hop-local
      peer 2.2.2.9 label-route-capability
      peer 4.4.4.9 enable
      peer 4.4.4.9 route-policy policy1 export
      peer 4.4.4.9 reflect-client
      peer 4.4.4.9 next-hop-local
      peer 4.4.4.9 label-route-capability
    #
    ospf 2
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.3.1.0 0.0.0.255
    #
    route-policy policy1 permit node 1
     if-match mpls-label
     apply mpls-label
    #
    return
  • MASG的配置文件

    #
    sysname MASG
    #
    vlan batch 20 300
    #
    mpls lsr-id 4.4.4.9
    mpls
    # 
    mpls l2vpn 
    #
    mpls ldp
    #
    #
    mpls ldp remote-peer 1.1.1.9
     remote-ip 1.1.1.9
    #
    interface Vlanif20
     mpls l2vc 1.1.1.9 100
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk  
     port trunk allow-pass vlan 300 
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    bgp 100
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      network 4.4.4.9 255.255.255.255
      peer 3.3.3.9 enable
      peer 3.3.3.9 route-policy policy1 export
      peer 3.3.3.9 label-route-capability
    #
    ospf 2
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 172.3.1.0 0.0.0.255
    #
    route-policy policy1 permit node 1
     apply mpls-label
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8351

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页