所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置动态BFD for CR-LSP示例

配置动态BFD for CR-LSP示例

组网需求

图5-54为MPLS网络。要求从LSRA上建立一条TE隧道,目的地址为LSRC,并配置CR-LSP热备份(hot-standby)和逃生路径(best-effort)。其中:
  • 主CR-LSP的路径为LSRA→LSRB→LSRC;

  • 备份CR-LSP的路径为LSRA→LSRD→LSRC。

当主CR-LSP故障时,流量切换到备份CR-LSP;当主CR-LSP故障恢复,延时15秒后再进行流量回切。如果主、备CR-LSP都故障,触发建立逃生路径,使流量切换到逃生路径上。其中主、备CR-LSP都可以通过显式路径来指定,逃生路径由系统自动根据网络的故障情况来计算不需用户指定,本例中的结果为LSRA→LSRD→LSRB→LSRC。当故障节点不同时,逃生路径的结果也不一样。

现要求配置动态BFD for CR-LSP检测主、备CR-LSP,使得:

  • 主CR-LSP故障时,流量快速切换到备份CR-LSP。

  • 在主CR-LSP恢复后的延时回切时间(15秒)内,如果备份CR-LSP故障,可快速感知故障并将流量回切到主CR-LSP。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图5-54  配置动态BFD for CR-LSP组网图

说明:

相对静态BFD而言,动态BFD配置简单,且使用动态BFD可减少BFD会话数目,即可以减少网络上的BFD报文数,节约网络资源。因为使用动态BFD检测,同一时间内一个Tunnel接口只建立了一个BFD会话。

配置思路

采用如下思路配置动态BFD for CR-LSP:

  1. 配置CR-LSP热备份和逃生路径。

  2. 在入节点使能BFD,配置动态BFD for CR-LSP功能,指定本地发送BFD报文的时间间隔和允许接收BFD报文的时间间隔,以及BFD本地检测倍数。

  3. 在出节点使能被动创建BFD会话。

操作步骤

  1. 配置CR-LSP热备份和逃生路径

    配置CR-LSP热备份示例配置主、备CR-LSP和逃生路径。

  2. 在入节点配置动态BFD for CR-LSP

    在入节点配置动态BFD for CR-LSP功能,指定本地发送BFD报文的时间间隔和允许接收的时间间隔为500毫秒,BFD本地检测倍数为3。

    # 配置LSRA。

    [LSRA] bfd
    [LSRA-bfd] quit
    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] mpls te bfd enable
    [LSRA-Tunnel1] mpls te bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 3
    [LSRA-Tunnel1] mpls te commit

  3. 在出节点使能被动创建BFD会话

    # 配置LSRC。

    [LSRC] bfd
    [LSRC-bfd] mpls-passive
    [LSRC-bfd] quit

    完成以上配置后,在LSRA上执行命令display bfd session mpls-te interface Tunnel 1 te-lsp,可发现BFD会话状态为Up。

    [LSRA] display bfd session mpls-te interface Tunnel 1 te-lsp
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type        InterfaceName            
    --------------------------------------------------------------------------------
    8192  8192       3.3.3.9         Up        D_TE_LSP    Tunnel1              
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0                                         

    在LSRC上执行命令display bfd session passive-dynamic,可发现被动建立了一个BFD会话。

    [LSRC] display bfd session passive-dynamic
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type        InterfaceName            
    --------------------------------------------------------------------------------
    8192  8192       1.1.1.9         Up        E_Dynamic         -                  
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0                                         

  4. 检查配置结果

    将同一台测试仪的两个接口(Port1和Port2)分别接入LSRA和LSRC,从Port1向Port2打MPLS流(注意标签值的设置)。当拔出LSRA或LSRB上的GE1/0/0接口的线缆时,发现流量快速切换到备份CR-LSP,故障收敛时间为毫秒级。

    为了模拟在主CR-LSP恢复后的延时回切时间(15秒)内备份CR-LSP故障的场景,可以通过在插入拔出的GE1/0/0接口的线缆后,在LSRA重复执行display mpls te tunnel-interface tunnel 1命令查看隧道信息,直到发现主CR-LSP建立成功,然后在15秒内拔出LSRA或LSRD的GE2/0/0接口线缆来实现。此时可发现流量快速回切到主CR-LSP,故障收敛时间为毫秒级。

配置文件

  • LSRA的配置文件

    #
     sysname LSRA
    #
    vlan batch 100 500
    #
    bfd
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path backup-path
     next hop 172.5.1.2
     next hop 172.3.1.1
     next hop 3.3.3.9
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 3.3.3.9
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te                                                        
     destination 3.3.3.9                                                            
     mpls te tunnel-id 100                                                          
     mpls te bfd enable                                                             
     mpls te bfd min-tx-interval 500 min-rx-interval 500
     mpls te record-route                                                           
     mpls te path explicit-path pri-path                                            
     mpls te path explicit-path backup-path secondary                               
     mpls te backup hot-standby mode revertive wtr 15                               
     mpls te backup ordinary best-effort                                            
     mpls te commit
    #
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
  • LSRB的配置文件

    #
     sysname LSRB
    #
    vlan batch 100 200 400
    #
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
      network 172.4.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
     sysname LSRC
    #
    vlan batch 200 300
    #
    bfd
     mpls-passive
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.3.1.0 0.0.0.255                                                   
      mpls-te enable                                                                
    # 
    return
  • LSRD的配置文件

    #
     sysname LSRD
    #
    vlan batch 300 400 500
    #
    mpls lsr-id 4.4.4.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 4.4.4.9 0.0.0.0                                                       
      network 172.3.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      mpls-te enable                                                                
    # 
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8223

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页