所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-MPLS

本文档介绍了设备支持的MPLS相关配置。主要内容包括静态LSP的基本原理和配置过程、MPLS LDP的基本原理和配置过程、MPLS QoS的基本原理和配置过程、MPLS TE的基本原理和配置过程、MPLS OAM的基本原理和配置过程、Seamless MPLS的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MPLS TE隧道保护组示例

配置MPLS TE隧道保护组示例

组网需求

图5-51中,LSRA与LSRC之间建立了两条MPLS TE隧道。现要求为主隧道配置MPLS TE隧道保护组,采用MPLS TE自身机制来检测故障。

说明:

请确保该场景下互联接口的STP处于未使能状态。同时将互连接口退出VLAN1,避免形成环路。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图5-51  配置MPLS TE隧道保护组组网图

配置思路

采用如下思路配置MPLS TE隧道保护组:
  1. 配置各接口的IP地址,并使用OSPF协议实现各节点之间公网路由可达。
  2. 配置两条MPLS TE隧道,以便配置隧道保护组功能。
  3. 配置MPLS TE隧道保护组功能,为主隧道绑定保护隧道。

操作步骤

  1. 配置各接口的IP地址,并配置OSPF

    # 配置LSRA。按图5-51配置各设备的接口IP地址,其中LSRB、LSRC和LSRE的配置与LSRA类似,不再赘述。

    <Quidway> system-view
    [Quidway] sysname LSRA
    [LSRA] vlan batch 100 400
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 400
    [LSRA-Vlanif400] ip address 172.4.1.1 255.255.255.0
    [LSRA-Vlanif400] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 3/0/0
    [LSRA-GigabitEthernet3/0/0] port link-type trunk
    [LSRA-GigabitEthernet3/0/0] port trunk allow-pass vlan 400
    [LSRA-GigabitEthernet3/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.4.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    配置完成后,在各节点上执行display ip routing-table命令,应可以看到相互之间都学到了到对方Loopback1的路由。

  2. 配置MPLS基本能力,使能MPLS TE、RSVP-TE和CSPF

    # 配置LSRA。LSRB、LSRC和LSRE的配置与LSRA类似,不再赘述。其中,只需在主隧道的入节点上使能CSPF。

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 400
    [LSRA-Vlanif400] mpls
    [LSRA-Vlanif400] mpls te
    [LSRA-Vlanif400] mpls rsvp-te
    [LSRA-Vlanif400] quit
    

  3. 配置OSPF TE

    # 配置LSRA。LSRB、LSRC和LSRE的配置与LSRA类似,不再赘述。

    [LSRA] ospf
    [LSRA-ospf-1] opaque-capability enable
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  4. 在入节点LSRA上创建两条MPLS TE隧道

    # 配置显式路径。

    [LSRA] explicit-path pri-path
    [LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [LSRA-explicit-path-pri-path] next hop 3.3.3.9
    [LSRA-explicit-path-pri-path] quit
    [LSRA] explicit-path backup-path
    [LSRA-explicit-path-backup-path] next hop 172.4.1.2
    [LSRA-explicit-path-backup-path] next hop 172.5.1.2
    [LSRA-explicit-path-backup-path] next hop 3.3.3.9
    [LSRA-explicit-path-backup-path] quit
    

    # 配置MPLS TE隧道接口。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopBack 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 3.3.3.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te path explicit-path pri-path
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit
    [LSRA] interface tunnel 2
    [LSRA-Tunnel2] ip address unnumbered interface loopBack 1
    [LSRA-Tunnel2] tunnel-protocol mpls te
    [LSRA-Tunnel2] destination 3.3.3.9
    [LSRA-Tunnel2] mpls te tunnel-id 101
    [LSRA-Tunnel2] mpls te path explicit-path backup-path
    [LSRA-Tunnel2] mpls te commit
    [LSRA-Tunnel2] quit

    在LSRA上执行命令display interface tunnel查看隧道状态,可发现隧道状态为Up。

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-09-17 21:00:21                                
    Description:
    ...

  5. 配置MPLS TE隧道保护组

    # 在LSRA上配置Tunnel1作为主隧道,Tunnel2作为保护隧道,采用revertive模式,WTR为2分钟。

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] mpls te protection tunnel 101 mode revertive wtr 4
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit
    

  6. 检查配置结果

    完成上述配置之后,可以在LSRA上执行命令display mpls te protection tunnel 100 verbose,可查看隧道保护组的详细信息。

    [LSRA] display mpls te protection tunnel 100 verbose
    ----------------------------------------------------------------                
    Verbose information about the No.1 protection-group                             
    ----------------------------------------------------------------                
    Work-tunnel id                           : 100                                  
    Protect-tunnel id                        : 101                                  
    Work-tunnel name                         : Tunnel1                              
    Protect-tunnel name                      : Tunnel2                              
    Work-tunnel reverse-lsp                  : -                                    
    Protect-tunnel reverse-lsp               : -                                    
    Bridge type                              : 1:1                                  
    Switch type                              : unidirectional                       
    Switch result                            : work-tunnel                          
    Tunnel using Best-Effort                 : none                                 
    Tunnel using Ordinary                    : none                                 
    Work-tunnel frr in use                   : none                                 
    Work-tunnel defect state                 : non-defect                           
    Protect-tunnel defect state              : non-defect                           
    Work-tunnel forward-lsp defect state     : non-defect                           
    Protect-tunnel forward-lsp defect state  : non-defect                           
    Work-tunnel reverse-lsp defect state     : non-defect                           
    Protect-tunnel reverse-lsp defect state  : non-defect                           
    HoldOff config time                      : 0ms                                  
    HoldOff remain time                      : -                                    
    WTR config time                          : 120s                                 
    WTR remain time                          : -                                    
    Mode                                     : revertive                            
    Using same path                          : -                                    
    Local state                              : no request                           
    Far end request                          : no request                           

    在LSRA上执行命令tracert lsp te tunnel 1,查看流量经过主隧道的路径信息。

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to break.  
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.1.1.2/[4101 ]                  
      1     172.1.1.2          7 ms    Transit   172.2.1.2/[3 ]                     
      2     3.3.3.9            3 ms    Egress                                       

    在LSRA上执行命令display mpls te protection tunnel all,查看隧道保护组信息。

    [LSRA] display mpls te protection tunnel all
    ------------------------------------------------------------------------        
    No. Work-tunnel status  /id  Protect-tunnel status /id    Switch-Result         
    ------------------------------------------------------------------------        
    1          non-defect   /100        non-defect     /101     work-tunnel         
    

    # 在LSRA的GE1/0/0接口下执行命令shutdown,模拟主隧道故障。

    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] shutdown
    [LSRA-GigabitEthernet1/0/0] quit
    

    # 等待5秒之后,在LSRA上再次执行命令tracert lsp te tunnel 1,可以看到流量切换到保护隧道。

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to break. 
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.4.1.2/[1028 ]                  
      1     172.4.1.2          4 ms    Transit   172.5.1.2/[3 ]                     
      2     3.3.3.9            3 ms    Egress

    在LSRA上执行命令display mpls te protection tunnel all,查看隧道保护组信息。

    [LSRA] display mpls te protection tunnel all
    ------------------------------------------------------------------------        
    No. Work-tunnel status  /id  Protect-tunnel status /id    Switch-Result         
    ------------------------------------------------------------------------        
    1           in defect   /100        non-defect     /101  protect-tunnel         

配置文件

  • LSRA的配置文件

    #
    sysname LSRA
    #
    vlan batch 100 400
    #
    mpls lsr-id 1.1.1.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te                                                                   
     mpls te cspf 
    #
    explicit-path backup-path                                                       
     next hop 172.4.1.2                                                             
     next hop 172.5.1.2                                                             
     next hop 3.3.3.9
    #
    explicit-path pri-path                                                          
     next hop 172.1.1.2                                                             
     next hop 172.2.1.2                                                             
     next hop 3.3.3.9 
    #    
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #    
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 3.3.3.9                                                            
     mpls te tunnel-id 100                                                          
     mpls te protection tunnel 101 mode revertive wtr 4                             
     mpls te path explicit-path pri-path                                            
     mpls te commit
    #
    interface Tunnel2                                                               
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 3.3.3.9                                                            
     mpls te tunnel-id 101                                                          
     mpls te path explicit-path backup-path                                         
     mpls te commit 
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRB的配置文件

    #
    sysname LSRB
    #
    vlan batch 100 200
    # 
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
  • LSRC的配置文件

    #
    sysname LSRC
    #
    vlan batch 200 500
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
  • LSRE的配置文件

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0                                                       
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141521

浏览量:8318

下载量:343

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页