所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MQC实现流量监管示例

配置MQC实现流量监管示例

组网需求

Switch通过接口GE2/0/1与路由器互连,企业可经由Switch和路由器访问网络,如图4-10所示。

企业的语音业务对应的VLAN ID为120,视频业务对应的VLAN ID为110,数据业务对应的VLAN ID为100。

Switch上需要对不同业务的报文分别进行流量监管,以将流量限制在一个合理的范围之内,并保证各业务的带宽需求。

不同业务对于服务质量的需求不同,语音业务对服务质量要求最高,视频业务次之,数据业务要求最低,所以在Switch中还需要重标记不同业务报文的DSCP优先级,以便于路由器按照报文的不同优先级分别进行处理,保证各种业务的服务质量。

具体配置需求如表4-10所示。

表4-10  Switch为上行流量提供的QoS保障

流量类型

CIR(kbps)

PIR(kbps)

DSCP优先级

语音

2000

10000

46

视频

4000

10000

30

数据

4000

10000

14

图4-10  流量监管配置组网图

配置思路

采用如下的思路配置MQC实现流量监管:
  1. 创建VLAN,并配置各接口,使企业能够通过Switch访问网络。
  2. Switch上配置基于VLAN ID进行流分类的匹配规则。
  3. Switch上配置流行为,对来自企业的报文进行流量监管并且重标记报文的DSCP优先级。
  4. Switch上配置流量监管策略,绑定已配置的流行为和流分类,并应用到企业与Switch连接的接口上。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN 100、110、120。

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 100 110 120
    

    # 将接口GE1/0/1GE2/0/1的接入类型分别配置为trunk,并分别将接口GE1/0/1GE2/0/1加入VLAN 100、VLAN 110、VLAN 120。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet2/0/1] quit

  2. 配置流分类

    # 在Switch上创建流分类c1~c3,对来自企业的不同业务流按照其VLAN ID进行分类。

    [Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match vlan-id 120
    [Switch-classifier-c1] quit
    [Switch] traffic classifier c2 operator and
    [Switch-classifier-c2] if-match vlan-id 110
    [Switch-classifier-c2] quit
    [Switch] traffic classifier c3 operator and
    [Switch-classifier-c3] if-match vlan-id 100
    [Switch-classifier-c3] quit
    

  3. 配置流量监管行为

    # 在Switch上创建流行为b1~b3,对不同业务流进行流量监管以及重标记优先级。

    [Switch] traffic behavior b1
    [Switch-behavior-b1] car cir 2000 pir 10000 green pass
    [Switch-behavior-b1] remark dscp 46
    [Switch-behavior-b1] statistic enable
    [Switch-behavior-b1] quit
    [Switch] traffic behavior b2
    [Switch-behavior-b2] car cir 4000 pir 10000 green pass
    [Switch-behavior-b2] remark dscp 30
    [Switch-behavior-b2] statistic enable
    [Switch-behavior-b2] quit
    [Switch] traffic behavior b3
    [Switch-behavior-b3] car cir 4000 pir 10000 green pass
    [Switch-behavior-b3] remark dscp 14
    [Switch-behavior-b3] statistic enable
    [Switch-behavior-b3] quit
    

  4. 配置流量监管策略并应用到接口上

    # 在Switch上创建流策略p1,将流分类和对应的流行为进行绑定并将流策略应用到接口GE1/0/1入方向上,对来自企业的报文进行流量监管和重标记。

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] classifier c2 behavior b2
    [Switch-trafficpolicy-p1] classifier c3 behavior b3
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] quit
    

  5. 验证配置结果

    # 查看流分类的配置信息。

    [Switch] display traffic classifier user-defined
      User Defined Classifier Information:
       Classifier: c2
        Precedence: 10
        Operator: AND
        Rule(s) : if-match vlan-id 110
                 
       Classifier: c3
        Precedence: 15
        Operator: AND
        Rule(s) : if-match vlan-id 100
                 
       Classifier: c1
        Precedence: 5
        Operator: AND
        Rule(s) : if-match vlan-id 120
                 
    Total classifier number is 3 

    # 查看流策略的配置信息,以流策略p1为例。

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c1
        Operator: AND
         Behavior: b1
          Permit
          Committed Access Rate:
            CIR 2000 (Kbps), PIR 10000 (Kbps), CBS 250000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind
            Conform Action: pass
            Yellow  Action: pass
            Exceed  Action: discard
          Remark:
            Remark DSCP ef
          Statistic: enable
       Classifier: c2
        Operator: AND
         Behavior: b2
          Permit
          Committed Access Rate:
            CIR 4000 (Kbps), PIR 10000 (Kbps), CBS 500000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind
            Conform Action: pass
            Yellow  Action: pass
            Exceed  Action: discard
           Remark:                            
            Remark DSCP af33
          Statistic: enable 
       Classifier: c3
        Operator: AND
         Behavior: b3
          Permit
          Committed Access Rate:
            CIR 4000 (Kbps), PIR 10000 (Kbps), CBS 500000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind
            Conform Action: pass
            Yellow  Action: pass
            Exceed  Action: discard
          Remark:
            Remark DSCP af13
          Statistic: enable

    # 查看在接口上应用的流策略信息,以接口GE1/0/1为例。

    [Switch] display traffic policy statistics interface gigabitethernet 1/0/1 inbound
    
     Interface:  GigabitEthernet1/0/1
     Traffic policy inbound: p1
     Rule number: 3
     Current status: success
     Statistics interval: 300   
    ---------------------------------------------------------------------
     Board : 1
    ---------------------------------------------------------------------
     Matched          |      Packets:                             0   
                      |      Bytes:                               -        
                      |      Rate(pps):                           0        
                      |      Rate(bps):                           -          
    ---------------------------------------------------------------------   
       Passed         |      Packets:                             0        
                      |      Bytes:                               -         
                      |      Rate(pps):                           0           
                      |      Rate(bps):                           -            
    ---------------------------------------------------------------------         
       Dropped        |      Packets:                             0             
                      |      Bytes:                               -          
                      |      Rate(pps):                           0          
                      |      Rate(bps):                           -           
    ---------------------------------------------------------------------       
         Filter       |      Packets:                             0                   
                      |      Bytes:                               -                     
    ---------------------------------------------------------------------              
         Car          |      Packets:                             0                  
                      |      Bytes:                               -                  
    ---------------------------------------------------------------------             
    

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 100 110 120
    #
    traffic classifier c1 operator and precedence 5 
     if-match vlan-id 120
    traffic classifier c2 operator and precedence 10
     if-match vlan-id 110
    traffic classifier c3 operator and precedence 15
     if-match vlan-id 100
    #
    traffic behavior b1
     permit
     car cir 2000 pir 10000 cbs 250000 pbs 1250000 mode color-blind green pass yellow pass red discard
     remark dscp ef
     statistic enable
    traffic behavior b2
     permit
     car cir 4000 pir 10000 cbs 500000 pbs 1250000 mode color-blind green pass yellow pass red discard
     remark dscp af33
     statistic enable
    traffic behavior b3
     permit
     car cir 4000 pir 10000 cbs 500000 pbs 1250000 mode color-blind green pass yellow pass red discard
     remark dscp af13
     statistic enable
    #
    traffic policy p1 match-order config
     classifier c1 behavior b1
     classifier c2 behavior b2
     classifier c3 behavior b3
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 110 120
     traffic-policy p1 inbound
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 110 120
    #
    return
    
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141522

浏览量:4623

下载量:407

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页