所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置接口限速示例

配置接口限速示例

组网需求

图4-15所示,Switch通过接口GE2/0/1与路由器互连,企业部门1和企业部门2通过接口GE1/0/1和GE1/0/2接入Switch,经由Switch和路由器访问网络。

由于该网络只有数据业务流量,不需要对业务进行区分,但是网络带宽有限,因此需要对企业各个部门的接入带宽进行整体限制。要求企业部门1带宽限制为8Mbit/s,最高不超过10Mbit/s;企业部门2带宽限制为5Mbit/s,最高不超过8Mbit/s。

图4-15  接口限速配置组网图

配置思路

采用如下的思路配置接口限速:
  1. 创建VLAN,并配置各接口,使用户能够通过Switch访问网络。
  2. 创建不同的CAR模板并配置其中的CIR、PIR,在Switch接口GE1/0/1和GE1/0/2的入方向上分别应用CAR模板,实现对不同企业部门的限速功能。

操作步骤

  1. 创建VLAN并配置Switch各接口

    # 创建VLAN 100、200。

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 100 200
    

    # 配置接口GE1/0/1、GE1/0/2和GE2/0/1的接口类型为Trunk,并将GE1/0/1加入VLAN100,GE1/0/2加入VLAN200,GE2/0/1加入VLAN100和VLAN200。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 200
    [Switch-GigabitEthernet2/0/1] quit

  2. 配置CAR模板

    # 在Switch上创建CAR模板car1、car2,分别对企业部门1和企业部门2的流量进行限速。

    [Switch] qos car car1 cir 8192 pir 10240
    [Switch] qos car car2 cir 5120 pir 8192
    

  3. 应用CAR模板

    # 在Switch的接口GE1/0/1、GE1/0/2上的上行方向分别应用car1、car2,对企业部门1和企业部门2的流量进行限速。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] qos car inbound car1
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] qos car inbound car2
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] quit

  4. 验证配置结果

    # 查看CAR模板的配置信息。

    <Switch> display qos car all
      ----------------------------------------------------------------              
       CAR Name     : car1                                                           
       CAR Index    : 0                                                             
        car cir 8192 (Kbps) pir 10240 (Kbps) cbs 1024000 (byte) pbs 1280000 (byte)  
      ----------------------------------------------------------------              
       CAR Name     : car2                                                          
       CAR Index    : 1                                                             
        car cir 5120 (Kbps) pir 8192 (Kbps) cbs 640000 (byte) pbs 1024000 (byte)    

    # 分别使用6000kbps、9000kbps和11000kbps的速率向接口GE1/0/1和GE1/0/2输入报文流,然后使用命令display qos car statistics查看流量统计信息。如果配置成功:使用6000kbps向接口GE1/0/1和GE1/0/2输入报文流时,报文全部转发,无丢弃报文;使用9000kbps向接口GE1/0/1和GE1/0/2输入报文流时,接口GE1/0/1上的报文全部转发,接口GE1/0/2上的报文有部分丢弃;使用11000kbps向接口GE1/0/1和GE1/0/2输入报文流时,接口GE1/0/1上和GE1/0/2上的报文均有部分丢弃。

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 100 200
    #
    qos car car1 cir 8192 pir 10240 cbs 1024000 pbs 1280000
    qos car car2 cir 5120 pir 8192 cbs 640000 pbs 1024000
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
     qos car inbound car1
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
     qos car inbound car2
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
    
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141522

浏览量:4939

下载量:408

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页