所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置报文过滤示例

配置报文过滤示例

组网需求

图6-2所示,企业用户通过SwitchA的接口GE1/0/2连接到外部网络设备。

不同业务的报文在LSW侧使用802.1p优先级进行标识,当报文从接口GE1/0/2到达外部网络时,用户希望能够对数据业务报文进行过滤,优先保证语音和视频业务的业务体验。

图6-2  配置报文过滤组网图

配置思路

采用包含禁止动作的流策略方式实现报文过滤,具体配置思路如下:
  1. 配置各接口,实现企业用户能通过SwitchA访问外部网络。
  2. 配置流分类,实现基于802.1p优先级对报文进行分类。
  3. 配置流行为,实现对满足规则的报文进行禁止或允许动作。
  4. 配置流策略,绑定上述流分类和流行为,并应用到接口GE1/0/1的入方向,实现报文过滤。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN10。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit

    # 配置SwitchA上接口GE1/0/1GE1/0/2为Trunk类型接口,并加入VLAN10。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    说明:

    请配置LSW与SwitchA对接的接口为Trunk类型,并加入VLAN10。

    # 创建VLANIF10,并为VLANIF10配置IP地址192.168.2.1/24。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.2.1 24
    [SwitchA-Vlanif10] quit
    说明:

    请配置Router与SwitchA对接的接口IP地址为192.168.2.2/24。

  2. 配置流分类

    # 在SwitchA上创建并配置流分类c1、c2、c3,对报文按照802.1p优先级进行分类。

    [SwitchA] traffic classifier c1 operator and
    [SwitchA-classifier-c1] if-match 8021p 2
    [SwitchA-classifier-c1] quit
    [SwitchA] traffic classifier c2 operator and
    [SwitchA-classifier-c2] if-match 8021p 5
    [SwitchA-classifier-c2] quit
    [SwitchA] traffic classifier c3 operator and
    [SwitchA-classifier-c3] if-match 8021p 6
    [SwitchA-classifier-c3] quit
    

  3. 配置流行为

    # 在SwitchA上创建流行为b1,并配置禁止动作。

    [SwitchA] traffic behavior b1
    [SwitchA-behavior-b1] deny
    [SwitchA-behavior-b1] quit
    

    # 在SwitchA上创建流行为b2和b3,并配置允许动作。

    [SwitchA] traffic behavior b2
    [SwitchA-behavior-b2] permit
    [SwitchA-behavior-b2] quit
    [SwitchA] traffic behavior b3
    [SwitchA-behavior-b3] permit
    [SwitchA-behavior-b3] quit
    

  4. 配置流策略并应用到接口上

    # 在SwitchA上创建流策略p1,将流分类和对应的流行为进行绑定并将流策略应用到接口GE1/0/1的入方向上,对报文进行过滤。

    [SwitchA] traffic policy p1
    [SwitchA-trafficpolicy-p1] classifier c1 behavior b1
    [SwitchA-trafficpolicy-p1] classifier c2 behavior b2
    [SwitchA-trafficpolicy-p1] classifier c3 behavior b3
    [SwitchA-trafficpolicy-p1] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [SwitchA-GigabitEthernet1/0/1] quit
    

  5. 验证配置结果

    # 查看流分类的配置信息。

    [SwitchA] display traffic classifier user-defined
      User Defined Classifier Information:                                          
       Classifier: c2                                                               
        Precedence: 10
        Operator: AND                                                               
        Rule(s) : if-match 8021p 5                                                  
    
       Classifier: c3                                                               
        Precedence: 15
        Operator: AND                                                               
        Rule(s) : if-match 8021p 6                                                  
    
       Classifier: c1                                                               
        Precedence: 5
        Operator: AND                                                               
        Rule(s) : if-match 8021p 2    
       
    Total classifier number is 3                                               
    

    # 查看流策略的应用信息。

    [SwitchA] display traffic-policy applied-record p1
    -------------------------------------------------                               
      Policy Name:   p1                                                             
      Policy Index:  0                                                              
         Classifier:c1     Behavior:b1      
         Classifier:c2     Behavior:b2                                                  
         Classifier:c3     Behavior:b3                                              
    -------------------------------------------------                              
     *interface GigabitEthernet1/0/1                                                       
        traffic-policy p1 inbound                                                   
          slot 1    :  success                                                      
    -------------------------------------------------                               
      Policy total applied times: 1.                                                

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    traffic classifier c1 operator and precedence 5
     if-match 8021p 2
    traffic classifier c2 operator and precedence 10
     if-match 8021p 5
    traffic classifier c3 operator and precedence 15
     if-match 8021p 6
    #
    traffic behavior b1
     deny                                 
    traffic behavior b2
     permit
    traffic behavior b3
     permit
    #
    traffic policy p1 match-order config              
     classifier c1 behavior b1                                                      
     classifier c2 behavior b2                                                      
     classifier c3 behavior b3
    #
    interface Vlanif10                                                              
     ip address 192.168.2.1 255.255.255.0                                           
    #                                                                               
    interface GigabitEthernet1/0/1
     port link-type trunk                                                           
     port trunk allow-pass vlan 10                                                  
     traffic-policy p1 inbound                                                      
    #                                                                               
    interface GigabitEthernet1/0/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 10                                                  
    #
    return
    
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141522

浏览量:4649

下载量:407

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页