所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置流量统计示例

配置流量统计示例

组网需求

图8-2所示,PC1的MAC地址为0000-0000-0003,它连接在SwitchGE1/0/1端口上,实现与其他设备的互连互通。现希望Switch对源MAC为0000-0000-0003的报文进行流量统计。

图8-2  配置流量统计组网图

配置思路

采用包含流量统计动作的流策略方式实现流量统计,具体配置思路如下:
  1. 配置各接口,实现Switch与Router、PC1互通。
  2. 配置ACL规则,匹配源MAC为0000-0000-0003的报文。
  3. 配置流分类,实现基于上述ACL规则对报文进行分类。
  4. 配置流行为,实现对满足规则的报文进行流量统计。
  5. 配置流策略,绑定上述流分类和流行为,并应用到接口GE1/0/1的入方向,实现对该接口收到的源MAC为0000-0000-0003的报文进行流量统计。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN20。

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 20
    [Switch-vlan20] quit
    

    # 配置接口GE1/0/1为Access类型接口,接口GE1/0/2为Trunk类型接口,并将GE1/0/1GE1/0/2加入VLAN20。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 20
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet1/0/2] quit
    

    # 创建VLANIF20,并配置IP地址10.10.10.2/24。

    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.10.10.2 24
    [Switch-Vlanif20] quit
    
    说明:

    请配置Router与Switch对接的接口IP地址为10.10.10.1/24。

  2. 配置ACL规则

    # 在Switch上创建编码为4000的二层ACL,匹配源MAC为0000-0000-0003的报文。

    [Switch] acl 4000
    [Switch-acl-L2-4000] rule permit source-mac 0000-0000-0003 ffff-ffff-ffff
    [Switch-acl-L2-4000] quit
    

  3. 配置流分类

    # 在Switch上创建流分类c1,匹配规则为ACL 4000。

    [Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match acl 4000
    [Switch-classifier-c1] quit
    

  4. 配置流行为

    # 在Switch上创建流行为b1,并配置流量统计动作。

    [Switch] traffic behavior b1
    [Switch-behavior-b1] statistic enable
    [Switch-behavior-b1] quit
    

  5. 配置流策略并应用到接口上

    # 在Switch上创建流策略p1,将流分类和对应的流行为进行绑定。

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] quit
    

    # 将流策略p1应用到接口GE1/0/1

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] quit
    

  6. 验证配置结果

    # 查看ACL规则的配置信息。

    [Switch] display acl 4000
    L2 ACL 4000, 1 rule
    Acl's step is 5
     rule 5 permit source-mac 0000-0000-0003 
    

    # 查看流分类的配置信息。

    [Switch] display traffic classifier user-defined
      User Defined Classifier Information:                                          
       Classifier: c1                                                               
        Precedence: 5
        Operator: AND                                                                
        Rule(s) : if-match acl 4000  
    
    Total classifier number is 1  

    # 查看流策略的配置信息。

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:                                      
      Policy: p1                                                                    
       Classifier: c1                                                               
        Operator: AND                                                                
         Behavior: b1                                                               
          Permit
          Statistic: enable 
    

    # 查看流量统计信息。

    [Switch] display traffic policy statistics interface gigabitethernet 1/0/1 inbound
                                                                                    
     Interface: GigabitEthernet1/0/1                                                       
     Traffic policy inbound: p1                                                     
     Rule number: 1                                                                 
     Current status: success                                                            
     Statistics interval: 300                         
    ---------------------------------------------------------------------           
     Board : 1                           
    ---------------------------------------------------------------------       
     Matched          |      Packets:                             0                 
                      |      Bytes:                               0                 
                      |      Rate(pps):                           0                 
                      |      Rate(bps):                           0                 
    ---------------------------------------------------------------------           
       Passed         |      Packets:                             0                 
                      |      Bytes:                               0                 
                      |      Rate(pps):                           0                 
                      |      Rate(bps):                           0                 
    ---------------------------------------------------------------------           
       Dropped        |      Packets:                             0                 
                      |      Bytes:                               0                 
                      |      Rate(pps):                           0                 
                      |      Rate(bps):                           0                 
    ---------------------------------------------------------------------           
         Filter       |      Packets:                             0                 
                      |      Bytes:                               0                 
    ---------------------------------------------------------------------           
         Car          |      Packets:                             0                 
                      |      Bytes:                               0                 
    ---------------------------------------------------------------------
    

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 20
    #
    acl number 4000
     rule 5 permit source-mac 0000-0000-0003 
    #
    traffic classifier c1 operator and precedence 5 
     if-match acl 4000
    #
    traffic behavior b1
     permit
     statistic enable
    #
    traffic policy p1 match-order config
     classifier c1 behavior b1 
    #
    interface Vlanif20
     ip address 10.10.10.2 255.255.255.0
    #                                                                               
    interface GigabitEthernet1/0/1
     port link-type access                                                           
     port default vlan 20                                                   
     traffic-policy p1 inbound                                                      
    #                                                                               
    interface GigabitEthernet1/0/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 20                                                   
    #
    return
    
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141522

浏览量:4890

下载量:408

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页